Go Back   Thor Forums > Thor Brands and Products > Thor Motor Coach | Class A, Class B+ & Class C Motorhomes
Click Here to Login
Reply
 
Thread Tools Display Modes
 
Old 07-24-2017, 01:29 AM   #1
Senior Member
 
Ron1Z's Avatar
 
Brand: Thor Motor Coach
Model: Windsport 29m
State: Florida
Posts: 358
THOR #8069
No Signal from Cameras

Cameras all worked when I picked up new coach, on my way home from florida they worked sometimes, now they are not working at all, just says NO SIGNAL.
Any ideas where to look so I can make the repair myself??
__________________

__________________
Ron1Z is offline   Reply With Quote
Old 07-24-2017, 01:47 AM   #2
Senior Member
 
Brand: Thor Motor Coach
Model: 2015 Vegas 25.2
State: Oregon
Posts: 907
THOR #2271
It is a common problem for the camera input to the radio to not have been installed into the plug all the way. Pull the radio out the front. There should have been removal tools with your radio instructions. Make sure the three camera feeds are soundly seated in the back of the radio.
__________________

__________________
Added: HWH Kick-Down Leveler; RoadMaster Anti-sway bars; Tornado Rotary Tank Rinser; Accede Backup Sensor Kit; cylinder locks (w/one combo lock); custom sink cover; Kenwood DDX 5706S front radio; Pioneer MVH-X5560BT rear radio; Oxygenics Shower head; ScanGuage II; Blue Ox Tow Bar w/RVi Brake 2; Winegard Rayzar Automatic TV antenna; Trimark Steel door lock; Dometic 310 toilet; whatever is next.
gbrown is offline   Reply With Quote
Old 07-24-2017, 01:54 AM   #3
Senior Member
 
SuperD's Avatar
 
Brand: Thor Motor Coach
Model: 2017 Windsport 29M
State: Indiana
Posts: 3,648
THOR #5196
Quote:
Originally Posted by Ron1Z View Post
Cameras all worked when I picked up new coach, on my way home from florida they worked sometimes, now they are not working at all, just says NO SIGNAL.
Any ideas where to look so I can make the repair myself??
Take the top of the dash off and look down and probably to the right for a small silver box, this is the camera switch. Check connections on the switch, three camera inputs, one output, and a wiring harness for power and triggers. I kept getting intermittent camera signals on my coach, when I took it in for warranty the switch box was bad.

If you're under warranty go to the dealer, if not you can get a replacement from this company: https://www.rearviewsafety.com

Several of us have installed a 9" quad view monitor on the dash from the same company. Monitors from Amazon don't have the same camera connections, the monitor from Rear View Safety is basically plug and play with the exception of the wiring which is very simple.

Go to Modifications and updates, Jerry's Hurricane mods, last few pages but don't remember which one has tips on how to install if you want. Personally I think this is a great mod because I can actually see what's behind me now.

Click image for larger version

Name:	IMG_2087.jpg
Views:	88
Size:	119.7 KB
ID:	6025
__________________
USMC Veteran
FMCA 101070S

Dave & Myra
One day your life will flash before your eyes,
make sure it's worth watching!
SuperD is offline   Reply With Quote
Old 07-24-2017, 06:21 PM   #4
Member
 
Brand: Thor Motor Coach
Model: ACE 29.2
State: Texas
Posts: 61
THOR #1406
Ron,
Many times, I simply disconnect\connect the engine battery for about 15 minutes. This reboots\fixes many problems.
__________________
ThorRut is offline   Reply With Quote
Old 07-24-2017, 11:56 PM   #5
Senior Member
 
Ron1Z's Avatar
 
Brand: Thor Motor Coach
Model: Windsport 29m
State: Florida
Posts: 358
THOR #8069
You were correct SuperD, I found the camera box and tightened all connections and now everything works. I will keep an eye on it because it is scheduled to go back for warranty work in November.
__________________
Ron1Z is offline   Reply With Quote
Old 11-14-2019, 11:35 PM   #6
Junior Member
 
Brand: Thor Motor Coach
State: Nevada
Posts: 4
THOR #15961
Cameras were works and now says no signal.

I picked up my Thor Palazzo 2017 and noticed the cameras aren’t working and says no signal. How do I pull off the radio or fave plate to check the connections. I don’t see any screws to remove and I don’t want to just yank on it and break something. Does anyone know if it’s just attached with clips and will pull off?
__________________
Blackbeard11 is offline   Reply With Quote
Old 11-15-2019, 04:44 AM   #7
Senior Member
 
Brand: Thor Motor Coach
Model: 2015 Vegas 25.2
State: Oregon
Posts: 907
THOR #2271
There is a flat tool that fits in the sides of the radio to release it. If you don’t feel comfortable take it into a car audio shop and ask them to do it.
__________________
Added: HWH Kick-Down Leveler; RoadMaster Anti-sway bars; Tornado Rotary Tank Rinser; Accede Backup Sensor Kit; cylinder locks (w/one combo lock); custom sink cover; Kenwood DDX 5706S front radio; Pioneer MVH-X5560BT rear radio; Oxygenics Shower head; ScanGuage II; Blue Ox Tow Bar w/RVi Brake 2; Winegard Rayzar Automatic TV antenna; Trimark Steel door lock; Dometic 310 toilet; whatever is next.
gbrown is offline   Reply With Quote
Old 11-19-2019, 06:46 AM   #8
Junior Member
 
Brand: Thor Motor Coach
State: Nevada
Posts: 4
THOR #15961
Camera fixed

I got behind the dash and pushed all the connection together and cameras all work great again
__________________

__________________
Blackbeard11 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Thor Industries or any of its affiliates. This is an independent, unofficial site.




All times are GMT. The time now is 07:04 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0 PL2
×