Go Back   Thor Forums > Thor Tech Forums > Modifications and Updates
Click Here to Login
Reply
 
Thread Tools Display Modes
 
Old 10-30-2018, 06:21 PM   #1
Member
 
State: Alaska
Posts: 91
THOR #7980
Miramar 34.2 black tank vent

Today I replaced the black/grey tank vent with a camco turbo style. Very easy job BUT, there is absolutely no odor coming out, notta, zip, zilch and I stuck my nose into the pipe, yuck! NO smell and yes my toilet burps when full. I have pictures of the plumbing and it all looks serviceable is it probable the vent is plugged by "debris "?
__________________

__________________
ghof is offline   Reply With Quote
Old 10-31-2018, 09:24 AM   #2
Senior Member
 
Brand: Still Looking
State: Missouri
Posts: 399
THOR #5437
You may try running a water hose (low pressure) from the top of vent down. If there is a blockage that will take care of it. Years back I had that problem and the hose thing worked great.
__________________
S.O.B.
Retired and never looked back
be happy is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Thor Industries or any of its affiliates. This is an independent, unofficial site.




All times are GMT. The time now is 03:07 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0 PL2