Go Back   Thor Forums > Thor Tech Forums > Maintenance and Repair
Click Here to Login
Reply
 
Thread Tools Display Modes
 
Old 03-29-2019, 06:29 PM   #1
Junior Member
 
Brand: Thor Motor Coach
State: Illinois
Posts: 4
THOR #14859
2018 Thor Ace 30.3 water pump issue

Hi, new to this forum. Water pump worked until last stop. Now have an issue where when I turn on pump it runs, but doesn't pump any water. Cleaned out the filter on the inlet side (which was filled with shavings), but issue still exists. Any ideas on what to check?
__________________

__________________
gzenner is offline   Reply With Quote
Old 03-29-2019, 07:30 PM   #2
Senior Member
 
16ACE27's Avatar
 
Brand: Thor Motor Coach
Model: ACE 27.1
State: Florida
Posts: 2,890
THOR #7035
Does it ever stop running?
You sure you have water in the FW tank?
__________________

__________________
The USER Formally Known As TFryman
Ted & Melinda
2016 ACE 27.1
2016 Chevy Sonic Toad
16ACE27 is offline   Reply With Quote
Old 03-29-2019, 07:44 PM   #3
Senior Member
 
Brand: Thor Motor Coach
Model: 2013 ACE 30.1
State: Alberta
Posts: 921
THOR #2631
Welcome to the forum. Since the last thing you touched was the pump filter housing to clean it, you may have an air leak on the filter cap seal which prevents the pump from priming properly when it turns on. Also make sure all hose connections on the fresh water side of the pump are tight (on the filter etc.). Also it is not unusual to overtighten the filter ca and crack it....which also allows air into the system prime side.
__________________
javelin is offline   Reply With Quote
Old 03-30-2019, 02:15 PM   #4
Senior Member
 
Brand: Thor Motor Coach
Model: 2013 ACE 30.1
State: Alberta
Posts: 921
THOR #2631
One other item is that when you cleaned the pump filter you likely shut off the fresh water tank water line to the pump filter......did you open it back up again so water flows to the filter and pump? Sometimes the mini pex valves are out of sight and easy to forget about.
__________________
javelin is offline   Reply With Quote
Old 03-31-2019, 11:54 PM   #5
Junior Member
 
Brand: Thor Motor Coach
State: Illinois
Posts: 4
THOR #14859
Quote:
Originally Posted by javelin View Post
One other item is that when you cleaned the pump filter you likely shut off the fresh water tank water line to the pump filter......did you open it back up again so water flows to the filter and pump? Sometimes the mini pex valves are out of sight and easy to forget about.
Hi , sorry, my son and fiance joined me for a few days. Just getting back to this now. When I previously remove the water filter to clean it, did not have any flow on the inlet side. Checked again with same issue, and checked with valve in both positions. FW tank is 1/2 full. Pump just runs continuously with no water pressure. Something must be stopping flow from FW tank?
__________________
gzenner is offline   Reply With Quote
Old 04-01-2019, 12:56 AM   #6
Senior Member
 
Brand: Thor Motor Coach
Model: 2013 ACE 30.1
State: Alberta
Posts: 921
THOR #2631
Hi, so no water coming through the valve from the fresh water tank is why the pump is running continuously. You could try blowing air back up into the fresh water tank (short shots via lungs or low pressure air compressor) to try to break up the blockage. After each shot try to let any flow bring out the bits. Let any bits flow out on the ground if you can extend the water line out that far. It might be worth draining the tank through the blocked/reflowing line to try to ensure all pieces are removed if possible. Then reconnect to the pump filter; refill the FWT and try the pump again.
__________________
javelin is offline   Reply With Quote
Old 04-01-2019, 01:00 AM   #7
Junior Member
 
Brand: Thor Motor Coach
State: Illinois
Posts: 4
THOR #14859
Thanks Javelin. I have a compressor, so will try these ideas tomorrow morning. Thanks again!
__________________
gzenner is offline   Reply With Quote
Old 04-03-2019, 09:42 PM   #8
Junior Member
 
Brand: Thor Motor Coach
State: Illinois
Posts: 4
THOR #14859
Quote:
Originally Posted by gzenner View Post
Thanks Javelin. I have a compressor, so will try these ideas tomorrow morning. Thanks again!
Hi Javelin, All. This has turned out to be a pump issue. Originally was thinking a water flow blockage on the inlet side. I removed the tubing from the inlet side and using a compressor, blew water into the tank. Heard the gurgling sound from the fresh water tank. Drained and refilled FWT. Even after running pump, still no water to inlet side. Started to think, maybe a pump issue and its not pulling water through. Tried priming by mouth manually, still no water. Then used a vacuum to prime inlet side and got good water flow to the pump. Again tried pump, it ran, but no water coming from outlet side of pump. Since under warranty, will just take it to a dealer to get repaired/replaced.

Here is what I missed in the process: I thought gravity would naturally provide flowing water to the inlet side. Didn't realize there needed to be suction to get it flowing

Thanks Javelin for your input!!!
__________________
gzenner is offline   Reply With Quote
Old 04-03-2019, 11:35 PM   #9
Senior Member
 
Brand: Thor Motor Coach
Model: 2013 ACE 30.1
State: Alberta
Posts: 921
THOR #2631
Wow you tried everything except a divining rod to get water. Ha! In my coach the FWT is higher than the pump so gravity “helps” to fill the pump prime side, but anyone that draws pink plumbing antifreeze into their pump in Fall (from a bypass line stuck into a jug of pink on the ground) knows that the pump is self priming (if its working) and will pull liquid also (if no air leaks exist). The critical thing is no air should be drawn into the pump prime side. So if the pump filter or water line connections leak air not much if any water will go through the pump in my experience.


It sounded like you cleared your FWT blockage OK. If you have cleaned all bits from the pump filter and water lines between the FWT and pump/filter and all is leak free (no water leaking and no air getting in; feeder valves open).....that only leaves the pump. Perhaps some debris also got into the pump but hopefully the filter prevented that. This can be frustrating for sure and being under warrantee helps. Waiting in the Spring Dealer lineups might be equally frustrating sometimes though. Good luck.
__________________

__________________
javelin is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Thor Industries or any of its affiliates. This is an independent, unofficial site.




All times are GMT. The time now is 02:35 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0 PL2
×