Go Back   Thor Forums > Thor Tech Forums > Maintenance and Repair
Click Here to Login
Reply
 
Thread Tools Display Modes
 
Old 09-29-2017, 04:08 AM   #1
Senior Member
 
Brand: Thor Motor Coach
Model: ACE 30.3
State: Arkansas
Posts: 433
THOR #8012
ACE 30.3 - Pilot out light on - won't light LPG

Only had it a week. It was working on LPG (tested and dealer last week and once at home on Monday and both times it lit). I've had it parked at my house last couple days hooked to 15amp, so switched it to LPG.

Somewhere in last day or so, the pilot out light came on.

When I flip it to 110 off and LPG on and go outside, I can smell propane, so it's opening the valve.

I just went ahead and ordered a thermal cutoff kit and new electrode from Amazon as they were both pretty cheap.

RV is at my sisters (where I'll be parking it) so can't run out and test, but saw how they said to test the thermal cutoff (remove fuse and touch wire to see if it lights).

If it doesn't, is the igniter likely the issue? What else could it be and should I test?

Not close to a dealer and I'm going on a short trip in 10 days, so I would like to troubleshoot and repair myself.

P.S. I guess I forgot to bash Thor at the beginning of this post for an Atwood water heater failure....
__________________

__________________
tnedator is offline   Reply With Quote
Old 09-29-2017, 01:48 PM   #2
Senior Member
 
Brand: Thor Motor Coach
Model: 29h outlaw
State: New Jersey
Posts: 241
THOR #5248
Stupid question, but did they fill the propane? When low you will get the smell.
__________________

__________________
Trkyte@msn.com is offline   Reply With Quote
Old 09-29-2017, 01:50 PM   #3
Senior Member
 
Brand: Thor Motor Coach
Model: ACE 30.3
State: Arkansas
Posts: 433
THOR #8012
Tank is full and the fridge was still working on gas. I'll admit that I didn't try lighting a burner to make sure the gauge wasn't wrong, but both inside and outside gauges showed full and fridge didn't cut out.
__________________
tnedator is offline   Reply With Quote
Old 09-29-2017, 02:08 PM   #4
Senior Member
 
16ACE27's Avatar
 
Brand: Thor Motor Coach
Model: ACE 27.1
State: Florida
Posts: 3,104
THOR #7035
Does it work on electric?

You don't have a pilot light so what you are calling a "pilot light out" light is just a low temperature light as far as I understand it.

If you turn it on and don't hear the DSI lighter clicking it could be a control board problem or, as many have found, the contacts shorted by spider webs or other misc debris.
__________________
The USER Formally Known As TFryman
Ted & Melinda
2016 ACE 27.1
2016 Chevy Sonic Toad
16ACE27 is offline   Reply With Quote
Old 09-29-2017, 07:13 PM   #5
Senior Member
 
Brand: Thor Motor Coach
Model: ACE 30.3
State: Arkansas
Posts: 433
THOR #8012
Quote:
Originally Posted by Tfryman View Post
Does it work on electric?

You don't have a pilot light so what you are calling a "pilot light out" light is just a low temperature light as far as I understand it.

If you turn it on and don't hear the DSI lighter clicking it could be a control board problem or, as many have found, the contacts shorted by spider webs or other misc debris.
I know there isn't a pilot, I'm just using that term since that's what's on the control panel that Thor puts in shows pilot out, which I think is actually a generalized trouble (picture isn't from my ACE, but essentially the same but for tank heaters that the ACE doesn't have).



I'll admit that I didn't check the electric. It had worked for days, and it wasn't until I parked it at my house for a couple days to unload and was only hooked to a household outlet, that I switched fridge and hot water to gas. It initially was working, but I didn't notice until right before I drove it to my sisters to store.

In hind site, I should have turned on the electric with the generator on the drive over there. It's possible the whole thing is dead and electric no longer works. I plan to go over and trouble shoot more tomorrow.
__________________
tnedator is offline   Reply With Quote
Old 09-30-2017, 09:40 PM   #6
Senior Member
 
Brand: Thor Motor Coach
Model: ACE 30.3
State: Arkansas
Posts: 433
THOR #8012
Ok, went to my sisters to do some trouble shooting.

Electric does work. We opened up the panel behind the hot water heater to make sure all connections were tight and they were.

Outside, when turning to gas, you hear one click and smell gas. I assume that click is the gas valve opening, but not sure. I don't think it's the igniter. Am I correct that if the igniter was working correctly, it would spark repeatedly and you would hear more like click, click, click, click, click?

After 20-30 seconds, another click. Then a third. I assume that's it trying three times and then going into shutdown mode like a gas furnace at home.

All connections appear to be tight. I didn't actually test without the thermal cutoff (I should have), but there was no obvious signs that the wire was broken.

At this point, I think it's likely the igniter or the circuit board.

At least electric does work, as we are supposed to be going on a five night trip next week.
__________________

__________________
tnedator is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Thor Industries or any of its affiliates. This is an independent, unofficial site.




All times are GMT. The time now is 02:05 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0 PL2
×