Go Back   Thor Forums > Thor Tech Forums > Maintenance and Repair
Click Here to Login
Reply
 
Thread Tools Display Modes
 
Old 10-21-2017, 09:59 PM   #1
Junior Member
 
Brand: Thor Motor Coach
State: Nebraska
Posts: 2
THOR #9700
Axxera

Hello all, we have a 2017 Chateau with the Axxera radio. Recently, it will not power on at all which also means the back-up camera is unavailable. I have check all fuses on the coach and the chassis and canít find any that are bad. Suggestions?
__________________

__________________
Norlenfamily is offline   Reply With Quote
Old 10-22-2017, 01:44 AM   #2
Senior Member
 
State: Alaska
Posts: 243
THOR #8813
Quote:
Originally Posted by Norlenfamily View Post
Hello all, we have a 2017 Chateau with the Axxera radio. Recently, it will not power on at all which also means the back-up camera is unavailable. I have check all fuses on the coach and the chassis and canít find any that are bad. Suggestions?


Mine has a bad touch screen. Thor sent replacement.
__________________

__________________
carlgorski is offline   Reply With Quote
Old 10-22-2017, 02:35 AM   #3
Kev
Senior Member
 
Kev's Avatar
 
Brand: Thor Motor Coach
Model: Windsport
State: Florida
Posts: 738
THOR #3918
I just got a new one installed under warranty. It would not power up.
__________________
Kev is offline   Reply With Quote
Old 10-22-2017, 02:40 AM   #4
Senior Member
 
State: Alaska
Posts: 243
THOR #8813
Quote:
Originally Posted by Kev View Post
I just got a new one installed under warranty. It would not power up.


They are junk.
__________________
carlgorski is offline   Reply With Quote
Old 10-22-2017, 12:22 PM   #5
Senior Member
 
Brand: Thor Motor Coach
Model: 29h outlaw
State: New Jersey
Posts: 238
THOR #5248
Radio is powered by two 12v sources. One source is usually from the coach fuse center. The other is a keep alive signal, mine is a inline fuse wired off the use/store relay on the battery terminal side. You can find the relay by following the clicking noise when you operate the switch.
__________________
Trkyte@msn.com is offline   Reply With Quote
Old 10-22-2017, 01:19 PM   #6
Senior Member
 
16ACE27's Avatar
 
Brand: Thor Motor Coach
Model: ACE 27.1
State: Florida
Posts: 2,884
THOR #7035
Did you try using the reset procedure? I think you have to hold the reset button in for 15 seconds or more.
__________________
The USER Formally Known As TFryman
Ted & Melinda
2016 ACE 27.1
2016 Chevy Sonic Toad
16ACE27 is offline   Reply With Quote
Old 10-22-2017, 02:01 PM   #7
Senior Member
 
State: Alaska
Posts: 243
THOR #8813
Quote:
Originally Posted by Tfryman View Post
Did you try using the reset procedure? I think you have to hold the reset button in for 15 seconds or more.


Powered by coach not van body in my case. Must have 12V switch on
__________________
carlgorski is offline   Reply With Quote
Old 10-22-2017, 03:28 PM   #8
Senior Member
 
Brand: Thor Motor Coach
Model: Four Winds
State: Ontario
Posts: 247
THOR #9081
There is also a10 amp blade fuse on the back of the radio, believe it or not. You will need to take your dog house off to get to it. Mine went black during the PDI. The dealer checked the fuse, but it was ok. They had another radio, for another customer who was coming in the following week, therefore changed mine out with it. Since then has worked.
__________________
_____________________
2018 Four Winds 31Y
Peterrrr is offline   Reply With Quote
Old 10-22-2017, 03:34 PM   #9
Senior Member
 
State: Alaska
Posts: 243
THOR #8813
Quote:
Originally Posted by Peterrrr View Post
There is also a10 amp blade fuse on the back of the radio, believe it or not. You will need to take your dog house off to get to it. Mine went black during the PDI. The dealer checked the fuse, but it was ok. They had another radio, for another customer who was coming in the following week, therefore changed mine out with it. Since then has worked.


Quality stuff
__________________
carlgorski is offline   Reply With Quote
Old 10-22-2017, 04:27 PM   #10
vkb
Senior Member
 
vkb's Avatar
 
Brand: Thor Motor Coach
Model: Axis 24.1 KC's Big Box
State: Kansas
Posts: 1,993
THOR #3510
ALMOST 2 YEARS OF USE...AXXERA STILL DOING WELL ! all functions OK.
__________________
Ron & Kay n KC too !
2016 Axis 24.1 E-450 6 spd.
'KC's Big Box'
Jeep Wrangler TJ
or 6x10 enclosed motorcycle trailer
vkb is offline   Reply With Quote
Old 10-22-2017, 04:44 PM   #11
Junior Member
 
Brand: Thor Motor Coach
State: Florida
Posts: 2
THOR #9717
I just purchased my first Class C and we thought something was seriously wrong when the radio stayed on even though the ignition was off and key out. Once we realized that it's power source was from the coach/living area and not the truck we thought it was wired incorrectly.

Also, the screen flickers from bright to dark repeatedly and is very annoying. I've watched youtube videos, read the manual, and tinkered with the settings but no luck. The Axxera AVM70 seems to have a lot of good features and would be a great radio if I could just get it working correctly.
__________________
ShaunUCF is offline   Reply With Quote
Old 10-22-2017, 05:56 PM   #12
CSR
Member
 
Brand: Thor Motor Coach
Model: Aria 3901
State: Minnesota
Posts: 49
THOR #6177
Axxera Radio Replacement

Hi Norlenfamily,

Sorry to hear that your having trouble with your Axxera radio. We experienced the same issue with the Axxera radio in our previous RV (2017 Thor Axis). After having it looked at by a repair shop, we chose to replace it.

The radio would have been covered under warranty, but the service at the dealer we purchased the Axis from was so horrific, we felt it would be far less painful to buy and replace it ourselves.

I found a replacement on online at Crutchfield.com. We purchased a newer model and had it installed by a local RV repair shop.

Here's the link:
https://www.crutchfield.com/shopsearch/Axxera.html

Hope this helps.
__________________
CSR is offline   Reply With Quote
Old 10-22-2017, 11:36 PM   #13
Senior Member
 
Tearstone's Avatar
 
Brand: Thor Motor Coach
Model: 2017 Miramar 34.4
State: Florida
Posts: 284
THOR #9721
Yesterday, when I drove the RV across town, I wasn't listening to music so I didn't think anything of the Axxera being on or not. When I went to go back it into my driveway, I noticed that it didn't work. I spent a bit of time trying to figure out what was up with it and even checked the 5A fuse (#17) under the dash. It looked fine.

Puzzled, still I came back later and found that it was on.

It's back on now and I'm not sure if it was a fluke or what. Either way, mine is connected with a backup and turn signal cameras. Any recommended upgrades to replace it?
__________________
Tearstone is offline   Reply With Quote
Old 10-22-2017, 11:43 PM   #14
Member
 
italiavb's Avatar
 
Brand: Thor Motor Coach
Model: Miramar 35.2
State: Louisiana
Posts: 72
THOR #6291
I had that very problem. Turns out there is a small reset on the front of the unit. Take a paper clip and push it in the small hole on the lower left side. That will reset the unit.
__________________
2017 Miramar 35.2
2005 Mini Cooper S
Blue Ox tow system
italiavb is offline   Reply With Quote
Old 10-23-2017, 12:39 AM   #15
Senior Member
 
State: Alaska
Posts: 243
THOR #8813
Quote:
Originally Posted by CSR View Post
Hi Norlenfamily,



Sorry to hear that your having trouble with your Axxera radio. We experienced the same issue with the Axxera radio in our previous RV (2017 Thor Axis). After having it looked at by a repair shop, we chose to replace it.



The radio would have been covered under warranty, but the service at the dealer we purchased the Axis from was so horrific, we felt it would be far less painful to buy and replace it ourselves.



I found a replacement on online at Crutchfield.com. We purchased a newer model and had it installed by a local RV repair shop.



Here's the link:

https://www.crutchfield.com/shopsearch/Axxera.html



Hope this helps.


Another Axxera. I would of went JVC or Pipneer
__________________
carlgorski is offline   Reply With Quote
Old 10-23-2017, 12:41 AM   #16
Senior Member
 
Tearstone's Avatar
 
Brand: Thor Motor Coach
Model: 2017 Miramar 34.4
State: Florida
Posts: 284
THOR #9721
Quote:
Originally Posted by carlgorski View Post
Another Axxera. I would of went JVC or Pipneer
Does JVC or Pioneer support the rear and side marker cameras?

The more I think about, I'm betting that the system that manages those cameras are independent of the head unit itself. If that is the case, the any head unit that is "back up camera" ready should do the job, right?
__________________
Russ Sanderlin
USMC Veteran
2017 Miramar 34.4
RV Travel Bug
Tearstone is offline   Reply With Quote
Old 10-23-2017, 12:49 AM   #17
Senior Member
 
State: Alaska
Posts: 243
THOR #8813
Right. It is a switching box that provides output to unit. Hopefully yours will work good.
__________________
carlgorski is offline   Reply With Quote
Old 10-23-2017, 12:52 AM   #18
Senior Member
 
Tearstone's Avatar
 
Brand: Thor Motor Coach
Model: 2017 Miramar 34.4
State: Florida
Posts: 284
THOR #9721
Quote:
Originally Posted by carlgorski View Post
Right. It is a switching box that provides output to unit. Hopefully yours will work good.
Crossing my fingers and lots of prayer. Thank you
__________________
Russ Sanderlin
USMC Veteran
2017 Miramar 34.4
RV Travel Bug
Tearstone is offline   Reply With Quote
Old 10-23-2017, 12:54 AM   #19
Senior Member
 
State: Alaska
Posts: 243
THOR #8813
I really donít listen to radio much but I like video for mirrors and back up. I took out stock speakers and put JBLís in.
__________________
carlgorski is offline   Reply With Quote
Old 10-23-2017, 01:36 AM   #20
Senior Member
 
Tearstone's Avatar
 
Brand: Thor Motor Coach
Model: 2017 Miramar 34.4
State: Florida
Posts: 284
THOR #9721
I enjoy the sound of the engine.

Did you replace your outdoors speakers as well? I'm surprised those fair against the rain.
__________________

__________________
Russ Sanderlin
USMC Veteran
2017 Miramar 34.4
RV Travel Bug
Tearstone is offline   Reply With Quote
Reply

Tags
axis, axxera, radio

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Thor Industries or any of its affiliates. This is an independent, unofficial site.




All times are GMT. The time now is 10:57 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0 PL2
×