Go Back   Thor Forums > Thor Tech Forums > Maintenance and Repair
Click Here to Login
Reply
 
Thread Tools Display Modes
 
Old 10-09-2016, 08:28 PM   #1
Junior Member
 
Brand: Thor Motor Coach
State: Virginia
Posts: 2
THOR #5661
Axxera AV614BH Won't switch to mirrors

I have a 2015 Thor Ace Class A with the Axxera AV614BH radio. Until just last month on a trip when I used my turn signal or was backing up the display would automatically switch to the camera. All of a sudden without any incident it no longer will switch. I can select the camera on the touch screen and can get the camera image from both turn signals and back up camera. When driving it will not switch from the radio to camera. I have stuck my hand up there to see if I could feel and loose cables...no luck. Any suggestions? Is there any sort of fuse or something similar?
__________________

__________________
Thorlvr is offline   Reply With Quote
Old 10-09-2016, 09:55 PM   #2
Senior Member
 
EA37TS's Avatar
 
Brand: Entegra
Model: Entegra Accolade 37TS
State: Virginia
Posts: 3,574
THOR #1469
More than likely you have a camera controller which may have a loose trigger wire or the controller could may have gone bad.

Here is a link to the controller that is installed in my Challenger.

Voyager Multi-Camera Controller

If installed it will be listed on your build sheet from Thor.

Not sure about your model, but on my Challenger I remove 4 Phillips head screws and remove the top of the dash to get to the controller.

It is hard to see but in the attached photo the camera controller is the item with the white label at about 10 o-clock in the opening.

Click image for larger version

Name:	Dashboard.JPG
Views:	102
Size:	105.4 KB
ID:	3129
__________________

__________________
Dave
US Army (Ret)
2020 Entegra Accolade 37TS
2019 Jeep Grand Cherokee Trailhawk (Toad)
FMCA - F432054
EA37TS is offline   Reply With Quote
Old 10-09-2016, 10:47 PM   #3
Junior Member
 
Brand: Still Looking
State: Alabama
Posts: 2
THOR #5599
I also have the same issue. the turn signal cameras worked fine when I left the dealership but now they will only come on when I hold the mode button,
__________________
olkowski1 is offline   Reply With Quote
Old 10-10-2016, 01:56 AM   #4
Senior Member
 
djnash's Avatar
 
Brand: Thor Motor Coach
Model: Hurricane 35C
State: Florida
Posts: 110
THOR #4067
Try resetting the radio. The reset button is just abobe the usb on the lower left of the radio. Worked for me
__________________
djnash is offline   Reply With Quote
Old 10-10-2016, 08:58 PM   #5
Junior Member
 
Brand: Thor Motor Coach
State: Virginia
Posts: 2
THOR #5661
Dave, Thx for the info. I see you are in Chester...not far from Sandston. Who do you use when you take your RV in for service? I have only had my ACE for about 6 mo. It is my first, so I am definitely learning alot.
Thanks again,
Sandi
__________________
Thorlvr is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Thor Industries or any of its affiliates. This is an independent, unofficial site.




All times are GMT. The time now is 05:22 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0 PL2
×