Go Back   Thor Forums > Thor Tech Forums > Maintenance and Repair
Click Here to Login
Reply
 
Thread Tools Display Modes
 
Old 12-14-2018, 05:33 PM   #1
Junior Member
 
Brand: Thor Motor Coach
Model: Axis 24.1
State: Kentucky
Posts: 21
THOR #9694
Axxera Radio Problem

Our Axxera radio is burning up speakers. We were driving with our rear camera on and the radio in Aux In mode, when we smelled electrical burning. Then we heard popping from the passenger side speaker. The speaker was blown. I replaced it at home and everything seemed good while plugged into shore power.

Our next trip the same thing happened, now both speakers are blown. All the functions of radio and cameras are working fine. Any advice.

Axxera AV615BHM
2017 Axis 24.1

Thanks, Ron
__________________

__________________
rswoodson is offline   Reply With Quote
Old 12-14-2018, 06:25 PM   #2
Senior Member
 
Brand: Thor Motor Coach
State: Massachusetts
Posts: 338
THOR #12830
I hate my radio. Told the cheapest out there. I called axxera to upgrade and the best radio was like $140. Ordering a Kenwood.
__________________
Yaktop is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Thor Industries or any of its affiliates. This is an independent, unofficial site.




All times are GMT. The time now is 09:17 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0 PL2
×