Go Back   Thor Forums > Thor Tech Forums > Maintenance and Repair
Click Here to Login
Reply
 
Thread Tools Display Modes
 
Old 08-14-2016, 12:19 AM   #1
Junior Member
 
Brand: Thor Motor Coach
State: Virginia
Posts: 14
THOR #2640
backup camera Jensen radio

I have a 2013 Thor Palazzo 33.3. My rear backup camera has stopped working. The only indication I get is "no input" on the screen. Both of the side cameras work just fine. I have checked all connections and they seem to be fine.
__________________

__________________
1930fordcoupe is offline   Reply With Quote
Old 08-14-2016, 08:53 PM   #2
Axis/Vegas Enthusiast
 
JamieGeek's Avatar
 
Brand: Thor Motor Coach
Model: Axis 24.1
State: Michigan
Posts: 8,134
THOR #1150
Its possible the plugs wiggled out behind the radio.

Mine go out with the roughness of the road (Jensen radio 215) but so far they have always managed to come back on.
__________________
2014 Thor Axis 24.1
2018 Chevy Bolt
blog - https://spareelectrons.wordpress.com/
JamieGeek is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Thor Industries or any of its affiliates. This is an independent, unofficial site.




All times are GMT. The time now is 08:18 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0 PL2
×