Go Back   Thor Forums > Thor Tech Forums > Maintenance and Repair
Click Here to Login
Reply
 
Thread Tools Display Modes
 
Old 09-13-2017, 03:09 PM   #1
Junior Member
 
Brand: Thor Motor Coach
State: Oregon
Posts: 10
THOR #9173
Battery disconnect

battery disconnect switch is not working 2011 class c Thor 28 u. I checked the switch with meter replaced solenoid cleaned all battery terminals. tried by passing the solenoid still nothing. it seems i am not getting power from the cable from the battery to the solenoid when checked with meter. Is there a relay or something I donot no about? Or any other suggestion
will is online now Report Post
__________________

__________________
will is offline   Reply With Quote
Old 09-13-2017, 07:45 PM   #2
Senior Member
 
Brand: Thor Motor Coach
Model: Windsport 27K
State: Florida
Posts: 139
THOR #2154
Hi Will,

Please don't post the same message in multiple threads; users on the forum usually look for "new posts" and contribute when they can.

Not sure if you were referring to a physical disconnect switch near the battery, or the "Use/Store" switch. In any case, there is usually a high amperage fuse or circuit breaker located near the battery. If it's a circuit breaker, there is often a yellow or white lever that drops to show the breaker needs to be reset, and you just push it back up into place to reset it.

If it's a fuse then a meter is helpful to show whether there is voltage on both sides of the fuse holder.

Not familiar with your RV model so I can't be specific.
__________________

__________________
Tom N3EQF is offline   Reply With Quote
Old 09-14-2017, 07:19 PM   #3
Senior Member
 
Yvonnemarc's Avatar
 
Brand: Thor Motor Coach
Model: ACE 30.2
State: Massachusetts
Posts: 238
THOR #8180
Should look something like this.
Attached Images
 
__________________
USN - RETIRED NUKE
Taunton, MA
Yvonnemarc is offline   Reply With Quote
Old 09-14-2017, 08:05 PM   #4
Junior Member
 
Brand: Thor Motor Coach
Model: Outlaw 35SG
State: Texas
Posts: 6
THOR #1655
I had something similar happen. The fix for me was the fuses (car type 35amp) at the inverter.
__________________
OutlawDriver is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Thor Industries or any of its affiliates. This is an independent, unofficial site.




All times are GMT. The time now is 12:56 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0 PL2