Go Back   Thor Forums > Thor Tech Forums > Maintenance and Repair
Click Here to Login
Reply
 
Thread Tools Display Modes
 
Old 05-21-2018, 03:09 AM   #1
Member
 
Brand: Thor Motor Coach
Model: Ace 30.4
State: Louisiana
Posts: 41
THOR #9620
Flickering rear camera

The camera on my Thor Ace has been flickering and progressively getting worse. Found the entire console holding the radio, a/c controls and power outlets can be easily removed. It is secured with two small nuts at the lower part of the console on either side of the power outlets. There are actually six screws, but only two have nuts on the end. After nut removal console can be pulled outward and up. I was able to remove with a nutdriver without taking off doghouse. The RCA cable, was barely connected to a grey box which I think is referred to as the trigger switch. Seems to be fixed now. I used the Thor zip tie method to keep RCA plug secured, lol. Just posting as a reference Incase someone has same issue. The radio itself seems to have a different system than the C wire tool others have mentioned.
__________________

__________________
Zeagle63 is offline   Reply With Quote
Old 05-21-2018, 12:02 PM   #2
Senior Member
 
bruno1950's Avatar
 
Brand: Thor Motor Coach
Model: A.C.E. 30.2
State: Ohio
Posts: 103
THOR #8054
Having the same issue. Thanks for posting. Ill be working on that today. I feel like Ive become a full time RV mechanic since I retired. Thanks again.
__________________

__________________
bruno1950 is offline   Reply With Quote
Old 05-21-2018, 02:50 PM   #3
Member
 
Brand: Thor Motor Coach
Model: Challenger LX
State: Texas
Posts: 94
THOR #6651
We just got back from a six week trip out west in our 2017 Challenger LX. About half way into the trip, my rear view camera started flickering and eventually went out completely. The side view cameras were not affected.

I suspected a loose connection to the Axxera unit, so I pulled the unit out of the dash but found no issues. I then removed the panel on the rear of the coach holding the rear view camera. I thought that maybe there was a loose connection there. The wire to the camera was hard wired (not plugged in) but after removing the panel, it started working again. I reassembled it and it worked fine for about a half day of driving, but then went out again. I think the problem is obviously at the camera (either the camera itself or the hardwired connection), but Im unsure of what I need to do now. Any suggestions?
__________________
TxTig is offline   Reply With Quote
Reply

Tags
flickering camera

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Thor Industries or any of its affiliates. This is an independent, unofficial site.




All times are GMT. The time now is 07:22 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0 PL2