Go Back   Thor Forums > Thor Tech Forums > Maintenance and Repair
Click Here to Login
Reply
 
Thread Tools Display Modes
 
Old 10-30-2018, 12:10 AM   #1
Junior Member
 
Brand: Thor Motor Coach
State: Alberta
Posts: 3
THOR #12094
Guage issue

We had our gauges act up on our trip home last spring on our 2014 palazzo 36.1. Initially the fuel gauge dropped and stayed off. 30 minutes later the oil pressure dropped and came back up. Later the same day the air pressure started dropping and quickly coming up.This continued for 4 days. Obviously there was a bad connection. Our trip was 4 days back to Canada where I booked the RV in for repair. On the morning of the appointment all gauges worked normally and have ever since. I canceled the appointment. I am expecting a repeat performance at some point but have traveled 5000 miles with everything working fine. Anyone have a similar experience?
__________________

__________________
Maurice G is offline   Reply With Quote
Old 10-30-2018, 02:26 PM   #2
Senior Member
 
Cason61's Avatar
 
Brand: Thor Motor Coach
Model: 34F
State: Oklahoma
Posts: 628
THOR #8432
Quote:
Originally Posted by Maurice G View Post
We had our gauges act up on our trip home last spring on our 2014 palazzo 36.1. Initially the fuel gauge dropped and stayed off. 30 minutes later the oil pressure dropped and came back up. Later the same day the air pressure started dropping and quickly coming up.This continued for 4 days. Obviously there was a bad connection. Our trip was 4 days back to Canada where I booked the RV in for repair. On the morning of the appointment all gauges worked normally and have ever since. I canceled the appointment. I am expecting a repeat performance at some point but have traveled 5000 miles with everything working fine. Anyone have a similar experience?
Yeah, long time ago, when I owned a truck, the Oil pressure gauge started acting intermittent, so I had the pressure checked with a good tester and it was good. Ok replaced the gauge and 800 miles into a 1000 mile trip the gauge died. The engine kept running, the temp didn't rise, nothing else happened, so I finished the trip and replaced the bad gauge, tightened the nut to the wire and it was good. Had another time when I started my car at night and the lights came on, everything worked, but the gauges had no lights. Found out that the battery needed another ground from the post to the frame. The negative post to the engine was not good enough. Had another time on my motorcycle when it just stopped, no power at all. 30 minutes of checking and the negative wire to the frame somehow got loose. Scratched the paint off, tightened the screw and it started and ran. So I learned that if your battery is good, check the posts for connection, then all the grounds, then for loose wires, or wires that are not crimped to the clamp, then the fuses. Sometimes turning a switch off, turns other things off as well.
__________________

__________________
Cason61 is offline   Reply With Quote
Old 10-30-2018, 03:20 PM   #3
Senior Member
 
Brand: Thor Motor Coach
Model: Four Winds
State: Ontario
Posts: 247
THOR #9081
I had a 2014 Palazzo before and also had problems with intermittent loss of all gauges. It is a common, irritating, intermittent problem. When you have some spare time take a read of this thread over at IRV2. Several different variations. Loose grounds or relays. And no that was not my reason for changing coaches.
Power off while driving, Event 5 - iRV2 Forums
__________________
_____________________
2018 Four Winds 31Y
Peterrrr is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Thor Industries or any of its affiliates. This is an independent, unofficial site.




All times are GMT. The time now is 03:45 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0 PL2
×