Go Back   Thor Forums > Thor Tech Forums > Maintenance and Repair
Click Here to Login
Reply
 
Thread Tools Display Modes
 
Old 05-28-2017, 12:40 PM   #1
Junior Member
 
Brand: Thor Motor Coach
State: Pennsylvania
Posts: 17
THOR #7047
House batteries not charging.

On my 17 axis the house batteries are not accepting a charge from shore power. The blue light on the 30a furrion recepticle is very dim when connected too which strikes me as odd.
I have a in line surge suppressor that indicates all is good from the outlet.
I checked the cutoff switches by the left house battery, it wasn't tripped. I checked all the fuses and toggled all the breakers in the hallway breaker box and all the fuses in the BIRD box under the driver seat.
The RV has power when connected to shore power but the batteries won't charge.
Oddly I know when I bought it the dealer said the battery cutoff was bad and they replaced it before we took delivery. Everything did work properly when we did the PDI.
What am I missing on my diagnostics? L
__________________

__________________
chimez78 is offline   Reply With Quote
Old 05-28-2017, 02:54 PM   #2
Senior Member
 
Brand: Thor Motor Coach
Model: '17 Axis 24.1
State: Texas
Posts: 164
THOR #6523
We had defective house batteries in our new '17 Axis that wouldn't hold a charge, but didn't discover until we had it in storage plugged in to shore power. Called Thor and they will replace with same cheap batteries or reimburse $90 per battery and we could buy what we wanted. We replaced with Interstate AGM batteries.
__________________

__________________
TexAxis is offline   Reply With Quote
Old 05-28-2017, 02:56 PM   #3
Axis/Vegas Enthusiast
 
JamieGeek's Avatar
 
Brand: Thor Motor Coach
Model: Axis 24.1
State: Michigan
Posts: 8,125
THOR #1150
Did you check the voltage at the battery? 13+ Volts indicates its a battery issue and not the coach (e.g. the converter is supplying enough volt/current to charge the battery thus problem is the battery).
__________________
2014 Thor Axis 24.1
2018 Chevy Bolt
blog - https://spareelectrons.wordpress.com/
JamieGeek is offline   Reply With Quote
Old 05-28-2017, 11:54 PM   #4
Junior Member
 
Brand: Thor Motor Coach
State: Pennsylvania
Posts: 17
THOR #7047
It turned out to be a sutck relay. After starting the RV, and powering on the generator, along with probing a ton of outlets and checking the GFI in the bathroom, I heard the relay click and the situation seems to be now resolved.

Thank you for your input.
__________________
chimez78 is offline   Reply With Quote
Old 05-29-2017, 01:43 AM   #5
Senior Member
 
Mo_Mike's Avatar
 
Brand: Thor Motor Coach
Model: Vegas 25.2
State: Missouri
Posts: 900
THOR #4687
We discovered on our 2016 VEGAS that we need to disconnect shore power BEFORE we start the engine. If we don't and start the engine with shore power connected, the chassis battery doesn't charge. Doesn't make a lot of sense, but have learned to live with it.
__________________
Mo_Mike is offline   Reply With Quote
Old 05-29-2017, 01:45 AM   #6
Senior Member
 
Mo_Mike's Avatar
 
Brand: Thor Motor Coach
Model: Vegas 25.2
State: Missouri
Posts: 900
THOR #4687
Oops, sorry just reread your post that you were talking about HOUSE batteries. Sorry...
__________________

__________________
Mo_Mike is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Thor Industries or any of its affiliates. This is an independent, unofficial site.




All times are GMT. The time now is 07:04 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0 PL2
×