Go Back   Thor Forums > Thor Tech Forums > Maintenance and Repair
Click Here to Login
Reply
 
Thread Tools Display Modes
 
Old 06-13-2018, 09:49 AM   #1
Member
 
Brand: Thor Motor Coach
State: Massachusetts
Posts: 36
THOR #11935
house batteries not charging when engine running

i have a 2016 mirimar 35.2 i can hear solenoid click when i hit store/use button but when i start rv engine battery on inverter inly shows 12v any clues?
__________________

__________________
jplacz2000 is offline   Reply With Quote
Old 06-13-2018, 09:56 AM   #2
Senior Member
 
Brand: Thor Motor Coach
Model: ACE 29.3
State: Missouri
Posts: 383
THOR #5437
I could be wrong on this, but, I beleive the engine will only charge the engine battery. To charge the house batteries you will need to plug into shore power or use generator.
__________________

__________________
2017 ACE 29.3
Retired and never looked back
be happy is offline   Reply With Quote
Old 06-13-2018, 10:25 AM   #3
Member
 
Brand: Thor Motor Coach
State: Massachusetts
Posts: 36
THOR #11935
Teply

Quote:
Originally Posted by be happy View Post
I could be wrong on this, but, I beleive the engine will only charge the engine battery. To charge the house batteries you will need to plug into shore power or use generator.
It did when I first bought the United something went would say 14.2 in inverter gauge weired
__________________
jplacz2000 is offline   Reply With Quote
Old 06-13-2018, 10:57 AM   #4
Senior Member
 
16ACE27's Avatar
 
Brand: Thor Motor Coach
Model: ACE 27.1
State: Florida
Posts: 2,501
THOR #7035
It is supposed to charge the house batteries as well. Perhaps the cross-connect relay has failed?
__________________
The USER Formally Known As TFryman
Ted & Melinda
2016 ACE 27.1
2016 Chevy Sonic Toad
16ACE27 is offline   Reply With Quote
Old 06-13-2018, 11:07 AM   #5
Member
 
Brand: Thor Motor Coach
State: Massachusetts
Posts: 36
THOR #11935
Reply

Quote:
Originally Posted by Tfryman View Post
It is supposed to charge the house batteries as well. Perhaps the cross-connect relay has failed?
Itís under bed I believe I will jump it today and see if that works
__________________
jplacz2000 is offline   Reply With Quote
Old 06-13-2018, 11:52 AM   #6
I Think We're Lost!
 
Bob Denman's Avatar
 
Brand: Still Looking
Model: Tiffin Wayfarer 24 BW
State: New York
Posts: 9,824
THOR #8860
Please let us know what you find, and good luck!
__________________
Good Sam Member 843599689
FMCA Member F473304

Current coach: Tiffin Wayfarer 24 BW
Former coach: Thor Outlaw 29-H
Bob Denman is offline   Reply With Quote
Old 06-13-2018, 03:14 PM   #7
Senior Member
 
Brand: Thor Motor Coach
Model: 2013 31L
State: Florida
Posts: 1,815
THOR #908
I found that the solenoid was bad on mine when I discovered the same issue. Not the BIRD controller, but the contactor.
On mine, and as I understand a lot of others, this is under the hood. Mine is near/under the brake master cylinder back on the fire wall/fender area..
The contractor under the beds is the use/store one I think, not the BIRD
__________________
blw2 is offline   Reply With Quote
Old 06-13-2018, 03:20 PM   #8
Senior Member
 
Brand: Thor Motor Coach
Model: 2013 31L
State: Florida
Posts: 1,815
THOR #908
can't find a photo of mine...but here is the manual for my BIRD controller. yours may be a different brand or model, but should be roughly the same I would guess...

In the schematic, it's the "isolator relay" that was bad on mine. It was very rusty....

This controller was mounted right next to this contactor.
Attached Files
File Type: pdf Alternator Charge House Battery BIRD.pdf (101.2 KB, 74 views)
__________________
blw2 is offline   Reply With Quote
Old 06-13-2018, 03:22 PM   #9
Senior Member
 
Brand: Thor Motor Coach
Model: 2013 31L
State: Florida
Posts: 1,815
THOR #908
one more thing... you mentioned hearing the click. That's the wrong one.

This is the one you would hear when you press the emergency start switch
__________________
blw2 is offline   Reply With Quote
Old 06-13-2018, 03:25 PM   #10
Senior Member
 
Brand: Thor Motor Coach
Model: Four Winds 22E
State: Illinois
Posts: 117
THOR #10965
Just went through this - three things to check but from my understanding the solenoid is usually a problem.

Once you find the solenoid and BIRD, track the wires and check for some fuses. There should be two of them. Make sure those are good.

Second test the solenoid. What worked for me was pressing the boost button while the engine was running. When the old solenoid was on there, no change in house battery voltage (even though it clicked). Put new solenoid on and when the button was engaged the house battery would charge.

Final piece is the BIRD .. basically tells everything to start charging bases on battery levels and a delay after starting the engine. I ordered this part, but found the fuses as I was getting ready to change it and had a blown fuse.
__________________
FMCA Member F484487
Bogie is offline   Reply With Quote
Old 06-14-2018, 09:47 AM   #11
Member
 
Brand: Thor Motor Coach
State: Massachusetts
Posts: 36
THOR #11935
post reply

i checked it last night found the relay for store/use if stuck cant turn power off or on wiered i ordred new one online
__________________
jplacz2000 is offline   Reply With Quote
Old 06-14-2018, 11:51 AM   #12
I Think We're Lost!
 
Bob Denman's Avatar
 
Brand: Still Looking
Model: Tiffin Wayfarer 24 BW
State: New York
Posts: 9,824
THOR #8860
I hope that replacing it; does the trick for you!
__________________
Good Sam Member 843599689
FMCA Member F473304

Current coach: Tiffin Wayfarer 24 BW
Former coach: Thor Outlaw 29-H
Bob Denman is offline   Reply With Quote
Old 06-21-2018, 11:14 PM   #13
Member
 
Brand: Thor Motor Coach
State: Massachusetts
Posts: 36
THOR #11935
Installed new solenoid

Weíll I installed new solenoid today same thing when I hit switch to store /use it clicks but lights stay on no matter what not sure now
__________________
jplacz2000 is offline   Reply With Quote
Old 06-22-2018, 12:15 AM   #14
Senior Member
 
16ACE27's Avatar
 
Brand: Thor Motor Coach
Model: ACE 27.1
State: Florida
Posts: 2,501
THOR #7035
Quote:
Originally Posted by jplacz2000 View Post
Weíll I installed new solenoid today same thing when I hit switch to store /use it clicks but lights stay on no matter what not sure now
Are you plugged into Shore Power? The converter will supply the DC buss even when in STORE.
__________________
The USER Formally Known As TFryman
Ted & Melinda
2016 ACE 27.1
2016 Chevy Sonic Toad
16ACE27 is offline   Reply With Quote
Old 06-22-2018, 12:49 AM   #15
Member
 
Brand: Thor Motor Coach
State: Massachusetts
Posts: 36
THOR #11935
Reply

No unplugged it used to work properly then something went wrong
__________________
jplacz2000 is offline   Reply With Quote
Old 06-22-2018, 12:56 AM   #16
Member
 
Brand: Thor Motor Coach
State: Massachusetts
Posts: 36
THOR #11935
Reply

Even when I turn converter off when I hit switch lights flicker but donít turn off into store mode maybee bad switch?
__________________
jplacz2000 is offline   Reply With Quote
Old 06-22-2018, 01:08 AM   #17
Senior Member
 
16ACE27's Avatar
 
Brand: Thor Motor Coach
Model: ACE 27.1
State: Florida
Posts: 2,501
THOR #7035
Quote:
Originally Posted by jplacz2000 View Post
Even when I turn converter off when I hit switch lights flicker but donít turn off into store mode maybee bad switch?
Which switch? The light switch? No, not if the rest of the circuitry is working correctly; the lights would go off when you removed power from the DC buss.

The USE/STORE switch? Not if it is actuating the solenoid.

Sounds like the solenoid that cross-connects the house and chassis batteries may be stuck. Lift a lead on your chassis battery and see what happens.
__________________
The USER Formally Known As TFryman
Ted & Melinda
2016 ACE 27.1
2016 Chevy Sonic Toad
16ACE27 is offline   Reply With Quote
Old 06-22-2018, 01:22 AM   #18
Member
 
Brand: Thor Motor Coach
State: Massachusetts
Posts: 36
THOR #11935
The store/ use switch I’m talking about
__________________
jplacz2000 is offline   Reply With Quote
Old 06-22-2018, 10:22 AM   #19
Member
 
Brand: Thor Motor Coach
State: Massachusetts
Posts: 36
THOR #11935
I pulled the booster fuse out for that solenoid now it works wiered
__________________
jplacz2000 is offline   Reply With Quote
Old 07-01-2018, 10:46 AM   #20
Junior Member
 
Brand: Still Looking
State: North Carolina
Posts: 13
THOR #5767
Battery not charging

I have a 2015 Thor Citation and I also do not believe the engine generator will charge the house batterys . At least that is what I was told by Camping World. We need to be plugged into shore power or have the generator running
__________________

__________________
Howard1257 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Thor Industries or any of its affiliates. This is an independent, unofficial site.




All times are GMT. The time now is 09:51 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0 PL2