Go Back   Thor Forums > Thor Tech Forums > Maintenance and Repair
Click Here to Login
Reply
 
Thread Tools Display Modes
 
Old 08-07-2019, 10:49 PM   #1
Junior Member
 
Brand: Thor Motor Coach
State: Ontario
Posts: 6
THOR #10408
Ignition Turns on by itself??

Good Evening,

I have a 2017 Challenger; F53 Ford Chassis; V10.

The last two nights when I pulled into my yard the LED running lights were on - they only come on when the ignition is turned on.

I went inside and the dash is lit-up - no key in the ignition. I put the key in and turned it on & off - nothing changed. I started the engine and shut it off and everything went back to normal. This same process worked both times.

The unit is sitting in our driveway, shut-down and no-one in it either time.

Any ideas? To go to a dealer will likely be a nightmare, with an intermittent issue like this.

Thank you!
__________________

__________________
Mover is offline   Reply With Quote
Old 08-08-2019, 01:31 AM   #2
Senior Member
 
dstankov's Avatar
 
Brand: Thor Motor Coach
Model: 2015 Challenger 37ND
State: Virginia
Posts: 3,327
THOR #1469
That issue may be one for a Ford dealer to look at rather than an RV dealer. The ignition system should be standard Ford F53.
__________________

__________________
Dave
US Army (Ret)
Chester, VA
2015 Thor Challenger 37ND
FMCA - F432054
dstankov is offline   Reply With Quote
Old 08-08-2019, 05:46 PM   #3
Senior Member
 
Brand: Thor Motor Coach
Model: 2013 ACE 30.1
State: Alberta
Posts: 773
THOR #2631
Hmmm.....my old 2013 ACE does not require ignition to be on for running/park lights to be turned on.....just the dash light switch has to be operated. They must have changed that one I guess......I'd be checking the light switch for loose or crossed wiring on my coach; not sure about yours though.
__________________
javelin is offline   Reply With Quote
Old 08-11-2019, 02:04 AM   #4
Member
 
Brand: Thor Motor Coach
State: Ohio
Posts: 87
THOR #12726
Quote:
Originally Posted by Mover View Post
Good Evening,

I have a 2017 Challenger; F53 Ford Chassis; V10.

The last two nights when I pulled into my yard the LED running lights were on - they only come on when the ignition is turned on.

I went inside and the dash is lit-up - no key in the ignition. I put the key in and turned it on & off - nothing changed. I started the engine and shut it off and everything went back to normal. This same process worked both times.

The unit is sitting in our driveway, shut-down and no-one in it either time.

Any ideas? To go to a dealer will likely be a nightmare, with an intermittent issue like this.

Thank you!
Next time it does that find the daytime running light relay and unplug it see if the lights go out if they do replace the relay.
__________________
simidrm is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Thor Industries or any of its affiliates. This is an independent, unofficial site.




All times are GMT. The time now is 01:30 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0 PL2