Go Back   Thor Forums > Thor Tech Forums > Maintenance and Repair
Click Here to Login
Reply
 
Thread Tools Display Modes
 
Old 05-06-2019, 11:34 PM   #1
Junior Member
 
Brand: Thor Motor Coach
State: Illinois
Posts: 6
THOR #10522
Leveler Circuit Breaker

Despite having good batteries that are correctly hooked up, and even when connected to shore power, I am getting a "low voltage" error code on my LCI leveler LCD screen. The engine is running and the parking break set. Based on what I've read, it could be a tripped circuit breaker. I've checked by the hydraulic leveling unit, the battery bay, around the inverter, and in every storage bay, and I am unable to locate it. There is a 15 amp fuse in line with the hydraulic pump, and it's OK. I've checked with Thor, and they were unable to tell me exactly where it is located, except it may be near the pump or the battery bay. Anyone know where I might find it? I have a 2017 Thor Chateau 31W.
__________________

__________________
steveL332 is offline   Reply With Quote
Old 05-07-2019, 03:15 AM   #2
Senior Member
 
Brand: Thor Motor Coach
Model: Palazzo 33.2
State: California
Posts: 221
THOR #12839
In our Palazzo 33.2, the breaker is one of two flag style breakers in the battery compartment. Look for a breaker with the yellow flag flipped out. I got the same error when the that breaker tripped. Very frustrating, because you think you have power because the panel lights are on but nothing works...
Good luck, I hope you find it.
__________________

__________________
2018 Palazzo 33.2
HaRVey is offline   Reply With Quote
Old 05-07-2019, 03:20 AM   #3
Senior Member
 
Brand: Thor Motor Coach
Model: 2013 ACE 30.1
State: Alberta
Posts: 917
THOR #2631
Welcome to the forum. I have to advise that I don't know your coach specifics, but usually the hydraulic pump motor draws high currents when operating and I would think you should have a 100 amp re-settable breaker mounted somewhere between the coach batteries and the hydraulic pump motor. It probably also feeds the generator (if equipped). The 15 amp fuse is probably to protect the pump solenoid (relay) that turns on the actual pump motor as required. So try following the + cable from the coach batteries towards the hydraulic pump location and see if you can find another large breaker. It may have a yellow (or other color) flag showing if tripped. Reset and see if anything changes on the display/operation as a start.
__________________
javelin is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Thor Industries or any of its affiliates. This is an independent, unofficial site.




All times are GMT. The time now is 08:17 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0 PL2
×