Go Back   Thor Forums > Thor Tech Forums > Maintenance and Repair
Click Here to Login
Reply
 
Thread Tools Display Modes
 
Old 02-15-2016, 05:14 PM   #1
Senior Member
 
Brand: Thor Motor Coach
Model: Miramar 33.5
State: Washington
Posts: 217
THOR #578
Miramar 33.5 Electrical Issue

Help with an electrical issue;
2016 Miramar 33.5

Problem with monitor panel and water pump:
Water pump will not turn on
Monitor panel status lights will not illuminate when buttons are pressed

All other functions on the monitor panel work;
Gen starts/runs from panel
Both slide out functions work normally
Both water heater switches work normally, 110/gas

Everything else on coach works as advertised, no other electrical issues. Problem is intermittent, occurring twice now. During this event the battery volts are reading 13.6-14.9 volts, as read from the Xantrex 1800 Inverter, (depending if the engine is running).

Problem occurs regardless of source of power, AC shore power, Genny or Xantrex 1800 Inverter as well as on 12 volt battery power!
I checked battery state with volt meter, with no load-batteries were reading 13.8 volts.

Latest event occurred at repair facility, the technician removed monitor panel and checked all connections, they were good as well as all fuses; everything checked good. Lastly he checked the water pump volts behind the monitor panel, to his surprise they were only reading 4.6 volts.

The tech removed his hat and scratched his head! He said he would need the coach back at a later date for a couple of weeks to troubleshoot!!

I've tried turning the store/use switch on and off, drove down a bumpy road, looking to see if it's a lose connection, nothing has worked so far!!

Anybody have any ideas or solutions?

Thanks,
__________________

__________________
brianh442 is offline   Reply With Quote
Old 01-19-2018, 12:24 AM   #2
Junior Member
 
Brand: Thor Motor Coach
State: Kentucky
Posts: 1
THOR #10488
Smile Challenger 37kt Electrical Issue

I have the very same issue with my unit, have you found the fault? I am going to try to obtain a elecctrical drawing for my unit. Maybe that will help. Thanks
__________________

__________________
terrycrotteau is offline   Reply With Quote
Old 01-19-2018, 12:35 AM   #3
Senior Member
 
Brand: Thor Motor Coach
Model: outlaw 37ls
State: Europe
Posts: 230
THOR #6831
loose connection or broken wire, slim chance water pump motor has internal issue
__________________
captmetal is offline   Reply With Quote
Old 01-19-2018, 01:16 PM   #4
Senior Member
 
Brand: Thor Motor Coach
Model: Miramar 33.5
State: Washington
Posts: 217
THOR #578
Quote:
Originally Posted by terrycrotteau View Post
I have the very same issue with my unit, have you found the fault? I am going to try to obtain a elecctrical drawing for my unit. Maybe that will help. Thanks
It was a bad ground! After some searching, they found a ground wire that had been pierced by an errant screw. Normal driving would cause the ground to break then come back. Since itís been repaired, Iíve had no problems with it!!

Hope this helps!!!

Brian
__________________
brianh442 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Thor Industries or any of its affiliates. This is an independent, unofficial site.




All times are GMT. The time now is 05:05 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0 PL2