Go Back   Thor Forums > Thor Tech Forums > Maintenance and Repair
Click Here to Login
Reply
 
Thread Tools Display Modes
 
Old 03-15-2019, 12:59 AM   #1
Junior Member
 
Brand: Thor Motor Coach
State: Wisconsin
Posts: 25
THOR #13332
Shore power not working

We have power from out generator but no power from landline. Box at campground is good. Juice to the box. We are first time RVers and this is a 2014 Thor Challenger. Thank you for any help.
__________________

__________________
Driley43 is offline   Reply With Quote
Old 03-15-2019, 01:07 AM   #2
Junior Member
 
Brand: Thor Motor Coach
Model: ACE 29.3
State: Alaska
Posts: 18
THOR #6077
Check the wiring near the automatic transfer switch. This should be near your fuse/breaker panel, often in a compartment under the bed. I have a 29.3 ACE and the wires worked loose and burned. Easy fix: clean, rewire with a quality wire nut and see if it works. If not, the switch may have gone bad. DO THIS WITH ALL SHORE LINE OFF AND UNPLUGGED!
__________________

__________________
naturescott49 is offline   Reply With Quote
Old 03-15-2019, 03:22 AM   #3
Junior Member
 
State: Arizona
Posts: 24
THOR #13531
Quote:
Originally Posted by Driley43 View Post
We have power from out generator but no power from landline. Box at campground is good. Juice to the box. We are first time RVers and this is a 2014 Thor Challenger. Thank you for any help.
Check the main breaker at coach panel to make sure it is engaged. Sometimes a breaker will appear to be on but will be tripped . Check out the in line fuses to make sure that they are good also . Be careful and safe about checking . Make sure your shore cable is not connected while doing the checks .
__________________
ddlonewolf50 is offline   Reply With Quote
Old 03-15-2019, 03:48 AM   #4
Senior Member
 
Brand: Thor Motor Coach
Model: Hurricane 31S
State: Texas
Posts: 947
THOR #6411
The most common cause of this problem is a bad shore line. Usually the pedestal plug end.
__________________
Jim & Roy Davis
2016 Hurricane 31S
1961 Rampside in tow
Beau388 is offline   Reply With Quote
Old 03-15-2019, 03:50 AM   #5
Member
 
Brand: Thor Motor Coach
State: Colorado
Posts: 61
THOR #13375
I had similar issue at RV park. Problem was the shore line plug on Pallazo 2014. Vibration loosened wires. Pulled power receptacle , striped wire back and inserted back into receptacle.
If you are not comfortable with electrical work call a mechanic like I did.
__________________
roncalderz@gmail.com is online now   Reply With Quote
Old 03-15-2019, 03:55 AM   #6
Member
 
Brand: Thor Motor Coach
State: Colorado
Posts: 61
THOR #13375
Quote:
Originally Posted by Beau388 View Post
The most common cause of this problem is a bad shore line. Usually the pedestal plug end.
Is the pedestal where you plug in shore power ?
Still learning correct lingo , I have a long way to go. Thanks.
__________________
roncalderz@gmail.com is online now   Reply With Quote
Old 03-15-2019, 04:00 AM   #7
Senior Member
 
16ACE27's Avatar
 
Brand: Thor Motor Coach
Model: ACE 27.1
State: Florida
Posts: 2,119
THOR #7035
Quote:
Originally Posted by roncalderz@gmail.com View Post
Is the pedestal where you plug in shore power ?
Still learning correct lingo , I have a long way to go. Thanks.
Yes - SP or Shore Power.
__________________
The USER Formally Known As TFryman
Ted & Melinda
2016 ACE 27.1
2016 Chevy Sonic Toad
16ACE27 is offline   Reply With Quote
Old 03-15-2019, 04:00 AM   #8
Senior Member
 
16ACE27's Avatar
 
Brand: Thor Motor Coach
Model: ACE 27.1
State: Florida
Posts: 2,119
THOR #7035
Quote:
Originally Posted by ddlonewolf50 View Post
Check the main breaker at coach panel to make sure it is engaged. Sometimes a breaker will appear to be on but will be tripped . Check out the in line fuses to make sure that they are good also . Be careful and safe about checking . Make sure your shore cable is not connected while doing the checks .
It works from the generator so this is not his problem.
__________________
The USER Formally Known As TFryman
Ted & Melinda
2016 ACE 27.1
2016 Chevy Sonic Toad
16ACE27 is offline   Reply With Quote
Old 03-18-2019, 07:19 PM   #9
Junior Member
 
Brand: Thor Motor Coach
State: Florida
Posts: 4
THOR #14737
My 03 Hurricane has 110 power when hooked to shore power but not when generator is running. Could it be the transfer switch and where is it located?
__________________
Theoldreliable is offline   Reply With Quote
Old 03-18-2019, 09:39 PM   #10
Senior Member
 
TurnerFam's Avatar
 
Brand: Thor Motor Coach
Model: Palazzo 33.3 34'bunkhouse
State: North Carolina
Posts: 1,416
THOR #4735
or the breaker on your Generator itself is tripped... the most common 'issue' with no power from the Gen...
__________________
TurnerFam is offline   Reply With Quote
Old 03-19-2019, 04:15 PM   #11
Junior Member
 
Brand: Thor Motor Coach
State: Florida
Posts: 4
THOR #14737
I have checked all breakers both in coach and on the generator. I have checked for voltage at the transfer switch and there is none from the generator.
__________________
Theoldreliable is offline   Reply With Quote
Old 03-19-2019, 04:20 PM   #12
Senior Member
 
TurnerFam's Avatar
 
Brand: Thor Motor Coach
Model: Palazzo 33.3 34'bunkhouse
State: North Carolina
Posts: 1,416
THOR #4735
you may then have a loose incoming wire from the generator to the ATS(automatic transfer switch)
__________________
TurnerFam is offline   Reply With Quote
Old 03-19-2019, 05:46 PM   #13
Junior Member
 
Brand: Thor Motor Coach
State: Florida
Posts: 4
THOR #14737
Read the owner’s manual which said to hold the starter switch two to three seconds after the generator starts to “flash” the windings so that it will produce power. Tried that and we now have power! Can’t believe it was that simple!!
__________________
Theoldreliable is offline   Reply With Quote
Old Today, 03:38 PM   #14
Junior Member
 
Brand: Thor Motor Coach
State: Wisconsin
Posts: 25
THOR #13332
Quote:
Originally Posted by Driley43 View Post
We have power from out generator but no power from landline. Box at campground is good. Juice to the box. We are first time RVers and this is a 2014 Thor Challenger. Thank you for any help.
I would like to thank everyone for helping us with this problem. I am also sorry it has taken me so long to get back to you. We are at our daughter's in Bluffton, In. It has been to cold to work on anything till now. The issue has been fixed It was a loose screw where the power cord goes into the junction box. Thank you again.
__________________
Driley43 is offline   Reply With Quote
Old Today, 03:59 PM   #15
Member
 
Brand: Thor Motor Coach
State: Colorado
Posts: 61
THOR #13375
At least I am not the only one who had this problem. Happy Trails.
__________________

__________________
Rc3 po
roncalderz@gmail.com is online now   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Thor Industries or any of its affiliates. This is an independent, unofficial site.




All times are GMT. The time now is 07:57 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0 PL2