Go Back   Thor Forums > Thor Tech Forums > Maintenance and Repair
Click Here to Login
Reply
 
Thread Tools Display Modes
 
Old 06-28-2018, 09:35 PM   #1
Senior Member
 
Brand: Thor Motor Coach
Model: 2017 Thor Vegas 25.2
State: Indiana
Posts: 289
THOR #7993
Surge Guard 44260

I plugged my coach into the 20a outlet in our garage like I've done dozens of times. This time I got a red light on the left and no light next to it on the right. I assume that this means reverse polarity. I checked the outlet with my Fluke 177 and the polarity is NOT reversed. I then plugged the cord from the coach into the 44260 and it still had a red light. I haven't changed the outlet so I am assuming I need a new surge protector. What do you guys think?
__________________

__________________
jb1911 is offline   Reply With Quote
Old 06-29-2018, 02:09 AM   #2
Senior Member
 
Brand: Thor Motor Coach
Model: 2013 ACE 30.1
State: Alberta
Posts: 899
THOR #2631
Any chance you are using a long length 15 Amp 16 gauge household grade extension cord from the 20A house receptacle to the 15/30 adapter facing the coach cabling etc. ? If yes has the extension cord had any cord caps replaced and miswired? Failing that turn off all loads in your RV so current flow through the cheap extension cord drops to practically zero and see if that cures the LED indicator issues.
__________________

__________________
javelin is offline   Reply With Quote
Old 06-29-2018, 02:22 AM   #3
Senior Member
 
Brand: Thor Motor Coach
Model: 2017 Thor Vegas 25.2
State: Indiana
Posts: 289
THOR #7993
Path is 20a outlet > Surge Guard > 30a RV cord > coach. It gives the same reading with just the Surge Guard plugged in. Like I said. I've done this dozens of times in the past and this has never happened before. The house wiring hasn't been changed and I checked the outlet with my Fluke 177. It's not reversed polarity.
__________________
jb1911 is offline   Reply With Quote
Old 07-01-2018, 03:07 AM   #4
Senior Member
 
Brand: Thor Motor Coach
Model: ACE 27.1
State: Virginia
Posts: 315
THOR #7607
Just for kicks, try it on a few other receptacles.

Sent from my SAMSUNG-SM-N920A using Thor RV Forum mobile app
__________________
ComputerChips
ComputerChips is offline   Reply With Quote
Old 07-01-2018, 03:49 AM   #5
Senior Member
 
Brand: Thor Motor Coach
Model: 2013 ACE 30.1
State: Alberta
Posts: 899
THOR #2631
Another thing to try, just to see what happens, is disconnect the RV end, but leave the rest of the surge guard cct connected to the house receptacle. Does the surge guard show normal now with essentially no load?
__________________
javelin is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Thor Industries or any of its affiliates. This is an independent, unofficial site.




All times are GMT. The time now is 07:11 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0 PL2
×