Go Back   Thor Forums > Thor Tech Forums > Maintenance and Repair
Click Here to Login
Reply
 
Thread Tools Display Modes
 
Old 09-09-2017, 12:56 AM   #41
Senior Member
 
Dbadger777's Avatar
 
Brand: Thor Motor Coach
Model: Hurricane 34J
State: Michigan
Posts: 228
THOR #6009
Quote:
Originally Posted by gnach View Post
Yeah, count me in too. Took delivery from CW and took a maiden cruise of around 400 miles and the Axis drove fine. Loaded everything up for the BIG one, said goodbye to the dogsitter and... a block away no AC. We went straight to CW and their techs checked fuses and relays and found no cause. There is no AC, no blower control, no outlet selector (windshield, dash, floor), no recirculator switch AND no backup cameras! So, they say it's a Ford problem (but their cameras/radio are affected). We went on the trip anyway, around 2500 miles, in misery at times. At a home depot I bought some rigid foam and a roll of reflectix to cover the doghouse. This helped but we rode with the generator feeding the roof air, (closed all the back vents) and it was still inadequate. Ugh! We returned home and dropped the Axis off at CW and they can't find a Ford dealer that works on class As anymore. WTH?
Was this problem ever fixed? I had the same thing happen. Had to find it myself. I have pictures of what the problem was. let me know.
__________________

__________________
Dbadger777 is offline   Reply With Quote
Old 09-09-2017, 01:07 AM   #42
Site Team
 
Brand: Crossroads
Model: CF32BL
State: Mississippi
Posts: 917
THOR #121
Quote:
Originally Posted by Bob Denman View Post
I was thinking the same thing...
...And I'm hoping that this is the source of the problem: easiest fix possible!
Sounds like it, after 20 or so cycles (On Off ) the light will go out on its own
__________________

__________________
Frank and Janet Henn
2008 CrossRoads CF32Bl pushing a 2007 Dodge 2500
Traveling with Hoover, Rainbow and Sunshine
The wonder Schnauzers
fhenn is offline   Reply With Quote
Old 09-09-2017, 01:13 AM   #43
Senior Member
 
Brand: Thor Motor Coach
Model: Hurricane 27K
State: Nevada
Posts: 263
THOR #970
Welcome to the sheep club... I thought it was strange my RV spent 6 months out of 12 in the shop the first year but everyone told me that was normal. A/C not working, go to Ford for a compressor, then a Thor dealer for the box to be fixed.. each requires 2 months.. My first experience with the Ford dealer was I left it for a/c problem, vibration and handing. They had it for 2 months, took it for a test drive and told me it was normal... then I took it to an alignment shop, it was toe out 5/8 in, there was wear on the tires...3000 miles, then the tire shop, they found 2 out of round tires, and finally to another RV Ford dealer where they found the a/c compressor was bad... oh, and the first Ford dealer charged me $212 for testing my rig!!!! I got the money back from Thor for that and all the other stuff I had to do.. This is not a car dealership, once sold, no service... never expected this in my life..
__________________
petef is offline   Reply With Quote
Old 10-02-2017, 03:49 PM   #44
Senior Member
 
gnach's Avatar
 
Brand: Thor Motor Coach
Model: Axis 25.4
State: California
Posts: 473
THOR #6582
Quote:
Originally Posted by Dbadger777 View Post
Was this problem ever fixed? I had the same thing happen. Had to find it myself. I have pictures of what the problem was. let me know.
Sorry Dbadger777, I didn't see your reply. No, CampingWorld still has my Axis. I'd like to see your photos, it may help. TIA
__________________
I'm wearing trifocals now but my hindsight is 20/20.
*************
Bilsteins and Sumos front and rear...HUGE! FatMat and Hoodliner...HUGE!
Hellwig sway bars F&R, 235/85 Hankook ATM, alignment...HUGE!!!
Battery watering, 260watts Solar and BigFeets to make life easier.
gnach is offline   Reply With Quote
Old 10-02-2017, 04:54 PM   #45
Senior Member
 
Dbadger777's Avatar
 
Brand: Thor Motor Coach
Model: Hurricane 34J
State: Michigan
Posts: 228
THOR #6009
Quote:
Originally Posted by gnach View Post
Sorry Dbadger777, I didn't see your reply. No, CampingWorld still has my Axis. I'd like to see your photos, it may help. TIA
Here is a picture of the Box where the problem was. Its in the Drivers side, front storage. Everything you described also went out on mine. I was stuck on the road and had to have Thor send me the electrical schematics. Looking on top of the green connector, you will see that the back, white wire is sticking up and not pushed in like the other white wire. It wasn't making contact. I pushed it in and haven't had any trouble (With That) since. Hope this helps.
Attached Thumbnails
Click image for larger version

Name:	Axis electrical.jpg
Views:	94
Size:	105.1 KB
ID:	7216  
__________________
Dbadger777 is offline   Reply With Quote
Old 10-02-2017, 08:48 PM   #46
Senior Member
 
gnach's Avatar
 
Brand: Thor Motor Coach
Model: Axis 25.4
State: California
Posts: 473
THOR #6582
Holy $#@! Thank you very much for the photo. The
techs at CampingWorld checked fuses and relays, but I'll bet they didn't look for this. I hope it will just this easy but I really am PO'd that workmanship is so shabby and the Quality Control Inspector is the buyer.
__________________
gnach is offline   Reply With Quote
Old 10-05-2017, 01:52 PM   #47
Member
 
Brand: Thor Motor Coach
Model: Vegas 25.3
State: Texas
Posts: 39
THOR #8252
Update on the misfire issue

We just finished a 2000+ mile round trip to NC. I added two bottles of Gumout All In One Fuel System Cleaner on my first fill up. I had no further issues with misfires or engine lights.
On the east coast it was cool enough to keep the AC off and I got 11.9MPG at 60MPH mostly highway.
Once I put the AC on coming back to Texas I was getting 11.7MPG also at 60MPG
The last 130mile leg of the trip was all country roads, some small towns and traffic lights ending with some Dallas rush hour stop and go. I recorded just under 10MPG for that (9.96)
__________________
VegasinDallas is offline   Reply With Quote
Old 10-05-2017, 02:00 PM   #48
Senior Member
 
Brand: Thor Motor Coach
Model: ACE 30.3
State: Arkansas
Posts: 433
THOR #8012
Quote:
Originally Posted by VegasinDallas View Post
We just finished a 2000+ mile round trip to NC. I added two bottles of Gumout All In One Fuel System Cleaner on my first fill up. I had no further issues with misfires or engine lights.
On the east coast it was cool enough to keep the AC off and I got 11.9MPG at 60MPH mostly highway.
Once I put the AC on coming back to Texas I was getting 11.7MPG also at 60MPG
The last 130mile leg of the trip was all country roads, some small towns and traffic lights ending with some Dallas rush hour stop and go. I recorded just under 10MPG for that (9.96)
So, at this point are you thinking bad gas?
__________________
tnedator is offline   Reply With Quote
Old 10-05-2017, 04:00 PM   #49
Senior Member
 
Bob Denman's Avatar
 
Brand: Still Looking
Model: S.O.B.
State: New York
Posts: 8,607
THOR #8860
Quote:
Originally Posted by VegasinDallas View Post
We just finished a 2000+ mile round trip to NC. I added two bottles of Gumout All In One Fuel System Cleaner on my first fill up. I had no further issues with misfires or engine lights.
On the east coast it was cool enough to keep the AC off and I got 11.9MPG at 60MPH mostly highway.
Once I put the AC on coming back to Texas I was getting 11.7MPG also at 60MPG
The last 130mile leg of the trip was all country roads, some small towns and traffic lights ending with some Dallas rush hour stop and go. I recorded just under 10MPG for that (9.96)
That is some pretty dang good fuel mileage...
__________________
Good Sam Member 843599689
FMCA Member F473304

Current coach: Tiffin Wayfarer 24 BW
Former coach: Thor Outlaw 29-H
Bob Denman is offline   Reply With Quote
Old 10-05-2017, 05:04 PM   #50
Member
 
Brand: Thor Motor Coach
Model: Vegas 25.3
State: Texas
Posts: 39
THOR #8252
tnedator, yes at this point I am pretty sure it was bad gas. It had been on the lot for a year so it was kinda stupid of me not to think of that first.

And Bob, I was very impressed with the fuel mileage. That was poking along at 60.
__________________

__________________
VegasinDallas is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Thor Industries or any of its affiliates. This is an independent, unofficial site.




All times are GMT. The time now is 03:21 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0 PL2