Click Here to Login
View Single Post
Old 02-22-2016, 03:56 PM   #6
brianh442
Senior Member
 
Brand: Thor Motor Coach
Model: Miramar 33.5
State: Washington
Posts: 217
THOR #578
Quote:
Originally Posted by gauthig View Post
Just traded in a old class C for a new Hurricane 35C. While doing the PDI I noticed something strange. When hitting the sensors test button every thing as low, even the battery and Fresh water that was half full according to the salesman. Thought it was a defect and he finally tried something, he put the key in the ignition and turn on (not started). All sensors show correct level.

He stated this is normal that you need to the keys in to test the tanks and battery. I have never heard of that before and still think that is incorrect.

Is this the same for all Thor's? Any Hurricane owners?
Question: Does your water pump work??

I have a 2016 Miramar 33.5. I've been having an intermittent problem with my sensors on the monitor panel. None work??? My water pump stopped working as well. Everything else on the panel works! When a button is pressed, it will flash dimly and go blank, seems like there is some residual volts floating around in there!
It's happened twice now, I've called the mother ship and spoke with a helpful technician who walked me through a few steps to check the volts.

It seems like it may be a ground issue, I've checked all the connections on the tanks as well as the water pump, everything seems like it's connected snugly,

Your problem sounds similar!! Any input would be appreciated!!

Thanks,

Brian
__________________
brianh442 is offline   Reply With Quote
 
» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Thor Industries or any of its affiliates. This is an independent, unofficial site.




All times are GMT. The time now is 04:10 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
×