RV News RVBusiness 2021 Top 10 RVs of the Year, plus 56 additional debuts and must-see units → ×
 

Go Back   Thor Forums > Thor Tech Forums > Motorhome Tech Topics
Click Here to Login
Reply
 
Thread Tools Display Modes
 
Old 07-14-2019, 11:30 PM   #1
Member
 
Brand: Thor Motor Coach
State: Georgia
Posts: 71
THOR #3340
Cool Jenson radio/back up camera

Iíve had trouble with this unit in the past - if I turned it off, it struggled to be turned back on, if I didnít turn it off while at my granddaughters softball tournament, boondocking, it ran the battery down requiring use of the ďemergency startĒ of the truck. Iíve just dealt with it and it always turned itself back on after a few miles down the road. But now itís dead, well not really dead. The radio/camera wonít turn on but there are flickering lights at the CD insertion and there is no CD. I canít figure out what fuse to pull. Thought just pulling the fuse and maybe rebooting it would work. Itís not the fuse shown in the Ford manual and itís not the fuse showing on the panel schematic for the Ford.

You guys got any idea what I could try next?

2014 Ford Axis 24.1
__________________

__________________
sueasher1@netzero.net is offline   Reply With Quote
Old 07-15-2019, 01:12 AM   #2
gmc
Senior Member
 
gmc's Avatar
 
Brand: Thor Motor Coach
Model: Hurricane 32A
State: Florida
Posts: 1,871
THOR #2829
Quote:
Originally Posted by sueasher1@netzero.net View Post
Iíve had trouble with this unit in the past - if I turned it off, it struggled to be turned back on, if I didnít turn it off while at my granddaughters softball tournament, boondocking, it ran the battery down requiring use of the ďemergency startĒ of the truck. Iíve just dealt with it and it always turned itself back on after a few miles down the road. But now itís dead, well not really dead. The radio/camera wonít turn on but there are flickering lights at the CD insertion and there is no CD. I canít figure out what fuse to pull. Thought just pulling the fuse and maybe rebooting it would work. Itís not the fuse shown in the Ford manual and itís not the fuse showing on the panel schematic for the Ford.



You guys got any idea what I could try next?



2014 Ford Axis 24.1


The infamous JRV210 I assume bring a 2014 rig?
Easiest is to pop it out of the dash, and unplug from behind.
You should have gotten 2 ĎUí shaped wires in your paperwork/manuals the slide into holes on each side of radio, and with a little giggling (IIRC pushing outward) it will slide right out.

If you didnít get the wires, many auto parts stores carry them for a few bucks.

Havenít found a good long term solution other than replacing the unit... sigh...
__________________

__________________
Greg
Not yet retired...
Florida (Michigan transplant)
2014 Hurricane 32A
2000 Infinity (previous)
gmc is offline   Reply With Quote
Old 07-15-2019, 02:57 AM   #3
Member
 
Brand: Thor Motor Coach
State: Georgia
Posts: 71
THOR #3340
Quote:
Originally Posted by gmc View Post
The infamous JRV210 I assume bring a 2014 rig?
Easiest is to pop it out of the dash, and unplug from behind.
You should have gotten 2 ĎUí shaped wires in your paperwork/manuals the slide into holes on each side of radio, and with a little giggling (IIRC pushing outward) it will slide right out.

If you didnít get the wires, many auto parts stores carry them for a few bucks.

Havenít found a good long term solution other than replacing the unit... sigh...
Well! Thanks??? I guess. I didnít receive any ĎUí shaped wires. Not crazy about replacing of course. What did you replace with?
__________________
sueasher1@netzero.net is offline   Reply With Quote
Old 07-15-2019, 03:15 AM   #4
gmc
Senior Member
 
gmc's Avatar
 
Brand: Thor Motor Coach
Model: Hurricane 32A
State: Florida
Posts: 1,871
THOR #2829
Quote:
Originally Posted by sueasher1@netzero.net View Post
Well! Thanks??? I guess. I didnít receive any ĎUí shaped wires. Not crazy about replacing of course. What did you replace with?

I havenít yet... on second RV210... replaced by service plan last time... Second one having same issues bu each time I get ready to do something it starts working again...
The JRV215 was about only other choice that would take 3 camera input without adding another box for more $$, but not sure that is available any more.
Search to forum for ĎJensen blank screení and youíll find several threads including what others have replaced with.
__________________
Greg
Not yet retired...
Florida (Michigan transplant)
2014 Hurricane 32A
2000 Infinity (previous)
gmc is offline   Reply With Quote
Old 07-15-2019, 03:21 AM   #5
Member
 
Brand: Thor Motor Coach
State: Georgia
Posts: 71
THOR #3340
Quote:
Originally Posted by gmc View Post
I havenít yet... on second RV210... replaced by service plan last time... Second one having same issues bu each time I get ready to do something it starts working again...
The JRV215 was about only other choice that would take 3 camera input without adding another box for more $$, but not sure that is available any more.
Search to forum for ĎJensen blank screení and youíll find several threads including what others have replaced with.
Thank you
__________________
sueasher1@netzero.net is offline   Reply With Quote
Old 07-17-2019, 05:58 PM   #6
Member
 
Brand: Thor Motor Coach
State: Georgia
Posts: 71
THOR #3340
Quote:
Originally Posted by gmc View Post
The infamous JRV210 I assume bring a 2014 rig?
Easiest is to pop it out of the dash, and unplug from behind.
You should have gotten 2 ĎUí shaped wires in your paperwork/manuals the slide into holes on each side of radio, and with a little giggling (IIRC pushing outward) it will slide right out.

If you didnít get the wires, many auto parts stores carry them for a few bucks.

Havenít found a good long term solution other than replacing the unit... sigh...
I fixed it! Well, maybe only temporarily. I couldnít figure out how to remove it so I just pulled down the ďapronĒ for the dash. I had popped the top of the dash connection in the past, cleaning the little trough. So it got me into the back, then at the very bottom of that dash apron there were wingnuts that were easily removed. I unplugged the cord on the very bottom left hand side (as you see it from the driverís seat). Plugged it back and voilaí! Itís working. And it wasnít that difficult to do so if it does this trick in the future at least I know what to try. Thanks for pointing me in the right direction.
__________________

__________________
sueasher1@netzero.net is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Thor Industries or any of its affiliates. This is an independent, unofficial site.




All times are GMT. The time now is 11:08 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0 PL2
×