RV News RVBusiness 2021 Top 10 RVs of the Year, plus 56 additional debuts and must-see units → ×
 

Go Back   Thor Forums > Thor Tech Forums > Motorhome Tech Topics
Click Here to Login
Reply
 
Thread Tools Display Modes
 
Old 01-28-2019, 04:43 PM   #1
Junior Member
 
Brand: Thor Motor Coach
State: Georgia
Posts: 9
THOR #13447
LCI Ultra level hydraulic leveling

We have a 2013 Tuscany EX with an issue with the Ultra level hydraulic leveling system. It can take several minutes for the touch pad to turn on or off when the button is pressed. The manual has no guidance on what may be causing this.

Has anyone had this problem? Does anyone know of a solution? I was thinking of replacing the touch pad. Thoughts?
__________________

__________________
jmjah2018 is offline   Reply With Quote
Old 01-28-2019, 04:57 PM   #2
Axis/Vegas Enthusiast
 
JamieGeek's Avatar
 
Brand: Thor Motor Coach
Model: Axis 24.1
State: Michigan
Posts: 9,238
THOR #1150
Have you contacted LCI about the issue? They may offer guidance and/or replacement parts.

Especially given this thread:
http://www.thorforums.com/forums/f8/...per-15839.html
__________________

__________________
2014 Thor Axis 24.1
2021 Mach-E
blog - https://spareelectrons.wordpress.com/
JamieGeek is offline   Reply With Quote
Old 02-10-2019, 10:54 PM   #3
I Think We're Lost!
 
Bob Denman's Avatar
 
Brand: Still Looking
Model: Tiffin Wayfarer 24 BW
State: New York
Posts: 18,418
THOR #8860
It sounds as if that could stand to be replaced: give Lippert a call.
__________________
"The World is full of Kings and Queens; who blind your eyes, and steal your dreams."
Good Sam Member 843599689
Current coach: Tiffin Wayfarer 24 BW
Bob Denman is offline   Reply With Quote
Old 02-11-2019, 04:49 AM   #4
Junior Member
 
Brand: Thor Motor Coach
State: Georgia
Posts: 9
THOR #13447
Quote:
Originally Posted by jmjah2018 View Post
We have a 2013 Tuscany EX with an issue with the Ultra level hydraulic leveling system. It can take several minutes for the touch pad to turn on or off when the button is pressed. The manual has no guidance on what may be causing this.

Has anyone had this problem? Does anyone know of a solution? I was thinking of replacing the touch pad. Thoughts?
I did replace the touch pad and everything works as expected. Lippert was able to provide voltage information to indicate the touch pad as the problem
__________________
jmjah2018 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Thor Industries or any of its affiliates. This is an independent, unofficial site.




All times are GMT. The time now is 08:26 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0 PL2
×