RV News RVBusiness 2021 Top 10 RVs of the Year, plus 56 additional debuts and must-see units → ×
 

Go Back   Thor Forums > Thor Tech Forums > Motorhome Tech Topics
Click Here to Login
Reply
 
Thread Tools Display Modes
 
Old 10-24-2015, 07:37 PM   #1
Junior Member
 
Brand: Thor Motor Coach
State: Tennessee
Posts: 3
THOR #3117
Technical Transmission Issue

I have a 1993 Class A Thor Columbus. I have an issue where the transmission is in default mode where it is stuck in 2nd gear. I have traded out the inside wiring harness, and most sensors. At one point, I had the batteries disconnected and the ECM out. Connected everything and it was working fine, shifting into each gear. I then put everything back together
now it is in default mode again. Getting codes from the OBD connector of 81 and 82 that states the 1st gear and 2nd gear solenoids are bad. I have
replaced those as well. Unfortunately this coach set-up for almost 6 years. I bought it as a project to fix the interior, but this has sprung up on me. Anyone have any thoughts, before I take it to a mechanic?
__________________
map7660 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Thor Industries or any of its affiliates. This is an independent, unofficial site.




All times are GMT. The time now is 02:13 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0 PL2
×