RV News RVBusiness 2021 Top 10 RVs of the Year, plus 56 additional debuts and must-see units → ×
 

Go Back   Thor Forums > Thor Tech Forums > Motorhome Tech Topics
Click Here to Login
Reply
 
Thread Tools Display Modes
 
Old 10-01-2020, 09:06 PM   #1
Junior Member
 
Brand: Still Looking
State: Texas
Posts: 4
THOR #20690
Trans com fail

2017 Palazzo
Canít start - getting J1939 display- trans com fail
Gear selector panel not lit up

Thor advised check 10 amp fuses- checked out ok

Recently motorized shaded failed in den position

Rolled them up taped both in up position

Started drove 120 miles home

Tried reset but failed

Nothing else changed
Any help appreciated
Any other fuses or breakers that could be affecting this
What can be locking it out
__________________

__________________
Razalas_89 is offline   Reply With Quote
Old 10-01-2020, 09:46 PM   #2
Senior Member
 
Brand: Thor Motor Coach
Model: Tuscany
State: Texas
Posts: 198
THOR #1808
fuses, remove and wait ten seconds


if that does not clear the fault, try looking at the back side of the trans panel and ensure the cable is plugged in.




you can also disconnect the chassis batteries and then wait a few seconds then reconnect


speaking of batteries....are they charged and in good order ? if not, they will create all kinds of issues





shades have no bearing on transmission. my shade motor failed and had to be replaced.
__________________

__________________
retired Navy driving the short bus 2008 Tuscany 4056
powerboatr is offline   Reply With Quote
Old 11-22-2020, 05:51 PM   #3
Senior Member
 
Brand: Thor Motor Coach
State: Ohio
Posts: 172
THOR #12726
The power source for the transmission is in a fusible link at or near the engine batteries, oh there are so many things that can set that code, there was a tech repair notice sent out on that where the factory had the wiring harness pulled to tight at the fuse box (if yours is in the engine bay) and it would crack the inside of the 10a fuse for transmission and by a test light you would still have power on both points on the fuse, it was breaking the fuse at the leg, replace the fuse anyway there cheap and see if it works,I have found 3 times where this happened
__________________
simidrm is offline   Reply With Quote
Old 11-22-2020, 07:17 PM   #4
I Think We're Lost!
 
Bob Denman's Avatar
 
Brand: Still Looking
Model: Tiffin Wayfarer 24 BW
State: New York
Posts: 17,871
THOR #8860
It appears to be a failure in the communication between the transmission and the computer.
(It doesn't know what gear it's in. )
It could be a sensor, or the wiring between the components.
__________________
Bob Denman is online now   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Thor Industries or any of its affiliates. This is an independent, unofficial site.




All times are GMT. The time now is 03:19 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0 PL2
×