RV News RVBusiness 2021 Top 10 RVs of the Year, plus 56 additional debuts and must-see units → ×
 

Go Back   Thor Forums > Thor Tech Forums > Motorhome Tech Topics
Click Here to Login
Reply
 
Thread Tools Display Modes
 
Old 03-29-2015, 02:41 AM   #1
Senior Member
 
Brand: Thor Motor Coach
Model: Vegas 24.1
State: Arizona
Posts: 110
THOR #1670
Vegas 12V Problem

My 12V system works when motor is running, hooked up to shore power or when the generator is running. When the motor is running and I turn off the key, the lights stay on for about 15 seconds and then turn off, almost like courtesy lights. I Think the disconnect switch may be the problem but when it all worked before if the disconnect switch was off I did not have the turn signal and rearview camera working while the engine was running, It is now working while the engine is running.
__________________

__________________
srolfe is offline   Reply With Quote
Old 03-29-2015, 12:21 PM   #2
Moderator Emeritus
 
FW28z's Avatar
 
Brand: Thor Motor Coach
Model: 2011 Four Winds 28Z
State: Michigan
Posts: 1,273
THOR #531
Didn't you verify you had a coach battery problem from another thread?

The cameras are likely connected to the coach battery. Prior to around 2013, Thor connected the stereo system to the engine battery, but in later years, started connecting them to the coach battery.

So assuming the cameras are connected like the stereo, if they work with the disconnect switch in the ON position, that means they are probably getting power from the engine alternator with the engine running - as in many Thor coaches, the engine alternator charges the coach battery.

You may have a bad coach battery.
__________________

__________________
The only thing that works on a RV is the owner...
FW28z is offline   Reply With Quote
Old 03-29-2015, 07:52 PM   #3
Senior Member
 
Bruce's Avatar
 
Brand: Thor Motor Coach
Model: Axis 25.1
State: Pennsylvania
Posts: 299
THOR #1503
Check the voltage in your house battery (s) located under the step.

Also, do you hear the solenoid operate when you select the "Store" or Use" position on the battery switch.

Your turn/backup cameras should only work when the ignition key is on.

Bruce
__________________
Bruce is offline   Reply With Quote
Old 03-29-2015, 09:07 PM   #4
Senior Member
 
Brand: Thor Motor Coach
Model: Vegas 24.1
State: Arizona
Posts: 110
THOR #1670
Both the house and starter batteries are fully charged at this point. I do not hear the click when when the disconnect switch is pressed on or off. It is still under warranty, so I guess I will take it to service center to get it resolved
__________________
srolfe is offline   Reply With Quote
Old 03-29-2015, 09:58 PM   #5
Senior Member
 
Oneilkeys's Avatar
 
Brand: Still Looking
Model: Travato
State: Florida
Posts: 2,435
THOR #1765
Vegas 12v problem

I had a similar problem last summer. It turns out that there is a manual breaker that protects the 12v system and disconnects it from the coach. It is located to the left of both coach batteries (under the step) in the Vegas 24.1. It is located inside or behind the metal piece on the left hand battery wall where the red wire that connects the batteries to the coach is attached. It cost me $100 taking it to an RV dealer to find this out. It is not in any manual that I could find. The tech told me that the breaker flipped down and all you had to do was manually push it back up into the box.. It has worked fine ever since.

Hope this solves your problem...
__________________
Oneilkeys is offline   Reply With Quote
Old 03-29-2015, 10:14 PM   #6
Senior Member
 
Bruce's Avatar
 
Brand: Thor Motor Coach
Model: Axis 25.1
State: Pennsylvania
Posts: 299
THOR #1503
This must be the breaker:



The red stuff is corrosion protection that Thor sprays on it.

Bruce


Quote:
Originally Posted by Oneilkeys View Post
It turns out that there is a manual breaker that protects the 12v system and disconnects it from the coach. It is located to the left of both coach batteries (under the step) in the Vegas 24.1.
__________________
Bruce is offline   Reply With Quote
Old 03-29-2015, 10:45 PM   #7
Senior Member
 
Oneilkeys's Avatar
 
Brand: Still Looking
Model: Travato
State: Florida
Posts: 2,435
THOR #1765
Mine looks alittle different, there is no easy red button, but that is the beast.
__________________
Oneilkeys is offline   Reply With Quote
Old 03-29-2015, 11:27 PM   #8
Moderator Emeritus
 
FW28z's Avatar
 
Brand: Thor Motor Coach
Model: 2011 Four Winds 28Z
State: Michigan
Posts: 1,273
THOR #531
Eureka! Thanks for the photo.

That must be what is behind the side of my battery. Just the other day, I noticed there was battery cables going to something behind the battery, and I was not sure what it was as there is no way I can get to it without taking the battery out, and it has been too cold to investigate further.

Those are familiar to me as they come from the boating world. It looks like a Blue Sea series 285. I just bought one to put on the hydraulic lift circuit as they put in an auto-reset breaker, which while it will protect the circuit, will not allow you to disconnect it (you push in the red part to trip it).



I am going to re-wire the battery box area this year. I am going to replace the batteries, and I want to clean up the entire Rube Goldberg mess.

I am thinking of installing one of these hatches to the outside of the coach:



I want to put both the disconnect for the hydraulic lifters in there, as well as the one Thor put behind the battery, if indeed that is what it is. And if I have room, perhaps a solar battery charger plug.

But if I go this route, I need to make sure the existing cables will be long enough as I really don't want to run new cables. And I will probably have to buy thru-mount versions of the breakers as the existing ones are surface mount. And at $40 bucks per breaker, they ain't cheap.
__________________
The only thing that works on a RV is the owner...
FW28z is offline   Reply With Quote
Old 03-31-2015, 03:24 AM   #9
Senior Member
 
Brand: Thor Motor Coach
Model: Vegas 24.1
State: Arizona
Posts: 110
THOR #1670
This would explain all my problems if this breaker has tripped. Unfortunately it looks like it was installed upside down. I am going to have to get someone to crawl under the rv and see if it is reachable from below, or wait until I can remove the house batteries. I cannot get my hand in position to feel for the switch and I currently have a broken leg. Where is my nephew?
__________________
srolfe is offline   Reply With Quote
Old 04-04-2015, 07:43 PM   #10
Senior Member
 
Brand: Thor Motor Coach
Model: Vegas 24.1
State: Arizona
Posts: 110
THOR #1670
Thanks to everyone, especially those who pointed out that circuit breaker in the battery box, had my nephew come over, got his hand in there and reset the breaker, everything works now. Ready for my first trip of the year.
__________________
srolfe is offline   Reply With Quote
Old 04-05-2015, 01:13 AM   #11
Senior Member
 
Larry's Avatar
 
Brand: Thor Motor Coach
Model: Axis 24.1
State: Georgia
Posts: 837
THOR #1123
Nephews can really come in "handy", can't they? .

Glad to hear you got your problem solved. Enjoy that trip!
__________________

__________________
Larry is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Thor Industries or any of its affiliates. This is an independent, unofficial site.




All times are GMT. The time now is 11:56 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0 PL2
×