Free 7 Day Trial RV GPS App RV Trip Planner Campground Reviews RV Maintenance Free 7 Day Trial ×
 

Go Back   Thor Forums > Thor Community Forums > Forum Admin and Announcements
Click Here to Login
Reply
 
Thread Tools Display Modes
 
Old 07-08-2021, 09:24 PM   #21
I Think We're Lost!
 
Bob Denman's Avatar
 
Brand: Still Looking
Model: Tiffin Wayfarer 24 BW
State: New York
Posts: 21,744
THOR #8860
Just makin' sure: Bro!

__________________
Bob Denman is offline   Reply With Quote
Old 07-08-2021, 09:31 PM   #22
Senior Member
 
HMCSW's Avatar
 
Brand: Thor Motor Coach
Model: Aria 3401
State: Washington
Posts: 353
THOR #22245
logged in or not google tracks the IP address key strokes and any and all searches. If you happen to have anti virus software it can display what companies are looking at your information. I do not have a face book account but there are times that they are collecting data from my search. google sells access and everyone using google , gmail is having their information sold.
__________________
2021 Aria 3401
2015 Escalade (toad)
Retired US Navy Corpsman HMC(SW)(FMF)
HMCSW is offline   Reply With Quote
Old 07-08-2021, 11:41 PM   #23
Senior Member
 
Brand: Thor Motor Coach
Model: Chateau 24F
State: Ohio
Posts: 1,136
THOR #16721
Quote:
Originally Posted by OldWEB View Post
I am not talking about posting, just wanting to see what link the poster had posted... w/o logging in.
Using Chrome, right-click on the page and choose "View page source". Without being logged in, you are served a different plate of html. Notice the links redirect you to a blank page. That's by design. When you log in, you are served different html... you'll have to ask the moderators/forum designer why they chose to do that. I gave my opinion.

I urge you to educate yourself about how http requests, redirects, etc. work. When you click on a link, you're sending a request - same as if you had typed something and "posted" it.

The World Wide Web can be a scary place... but the more you understand how things work behind the scenes, the less mysterious it becomes. Understanding the mechanics also allows you to make good decisions about what is acceptable, and what to avoid.

Good luck.
__________________
Chateau_Nomad is offline   Reply With Quote
Old 07-09-2021, 02:01 AM   #24
Site Team
 
16ACE27's Avatar
 
Brand: Thor Motor Coach
Model: ACE 27.1
State: Florida
Posts: 7,528
THOR #7035
Oldweb is right: the issue about "page not found" is due to this Forum's software - that section is broke for non-logged in users. This is what you SHOULD be getting by clicking on a link in a thread:


And clicking on the "Continue to External Link" takes you to the actual web page.

If you look at the URL you will see it is properly formatted after the "&external_page=" area;

...https://www.thorforums.com/forums/mi...threadid=27332&external_page=https://www.amazon.com/DC-HOUSE-Upgr...dp/B08LVKCZPY/...

But, the forum hashes the link substituting ascii code for non-alphanumeric characters so what you get is:
...https://www.thorforums.com/forums/mi...VKCZPY%2Fref%3...

So instead of https:// you get https%3A%2F%2F which gets you the "page not found" error.

So it may be broke due to an actual problem in the software, or it may be broke due to changes/advances in web browsers, but in either case it probably won't get fixed until the forum moves to newer software.
__________________
Ted & Melinda
2016 ACE 27.1
2016 Chevy Sonic Toad
2020 Chevy Colorado Z71 Trail Runner Alternate Toad
16ACE27 is online now   Reply With Quote
Old 07-09-2021, 02:33 PM   #25
Senior Member
 
Brand: Thor Motor Coach
Model: Chateau 24F
State: Ohio
Posts: 1,136
THOR #16721
Google

As a curiosity test, I logged in (so I could post) then typed "www.google.com" for a hyperlink. Then I logged out and noticed the forum software evidently did a DNS lookup... it displayed "Google" as link text.

While logged out, clicking on the link text displayed the dialog 16ACE27 referenced above. So, I think that works as designed. But notice in the text I pasted in there are no characters outside the "standard" ASCII set.

Then when I logged back in and viewed the post, the software had automagically formatted my typed text into a proper url - likely using the data from a DNS lookup - and even enclosed it in tags/brackets.

Notice when logged out the link is prefixed for redirecting to the "External Links Notice"... AND the non alphanumeric characters are NOT ASCII encoded.

So... I 100% agree with 16ACE27... the forum is possibly using an outdated encoding algorithm, and unless the forum upgrades to an updated version...

Finally - apologies to oldWEB if I offended you. That was NOT my intention... I actually want to applaud you for sleuthing out those broken links. Cheers!
__________________
Chateau_Nomad is offline   Reply With Quote
Old 07-09-2021, 03:20 PM   #26
Senior Member
 
OldWEB's Avatar
 
Brand: Thor Motor Coach
Model: FW Hurricane 33T
State: England
Posts: 755
THOR #16471
Quote:
Originally Posted by 16ACE27 View Post
Oldweb is right: the issue about "page not found" is due to this Forum's software - that section is broke for non-logged in users. This is what you SHOULD be getting by clicking on a link in a thread:


THAT is what I would expect when not logged in and the odd link will bring it up. You are a smarter person than I in this area.
I also have to mention my Firefox has "Enhanced Tracking Protection" turned "on" and with uBlock my browser does act funny on some pages/links. That is why I will also try a link with a standard Chromium browser too.
Thanks!
__________________
OldWEB is offline   Reply With Quote
Old 07-09-2021, 03:29 PM   #27
Senior Member
 
OldWEB's Avatar
 
Brand: Thor Motor Coach
Model: FW Hurricane 33T
State: England
Posts: 755
THOR #16471
Quote:
Originally Posted by Chateau_Nomad View Post
Google

As a curiosity test, I logged in (so I could post) then typed "www.google.com" for a hyperlink. Then I logged out and noticed the forum software evidently did a DNS lookup... it displayed "Google" as link text.

While logged out, clicking on the link text displayed the dialog 16ACE27 referenced above. So, I think that works as designed. But notice in the text I pasted in there are no characters outside the "standard" ASCII set.

Then when I logged back in and viewed the post, the software had automagically formatted my typed text into a proper url - likely using the data from a DNS lookup - and even enclosed it in tags/brackets.

Notice when logged out the link is prefixed for redirecting to the "External Links Notice"... AND the non alphanumeric characters are NOT ASCII encoded.

So... I 100% agree with 16ACE27... the forum is possibly using an outdated encoding algorithm, and unless the forum upgrades to an updated version...

Finally - apologies to oldWEB if I offended you. That was NOT my intention... I actually want to applaud you for sleuthing out those broken links. Cheers!
No offence taken, I may not 'verbalize' what I have in my head properly and what you had posted before was techno-geek-speak that buzzed my haircut more than what my barber does.

I do feel better that what has been bothering ME for a long time has been noticed, and like I mentioned numerous times, the other RVLife forums do not have this problem and I think they do use the same platform (listed at the bottom of the page).
Powered by vBulletin® Version 3.8.8
Thanks again!
__________________
OldWEB is offline   Reply With Quote
Old 07-09-2021, 03:43 PM   #28
Senior Member
 
OldWEB's Avatar
 
Brand: Thor Motor Coach
Model: FW Hurricane 33T
State: England
Posts: 755
THOR #16471
Thanks for the example. It's not broken - we made it that way on purpose. The reason for this is complex and has to do with search engine traffic. Basically google indexes that link and drives up traffic to amazon instead of sending people here to this site. Just login - it will work



I just remembered awhile back that I did ask Janet H and the above was what she replied.
In my question to her I used Amazon links as examples and now I got thinking and lo and behold, the "problem - "Page not found!" only seems to apply to Amazon links.

I just did search many links on the forum and 'it appears' that when not logged in, the Amazon links only give the problem... So according to Janet H, it is "on purpose"
__________________
OldWEB is offline   Reply With Quote
Old 07-09-2021, 09:29 PM   #29
Senior Member
 
The_Breeze's Avatar
 
Brand: Thor Motor Coach
Model: Chateau 31L
State: Florida
Posts: 2,036
THOR #12189
I've been perusing the forum most of the early evening - NOT LOGGED IN - and (so far) all the links are working. I will not divludge how I am doing it so don't ask. I don't want it to be intentionally broken to force logons that drive whatever metrics are being sought by the current implementation. Over and out.
__________________
The_Breeze is offline   Reply With Quote
Old 07-10-2021, 01:29 AM   #30
Senior Member
 
The_Breeze's Avatar
 
Brand: Thor Motor Coach
Model: Chateau 31L
State: Florida
Posts: 2,036
THOR #12189
Quote:
Originally Posted by OldWEB View Post
Thanks for the example. It's not broken - we made it that way on purpose. The reason for this is complex and has to do with search engine traffic. Basically google indexes that link and drives up traffic to amazon instead of sending people here to this site. Just login - it will work



I just remembered awhile back that I did ask Janet H and the above was what she replied.
In my question to her I used Amazon links as examples and now I got thinking and lo and behold, the "problem - "Page not found!" only seems to apply to Amazon links.

I just did search many links on the forum and 'it appears' that when not logged in, the Amazon links only give the problem... So according to Janet H, it is "on purpose"

Easy fix: https://support.google.com/news/publ.../9605477?hl=en
__________________
The_Breeze is offline   Reply With Quote
Old 07-10-2021, 01:59 AM   #31
Senior Member
 
The_Breeze's Avatar
 
Brand: Thor Motor Coach
Model: Chateau 31L
State: Florida
Posts: 2,036
THOR #12189
Quote:
Originally Posted by OldWEB View Post
Thanks for the example. It's not broken - we made it that way on purpose. The reason for this is complex and has to do with search engine traffic. Basically google indexes that link and drives up traffic to amazon instead of sending people here to this site. Just login - it will work



I just remembered awhile back that I did ask Janet H and the above was what she replied.
In my question to her I used Amazon links as examples and now I got thinking and lo and behold, the "problem - "Page not found!" only seems to apply to Amazon links.

I just did search many links on the forum and 'it appears' that when not logged in, the Amazon links only give the problem... So according to Janet H, it is "on purpose"
After further forensics, This is correct. It seems only amazon links are affected. Amazon and Google sleep together so her statement about the index is correct. You also have affiliate links. Sometimes a click generates revenue for the perp, other times you have to buy something for that revenue to be dispursed.
__________________
The_Breeze is offline   Reply With Quote
Old 07-10-2021, 02:14 AM   #32
Senior Member
 
OldWEB's Avatar
 
Brand: Thor Motor Coach
Model: FW Hurricane 33T
State: England
Posts: 755
THOR #16471
Thanks for all the insights!

Well I have no problem not being able to connect with the links if not logged in... in fact I will strive to not attend any post if there are links involved.... and I hope I can remember to not post links here in the future.

The iRV2 forum does not mess with their links (that I know of), so I will gladly do more business there. Sayonara
__________________
OldWEB is offline   Reply With Quote
Reply

Tags
links

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Thor Industries or any of its affiliates. This is an independent, unofficial site.




All times are GMT. The time now is 11:58 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0 PL2