Journey with Confidence RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Take a Speed Test Free 7 Day Trial ×
 

Go Back   Thor Forums > Thor Community Forums > Introduce Yourself | Say Hello
Click Here to Login
Reply
 
Thread Tools Display Modes
 
Old 07-31-2016, 08:02 PM   #1
Junior Member
 
Bilake99's Avatar
 
Brand: Thor Motor Coach
Model: Freedom Elite 30FE
State: Florida
Posts: 8
THOR #4974
New Freedom Elite owner

Hi, my name is Bill and we just brought our new Thor RV home on Friday. We parked it here until today as our storage space didn't open up until now. It's a 22FE model, just the right size for the 2 of us. We're both retired and planning to see a lot of the country.
The only problem so far is that the radio and backup camera didn't work when I drove it to the storage site. Worked OK when I brought it home, but not today. It's an Axxera model, which I think is after market. So, back to Camping World tomorrow. The rest of the RV is great.

__________________
Bilake99 is offline   Reply With Quote
Old 04-29-2017, 02:18 PM   #2
Senior Member
 
Brand: Thor Motor Coach
Model: 29h outlaw
State: New Jersey
Posts: 455
THOR #5248
You have to have the store/use switch in use position
__________________
Trkyte@msn.com is offline   Reply With Quote
Old 05-19-2017, 05:37 PM   #3
Senior Member
 
Homer3's Avatar
 
Brand: Thor Motor Coach
Model: Freedom Elite 28H
State: California
Posts: 159
THOR #3559
Axxera Radio

Go to Axxera website for manuals on operation

http://www.axxera/dualav.com/downloa...ls/av613bh.pdf took me to the one in our 2016 Freedom Elite

I'm still working on solving my rear camera issues - any ideas are welcome
__________________
Homer3 is offline   Reply With Quote
Old 05-19-2017, 09:42 PM   #4
Senior Member
 
Brand: Thor Motor Coach
Model: Freedom Elite 26HE
State: Illinois
Posts: 150
THOR #4282
If my battery voltage drops enough my radio would not turn on nor the camera work. happed to me twice because of the junk battery that is installed in them new. The fix is to either A pull the radio out and unplug the back to reset the power or easier to just remove one of the battery leads from the coach battery for 30 seconds and hook back up then it works again. At least it does for mine.
__________________
gentilebrian is offline   Reply With Quote
Old 05-20-2017, 02:17 PM   #5
Junior Member
 
Bilake99's Avatar
 
Brand: Thor Motor Coach
Model: Freedom Elite 30FE
State: Florida
Posts: 8
THOR #4974
Quote:
Originally Posted by Homer3 View Post
Go to Axxera website for manuals on operation

http://www.axxera/dualav.com/downloa...ls/av613bh.pdf took me to the one in our 2016 Freedom Elite

I'm still working on solving my rear camera issues - any ideas are welcome
Thanks. That site info was really helpful. I think I have solved. Maybe.
__________________
Bilake99 is offline   Reply With Quote
Old 04-12-2021, 04:41 PM   #6
Junior Member
 
Brand: Thor Motor Coach
State: Arizona
Posts: 1
THOR #22945
Quote:
Originally Posted by Bilake99 View Post
Hi, my name is Bill and we just brought our new Thor RV home on Friday. We parked it here until today as our storage space didn't open up until now. It's a 22FE model, just the right size for the 2 of us. We're both retired and planning to see a lot of the country.
The only problem so far is that the radio and backup camera didn't work when I drove it to the storage site. Worked OK when I brought it home, but not today. It's an Axxera model, which I think is after market. So, back to Camping World tomorrow. The rest of the RV is great.
I have found two problems with my backup camera. one is the power plug behind the radio is a very loose connection and may cone loose. i taped them together. The second was the 6 pin connection in the back near the camera. The 6 pin to 6 pin connector wasn't making a good connection. I have going to get some contact cleaner and clean it.
__________________
hoytodom is offline   Reply With Quote
Old 04-12-2021, 04:46 PM   #7
I Think We're Lost!
 
Bob Denman's Avatar
 
Brand: Still Looking
Model: Tiffin Wayfarer 24 BW
State: New York
Posts: 22,080
THOR #8860
Quote:
Originally Posted by hoytodom View Post
I have found two problems with my backup camera. one is the power plug behind the radio is a very loose connection and may cone loose. i taped them together. The second was the 6 pin connection in the back near the camera. The 6 pin to 6 pin connector wasn't making a good connection. I have going to get some contact cleaner and clean it.
Welcome to the forum!
__________________
"What: me worry?"
Good Sam Member 843599689
Current coach: Tiffin Wayfarer 24 BW
Bob Denman is offline   Reply With Quote
Old 04-13-2021, 03:18 AM   #8
Senior Member
 
Elite Washington's Avatar
 
Brand: Thor Motor Coach
State: Washington
Posts: 905
THOR #6433
Congratulations and welcome glad it looks like you got your problem fixed
__________________
2017 Freedom Elite 30fe 2013 Wrangler Unlimited toad.
Elite Washington is offline   Reply With Quote
Reply

Tags
axxera radio, new member

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Thor Industries or any of its affiliates. This is an independent, unofficial site.




All times are GMT. The time now is 06:26 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2022, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0 PL2