Go Back   Thor Forums > Thor Community Forums > Thor Owners Community Discussions
Click Here to Login
Reply
 
Thread Tools Display Modes
 
Old 06-01-2020, 10:11 PM   #1
Junior Member
 
State: Alabama
Posts: 3
THOR #19048
Air conditioner doesnít work when generator is running

We have a Thor 2018 Palazzo 36.1 diesel class A.

My air conditioner runs fine when itís plugged into AC, but will not run when generator is on.

Any ideas?
__________________

__________________
Schembre04 is offline   Reply With Quote
Old 06-01-2020, 11:03 PM   #2
Site Team
 
16ACE27's Avatar
 
Brand: Thor Motor Coach
Model: ACE 27.1
State: Florida
Posts: 4,355
THOR #7035
Are you talking about one or both air conditioners? If this problem is confined to a single A/C then you probably have a problem with either one of the output breakers on the generator or the Automatic Transfer Switch (ATS) or the connections to it from the generator.
__________________

__________________
Ted & Melinda
2016 ACE 27.1
2016 Chevy Sonic Toad
16ACE27 is offline   Reply With Quote
Old 06-02-2020, 01:32 AM   #3
Senior Member
 
Mo_Mike's Avatar
 
Brand: Thor Motor Coach
Model: Vegas 25.2
State: Missouri
Posts: 993
THOR #4687
Quote:
Originally Posted by 16ACE27 View Post
Are you talking about one or both air conditioners? If this problem is confined to a single A/C then you probably have a problem with either one of the output breakers on the generator or the Automatic Transfer Switch (ATS) or the connections to it from the generator.
I vote for transfer switch. We have had problems twice with connections in the ATS. The first time a loose connection on neutral let the AC barely run.
__________________
Mo_Mike is offline   Reply With Quote
Old 06-02-2020, 02:37 AM   #4
Junior Member
 
State: Alabama
Posts: 3
THOR #19048
That is what we were thinking as well. We are leaving for a 2 week trip in the RV on Sunday. Might not be able to get it fixed by then, but not anticipating needing the air conditioner until we get to the KOA.

Thank you. We are new to this forum. So appreciate your advice.
__________________
Schembre04 is offline   Reply With Quote
Old 06-02-2020, 04:15 AM   #5
Site Team
 
16ACE27's Avatar
 
Brand: Thor Motor Coach
Model: ACE 27.1
State: Florida
Posts: 4,355
THOR #7035
Quote:
Originally Posted by Schembre04 View Post
That is what we were thinking as well. We are leaving for a 2 week trip in the RV on Sunday. Might not be able to get it fixed by then, but not anticipating needing the air conditioner until we get to the KOA.

Thank you. We are new to this forum. So appreciate your advice.
I would not put it off. This type of problem is caused by loose connections.
Loose connections cause heat.
Heat causes fires.
__________________
Ted & Melinda
2016 ACE 27.1
2016 Chevy Sonic Toad
16ACE27 is offline   Reply With Quote
Old 06-02-2020, 10:52 AM   #6
Junior Member
 
State: Alabama
Posts: 3
THOR #19048
Makes sense thanks again!
__________________
Schembre04 is offline   Reply With Quote
Old 06-02-2020, 11:42 AM   #7
Senior Member
 
Judge's Avatar
 
Brand: Thor Motor Coach
Model: 2020 Magnitude SV34
State: Florida
Posts: 925
THOR #12751
You might want to look at this post as well.... assuming all other 120v appliances work on generator power.

https://www.thorforums.com/forums/f8...lem-21828.html
__________________
Judge is offline   Reply With Quote
Old 06-02-2020, 12:12 PM   #8
Site Team
 
EA37TS's Avatar
 
Brand: Entegra
Model: Accolade 37TS
State: Virginia
Posts: 4,219
THOR #1469
If you turn off your inverter are you getting power to your residential fridge? A bad ATS connection will impact that as well as the AC. When the inverter is on the power comes from the batteries so turn the inverter off and check while the generator is running.
__________________
Dave
US Army (Ret)
2020 Entegra Accolade 37TS
2019 Jeep Grand Cherokee Trailhawk (Toad)
FMCA - F432054
EA37TS is offline   Reply With Quote
Old 06-02-2020, 12:24 PM   #9
Thor Palazzo 33.3 diesel
 
TurnerFam's Avatar
 
Brand: Thor Motor Coach
Model: Palazzo 33.3 34'bunkhouse
State: Georgia
Posts: 2,297
THOR #4735
I would think it's actually pretty simple - your generator's own BREAKER has tripped, on the generator itself. It will still 'run', but won't put out any 120v power to run the a/c unit...

it 'could' be your ATS, but I would check the breaker first. If the breaker is reset and it still does not provide power to the a/c unit when running, then remove the ATS cover, and while no shore or gen power, tighten ALL connections. This is not that all uncommon, since when the factory first installs the ATS, and the Main Breaker panel connections, they tighten them while 'cold', but when the generator is running, or shore power is in play, the ATS then has 'hot' wires that can create issues if the connection then loosens over time, which can easily happen.
__________________

__________________
the Turners
'14 Palazzo 33.3 bunkhouse 34' diesel
KingTailgater2 Dish HD, 100w/5a SOLAR, BlueOx
100,000+mi since '14 - US, Alaska, Canada - Hiawassee, GA! (also, '14 Gulfstream Amerilite and '07 ForestRiver Rockwood) : )
TurnerFam is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Thor Industries or any of its affiliates. This is an independent, unofficial site.




All times are GMT. The time now is 12:58 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0 PL2
×