RV News RVBusiness 2021 Top 10 RVs of the Year, plus 56 additional debuts and must-see units → ×
 

Go Back   Thor Forums > Thor Community Forums > Thor Owners Community Discussions
Click Here to Login
Reply
 
Thread Tools Display Modes
 
Old 07-10-2016, 08:01 AM   #1
Junior Member
 
Brand: Thor Motor Coach
Model: Hurricane 34J
State: California
Posts: 2
THOR #4768
LCI Levelling System

We just bought a new Hurricane 34J and had a very brief walk-through because the dealership was running behind and it was the end of the day on a Friday. Well, they didn't show me how to work the levelling system and now as we prepare to take it out on our first trip, on a weekend of course, I cannot get the LCI panel to turn on. No matter how much I press the on button, it will not turn on. I have the vehicle running and the parking break set. I have checked all of the cabin fuses and breakers. I even checked the in-line fuse in the basement next to the pump and motor. Has anyone had an issue like this?
__________________

__________________
RLK3 is offline   Reply With Quote
Old 07-10-2016, 09:09 AM   #2
Member
 
Brand: Thor Motor Coach
Model: A.C.E. 27.1
State: Texas
Posts: 64
THOR #2240
Hi,
Sorry to hear your problems.
Just a quick thought... do you have the Store/Use switch in the Use position, not sure if this has an effect but l think it does.
__________________

__________________
Texan is offline   Reply With Quote
Old 07-10-2016, 03:29 PM   #3
Senior Member
 
Oneilkeys's Avatar
 
Brand: Still Looking
Model: Travato
State: Florida
Posts: 2,435
THOR #1765
I don't have a leveling system so I am not sure of this, but in my Axis you cannot bring in or let out the slides with the engine on. It is a safety feature so they cannot be deployed while you are driving. Should be the same with the levelers.
__________________
Oneilkeys is offline   Reply With Quote
Old 07-11-2016, 05:42 AM   #4
Senior Member
 
fivejackie's Avatar
 
Brand: Thor Motor Coach
Model: Hurricane 27K
State: California
Posts: 121
THOR #1226
It could be a circuit breaker. There are a 50 and 100 amp breakers in the pump compartment. The 50 amp is near the front, but the 100 amp is way in the back. You might have to move some cables to see it. Look hard its there.
Another 50 amp it in the left front of the engine compartment.
I had the 100 amp blow once. I argued with the Thor tech that there wasn't a 100 amp breaker in the pump compartment. I looked once more and moved some cables and there it was, the breaker was blown. After resetting it, life was good.

Good Luck.
__________________
Don and Jackie

2015 Hurricane 27K
2013 Redhawk
1988 Pace Arrow
fivejackie is offline   Reply With Quote
Old 07-11-2016, 12:33 PM   #5
Site Team
 
EA37TS's Avatar
 
Brand: Entegra
Model: Accolade 37TS
State: Virginia
Posts: 4,823
THOR #1469
Congrats on the coach.

Another forum member had a similar issue with a different model. His issue was a large circuit breaker in the engine compartment would not allow his levelers to power on. Might want to check in the engine compartment to see if you have one of those large breakers that might be tripped.
__________________
Dave
US Army (Ret)
2020 Entegra Accolade 37TS
2019 Jeep Grand Cherokee Trailhawk (Toad)
FMCA - F432054
EA37TS is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Thor Industries or any of its affiliates. This is an independent, unofficial site.




All times are GMT. The time now is 02:56 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0 PL2
×