Journey with Confidence RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Take a Speed Test Free 7 Day Trial ×
 

Go Back   Thor Forums > Thor Community Forums > Thor Owners Community Discussions
Click Here to Login
Reply
 
Thread Tools Display Modes
 
Old 04-01-2024, 02:40 AM   #1
Junior Member
 
Bob n Cindy's Avatar
 
Brand: Thor Motor Coach
Model: Miramar
State: Kentucky
Posts: 29
THOR #1533
Lippert Not Working

Hi Folks
Need help/advice
I have a 2014 Miramar 34.2. All my house lights and 12v items quit on me. I replaced the 2 house batteries (6 volt) and chassis battery since the were 7 years old. Still no luck, so I replaced the converter. All my 12volt items work except the leveling system and the radio. I checked all connections and fuses which all checked out to include the 100amp switch. Does anyone have an idea what's wrong? I am out of ideas and it's driving me crazy. When you turn on the LCI Electronic Leveling system it is telling me "Low Voltage". I have tried reseting it but no luck. Please help, thanks in advance.

__________________
Bob and Cindy
USA, MSG (Ret) - USA (Civ)
Dottie & Boomer (Border Collies)
2014 Miramar 34.2
Rineyville, KY (Fort Knox)
Bob n Cindy is offline   Reply With Quote
Old 04-01-2024, 03:40 AM   #2
Site Team
 
16ACE27's Avatar
 
Brand: Thor Motor Coach
Model: ACE 27.1
State: Florida
Posts: 14,295
THOR #7035
The leveling system requires the engine/alternator to be running/charging to clear the "Low Voltage" warning. Emergency brake also needs to be set. There should also be a 100 amp BREAKER near the house batteries that supplies house battery power to the leveling hydraulic motor.

Other issues you may have with the given history:
USE/STORE latching relay not in USE
Battery cables not properly installed.
50 AMP DC breaker for House loads tripped.
__________________
Ted & Melinda
2016 ACE 27.1
2016 Chevy Sonic Toad - Selling
2020 Chevy Colorado Z71 Trail Runner Toad
2024 Chevrolet Trax 2RS - Soon 2B TOAD
16ACE27 is offline   Reply With Quote
Old 04-01-2024, 04:04 AM   #3
Site Team
 
EA37TS's Avatar
 
Brand: Entegra
Model: Accolade 37TS
State: South Dakota
Posts: 8,756
THOR #1469
Your system should be the same as our 2015 Challenger was. When first turning on power to the leveling system I would also get the low voltage error. I would raise the idle speed using the accelerator until the LCI monitor read over 13 volts and then reduce the idle and level.
__________________
EA37TS is offline   Reply With Quote
Old 04-03-2024, 01:58 AM   #4
Junior Member
 
Bob n Cindy's Avatar
 
Brand: Thor Motor Coach
Model: Miramar
State: Kentucky
Posts: 29
THOR #1533
I've tried all possible problems listed. Only thing left is the converter. I ordered a new WF9855. When it arrived, the box confirmed that it was a WF-9855. It looked exactly like the one I replaced except the one I replaced required 2-35volt fuses. The new one stated that it took 2-40 amp fuses. As I was taking a picture of the label, I noticed it said WF-8955. All the input and output numbers are exactly the same. Plus, it is in a sealed box where all the WF-8955 that I found online are not in a sealed case. I have a call in to the folks at WFCO waiting for a call back to see ii the unit is miss labeled. It sure doesn't look like the WF-8955 that I can find. Any thoughts?
__________________
Bob and Cindy
USA, MSG (Ret) - USA (Civ)
Dottie & Boomer (Border Collies)
2014 Miramar 34.2
Rineyville, KY (Fort Knox)
Bob n Cindy is offline   Reply With Quote
Old 04-03-2024, 02:24 AM   #5
Site Team
 
16ACE27's Avatar
 
Brand: Thor Motor Coach
Model: ACE 27.1
State: Florida
Posts: 14,295
THOR #7035
Quote:
Originally Posted by Bob n Cindy View Post
I've tried all possible problems listed. Only thing left is the converter. I ordered a new WF9855. When it arrived, the box confirmed that it was a WF-9855. It looked exactly like the one I replaced except the one I replaced required 2-35volt fuses. The new one stated that it took 2-40 amp fuses. As I was taking a picture of the label, I noticed it said WF-8955. All the input and output numbers are exactly the same. Plus, it is in a sealed box where all the WF-8955 that I found online are not in a sealed case. I have a call in to the folks at WFCO waiting for a call back to see ii the unit is miss labeled. It sure doesn't look like the WF-8955 that I can find. Any thoughts?
If you replaced the converter and all 12 VDC loads work except the radio and levelers, another new converter won't change that.
__________________
Ted & Melinda
2016 ACE 27.1
2016 Chevy Sonic Toad - Selling
2020 Chevy Colorado Z71 Trail Runner Toad
2024 Chevrolet Trax 2RS - Soon 2B TOAD
16ACE27 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Thor Industries or any of its affiliates. This is an independent, unofficial site.




All times are GMT. The time now is 04:38 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2024, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0 PL2