Journey with Confidence RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Take a Speed Test Free 7 Day Trial ×
 

Go Back   Thor Forums > Thor Motorcoach & Motorhome > Class C and Super C Motorhomes
Click Here to Login
Reply
 
Thread Tools Display Modes
 
Old 05-08-2021, 01:38 PM   #1
Member
 
Brand: Thor Motor Coach
Model: 2021 Chateau 28A
State: North Carolina
Posts: 69
THOR #23131
"Service Advance Trac" Message

2021 E450, Seems driving in high wind condition triggers this event. Happened to me 3x's now, haven't reached 3k on odometer yet. Researched the condition and found this: https://ford.oemdtc.com/6905/illumin...-ford-e-series, and this https://static.nhtsa.gov/odi/tsbs/20...83393-0001.pdf

Stopping the vehicle and shutting it down for 1-2 minutes and restarting clears the problem and you are good to go again. I am going to throw the BS Flag on this statement in the bulletin "This condition does not create drivability concerns". When you are driving at 60+mph with a crosswind and this malfunction occurs, you will know it instantly, and while I won't say its dangerous, it most certainly was startling and a serious cause for concern when it happened for the first time, now not so much.

I live on the OBX so wind is always present as demonstrated by Wilbur and Orville.

__________________
rtaggio is offline   Reply With Quote
Old 05-08-2021, 02:58 PM   #2
Senior Member
 
Brand: Thor Motor Coach
Model: Axis 24.1
State: Connecticut
Posts: 1,361
THOR #20289
It has happened to me twice on my E350 chassis based 2021 Thor Axis. The second time I was traveling on smooth Interstate with no crosswind. The message cleared after shutting down and restarting.

Interesting that there is no solution yet. On the iRV Ford Chassis forum: https://www.irv2.com/forums/f23/new-...ge-532864.html, there was a report that a cable melted underneath near the muffler and that caused it. I am going to check my Axis out for this next week.

So the problem apparently affects E350, E450 and F53 chassis.

David
__________________
DavidEM is offline   Reply With Quote
Old 05-08-2021, 03:43 PM   #3
Member
 
Brand: Thor Motor Coach
Model: 2021 Chateau 28A
State: North Carolina
Posts: 69
THOR #23131
David,
Please post your findings, and if you do find melted wires/cables please post photos also.
Thanks,
Rocky
__________________
rtaggio is offline   Reply With Quote
Old 05-10-2021, 07:58 PM   #4
Junior Member
 
Brand: Thor Motor Coach
State: Oklahoma
Posts: 1
THOR #23125
It has happened to me 3x on my E350 chassis based 2021 Thor Vegas. The third time I was traveling on smooth Interstate with little crosswind. The message cleared after shutting down and restarting.
__________________
kd5uaf is offline   Reply With Quote
Old 05-10-2021, 09:39 PM   #5
Senior Member
 
Scubawise's Avatar
 
Brand: Thor Motor Coach
Model: Vegas 25.6
State: New Mexico
Posts: 3,656
THOR #20220
hey did this come standard on your coach or installed?
__________________
LAS CRUCES 2020 Thor Vegas 25.6
Lora & George. 2 Golden Retrievers (age 13 & 9). Happy Campers!! E Biking, Hiking, Tennis, Scuba,Fishing,Cross Country Skiing, Snowshoeing. Retired H.S. Principal, Sr. IT Engineer, Life & Health Insurance Agent
"Today is a Gift and Why it is called the Present"
Scubawise is offline   Reply With Quote
Old 05-10-2021, 10:16 PM   #6
Member
 
Brand: Thor Motor Coach
Model: 2021 Chateau 28A
State: North Carolina
Posts: 69
THOR #23131
Quote:
Originally Posted by Scubawise View Post
hey did this come standard on your coach or installed?
Yes, Standard on my chassis
__________________
rtaggio is offline   Reply With Quote
Old 05-10-2021, 10:17 PM   #7
Senior Member
 
Judge's Avatar
 
Brand: Thor Motor Coach
Model: 2020 Magnitude SV34
State: Florida
Posts: 3,821
THOR #12751
Interesting.....

I have a 2020 Magnitude on a 2019 F-550 Chassis. Three times in the last year after stopping at a rest stop I would get a Stabil Trak / Advance Track error on the display. If I shut off the coach and restarted it, the error cleared.

I had the coach at Ford today for a State Inspection and to have them look at this error. They said the code was gone but I had it saved in my ODBII Scanner. The code said was for a steering wheel postiton sensor. Ford said they could not find anything wrong.

If it happens again, I am going to stop at Ford to have them pull the code immediately. This is what I found online for my code:

Make: Ford

Code: C0051:64

Definition: Steering Wheel Position Sensor: Signal Plausibility Failure

Cause: This DTC sets in continuous memory and on-demand if the difference between the steering wheel angle signal and the calculated reference signal is too high or if the steering wheel angle sensor does not match other stability control sensor inputs (yaw rate, lateral acceleration, longitudinal acceleration, roll rate).

Failure Type: Signal Plausibility Failure
This sub type is used for failures where the control module detects a single input parameter for plausibility.
__________________
Judge is offline   Reply With Quote
Old 05-10-2021, 10:21 PM   #8
Member
 
Brand: Thor Motor Coach
Model: 2021 Chateau 28A
State: North Carolina
Posts: 69
THOR #23131
Just turned 3.1k today and I've had this malfunction at least 4x's. It is almost expected now. I will say definitely not a real big deal as you just have to shut down completely then restart, its just a PITA. On the other hand the 1st time it spooked me because I'm new to the motorhome thing and it was day 3 of owning it with under 1k miles, 650 of that was from Thor to the dealer.
__________________
rtaggio is offline   Reply With Quote
Old 05-10-2021, 10:57 PM   #9
Senior Member
 
Scubawise's Avatar
 
Brand: Thor Motor Coach
Model: Vegas 25.6
State: New Mexico
Posts: 3,656
THOR #20220
Good luck everyone..I would be frustrated going crazy have this fixed!
__________________
LAS CRUCES 2020 Thor Vegas 25.6
Lora & George. 2 Golden Retrievers (age 13 & 9). Happy Campers!! E Biking, Hiking, Tennis, Scuba,Fishing,Cross Country Skiing, Snowshoeing. Retired H.S. Principal, Sr. IT Engineer, Life & Health Insurance Agent
"Today is a Gift and Why it is called the Present"
Scubawise is offline   Reply With Quote
Old 06-28-2021, 02:47 PM   #10
Member
 
Brand: Thor Motor Coach
Model: Freedom Elite 26HE
State: Maryland
Posts: 60
THOR #19558
Well, a little late to this thread but it happened to me yesterday in my 2021 Freedom Elite on the -350 chassis. We are just at 10Kmiles and in California. Heavy crosswinds. After shutting down, the light cleared.



Happy to know that it isn't a show stopper, but not happy it happened. We are getting an annual inspection here soon and I will have Ford look at it.
__________________
John and Carol and Daisy the Wonder Dog
US Army Retired
2021 Freedom Elite 26HE, the "RITA V"
Our other toy: a Cessna 182Q, N182MM
Johnandcarols is offline   Reply With Quote
Old 06-28-2021, 03:05 PM   #11
Member
 
Brand: Thor Motor Coach
Model: 2021 Chateau 28A
State: North Carolina
Posts: 69
THOR #23131
On I-70 thru KS last week we were dealing with strong crosswinds that kept knocking the Advance-Trac offline. I pulled over at 3 exits in a row to reset the system before finally caving in after the 4th time and "hand-flying" it the rest of the way.
__________________
rtaggio is offline   Reply With Quote
Old 06-28-2021, 03:09 PM   #12
Senior Member
 
The Gritz Carlton's Avatar
 
Brand: Thor Motor Coach
Model: THOR Chateua 35SF
State: Florida
Posts: 4,937
THOR #11130
It's happened on mine several times...seems to be just after a sharp turn from driveway or campsite, etc. Called a friend of mine at Ford dealer and he confirmed what Judge said. He said to just ignore it...it was not a fault but a notification. I ignore it and after a few miles it goes away.
__________________
2018 THOR Chateau 35SF
Two Labs, Bugsie & Blondie
The Gritz Carlton is offline   Reply With Quote
Old 06-28-2021, 03:15 PM   #13
Member
 
Brand: Thor Motor Coach
Model: 2021 Chateau 28A
State: North Carolina
Posts: 69
THOR #23131
Quote:
Originally Posted by The Gritz Carlton View Post
It's happened on mine several times...seems to be just after a sharp turn from driveway or campsite, etc. Called a friend of mine at Ford dealer and he confirmed what Judge said. He said to just ignore it...it was not a fault but a notification. I ignore it and after a few miles it goes away.
Either I am misunderstanding you or we are discussing different issues, but on my MH you can ignore the error message but until you stop and shut the vehicle down for at least 1 minute items such as the cruise control and hill asset will not work. On my last trip it occurred I drove almost 180miles ignoring it and it never went away.
__________________
rtaggio is offline   Reply With Quote
Old 06-28-2021, 03:45 PM   #14
Senior Member
 
Brand: Thor Motor Coach
Model: Axis 24.1
State: Connecticut
Posts: 1,361
THOR #20289
Quote:
Originally Posted by rtaggio View Post
Either I am misunderstanding you or we are discussing different issues, but on my MH you can ignore the error message but until you stop and shut the vehicle down for at least 1 minute items such as the cruise control and hill asset will not work. On my last trip it occurred I drove almost 180miles ignoring it and it never went away.
On my 2021 Axis with the E350 chassis.

There is a significant discussion on irv2.com Ford chassis subforum. It seems to be related to a failure of the "tone ring" on the rear axles. The tone ring is a serrated ring on the axle that provides speed data for the ABS system. How it fails is a mystery. Some have said it is also related to the cabling to the tone sensor.

And not surprisingly because Thor messes with that cable during the coach build, Ford points the finger at Thor and Thor points the finger at Ford. What a mess!

I hope that the NHTSB gets to the bottom of this problem.

David
__________________
DavidEM is offline   Reply With Quote
Old 07-08-2021, 12:55 AM   #15
Junior Member
 
Brand: Thor Motor Coach
Model: RC25
State: Virginia
Posts: 9
THOR #21090
I also have this problem on my 2021 Quantum RC25 (E450). I have had multiple occurrences (8–10) over 12K miles, mostly on interstate, with and without wind. It clears after restart, but sometimes reappears within 10 miles.
I am taking it to Ford in the coming weeks, and if I am “lucky” it will happen on the way to the shop so they can pull codes. Otherwise I’ll show them this thread for ideas.
It is more than an inconvenience to lose cruise control multiple times from Santa Fe to Washington D.C.!
If anyone gets to the bottom of this, please post whatever you find out.
Very frustrating, and makes me want to rethink my Ford vs. MB chassis decision!
__________________
taylojc is offline   Reply With Quote
Old 08-02-2021, 02:09 AM   #16
Member
 
Brand: Thor Motor Coach
Model: RS36
State: California
Posts: 53
THOR #24133
I have also had it in my 2022 Magnitude RS36 at least 3 times on my cross country trip. Sometimes it fixed itself in 10 min, sometimes hours. I had it happen on my Ford Expedition so I knew it was not a big deal, but what I do not like is you cannot use Tow/Haul mode which performs more aggressive down shifts when braking to help slow everything down.

I will bring it up when I take it in for oil change / service. But, without the code active, not much they can do.

Eric
__________________
elbenson is offline   Reply With Quote
Old 08-02-2021, 02:35 PM   #17
Senior Member
 
The Gritz Carlton's Avatar
 
Brand: Thor Motor Coach
Model: THOR Chateua 35SF
State: Florida
Posts: 4,937
THOR #11130
Quote:
Originally Posted by taylojc View Post
I also have this problem on my 2021 Quantum RC25 (E450). I have had multiple occurrences (8–10) over 12K miles, mostly on interstate, with and without wind. It clears after restart, but sometimes reappears within 10 miles.
I am taking it to Ford in the coming weeks, and if I am “lucky” it will happen on the way to the shop so they can pull codes. Otherwise I’ll show them this thread for ideas.
It is more than an inconvenience to lose cruise control multiple times from Santa Fe to Washington D.C.!
If anyone gets to the bottom of this, please post whatever you find out.
Very frustrating, and makes me want to rethink my Ford vs. MB chassis decision!

It doesn't have to happen on the way. If any fault trips a light on the dash, that fault code will stay in the computer and they will get the code when they scan it.
__________________
2018 THOR Chateau 35SF
Two Labs, Bugsie & Blondie
The Gritz Carlton is offline   Reply With Quote
Old 01-24-2022, 10:02 PM   #18
Junior Member
 
Brand: Thor Motor Coach
State: Colorado
Posts: 2
THOR #24118
Service Advance Track issue

I had this issue on my first trip after purchasing a Thor Axis 24.1 last March 2021.

I took it to a local dealer who reluctantly took it in and reset some software. That seemed to work until my next trip when it happened again. I live in Colorado so 20mph side winds are common.

I then took it to the only place in the state of Colorado that would even look at a class A motorhome and they kept it for over a month before telling me that they would no longer be working on Class A motorhomes!!! (thank you Rush Ford for such stellar customer service!!!)

I then took it over 550 miles to a place in Kansas City called Midway Ford Truck center. Polar opposite in terms of customer service. Top notch service. I still had to leave it there for almost a month but they took a look and fixed the problem permanently in 4 hours.

The issue: Extremely poor assembly from Thor when they connected the wiring from the Cassis to the RV. The Thor personnel pulled all the wires through this small round opening that had sharp edges. This caused the wires to lose their protective sleeves causing sporadic shorts. This caused the Advanced Track warnings. ABS warnings and even on occasion my blinkers didn't work.

To Thor's credit, they ended up paying for the repairs but this kind of poor workmanship should never be tolerated.
__________________
preisacher is offline   Reply With Quote
Old 01-26-2022, 11:25 PM   #19
Senior Member
 
Ottosails's Avatar
 
Brand: Thor Motor Coach
Model: SV34
State: Arizona
Posts: 242
THOR #24580
2021 Mag SV34 - I've experienced it as well. I feel like it comes on shortly after start up and a short period of driving when I start up quickly and take off. I now try to turn the key to "On" and wait for all of the dinging and donging to stop and then fire up the motor, wait a few more seconds and then take off. It seems to happen more when I don't wait till all the dinging and donging has subsided and then pull out and accelerate up to speed.

Not scientific but its my theory. :-)
__________________
RV: 2021 Class C Magnitude SV34
Toad: 2015 2dr Jeep Wrangler
Motorcycles: BMW K 1600 B, Harley Davidson Heritage Softail (EVO)
Ottosails is offline   Reply With Quote
Old 08-17-2022, 08:45 PM   #20
Member
 
makitso's Avatar
 
Brand: Thor Motor Coach
Model: Thor Four Winds 31WV
State: Arizona
Posts: 81
THOR #20429
Quote:
Originally Posted by rtaggio View Post
2021 E450, Seems driving in high wind condition triggers this event. .
I can confirm that crosswinds do trigger this error. I think that different tire diameter resulting from the crosswinds, is the problem.
__________________
makitso is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Thor Industries or any of its affiliates. This is an independent, unofficial site.




All times are GMT. The time now is 05:44 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2023, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0 PL2