Journey with Confidence RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Take a Speed Test Free 7 Day Trial ×
 

Go Back   Thor Forums > Thor Motorcoach & Motorhome > Class B & B+ Motorhomes
Click Here to Login
Reply
 
Thread Tools Display Modes
 
Old 10-28-2023, 10:11 PM   #1
Junior Member
 
Brand: Thor Motor Coach
State: Minnesota
Posts: 5
THOR #31174
Surge Protector problem

I've been using a Progressive Industries SSP-30XL surge protector for 3 years. Normally, the green and blue LEDs are ON and the red LED is OFF. Now the blue is ON so I have shore power but the green is OFF which means I don't have surge protection. I did some troubleshooting with my multi-meter and determined the green LED is bad. I am trying to find the schematic to this circuit board and parts list so I can replace the defective LED. Any suggestions?
Regards, Gray Nomad.

__________________
GrayNomad is offline   Reply With Quote
Old 10-28-2023, 11:08 PM   #2
Site Team
 
EA37TS's Avatar
 
Brand: Entegra
Model: Accolade 37TS
State: South Dakota
Posts: 8,767
THOR #1469
Quote:
Originally Posted by GrayNomad View Post
I've been using a Progressive Industries SSP-30XL surge protector for 3 years. Normally, the green and blue LEDs are ON and the red LED is OFF. Now the blue is ON so I have shore power but the green is OFF which means I don't have surge protection. I did some troubleshooting with my multi-meter and determined the green LED is bad. I am trying to find the schematic to this circuit board and parts list so I can replace the defective LED. Any suggestions?
Regards, Gray Nomad.

Call progressive industries, they should be able to assist unless they consider what youíre asking for to be proprietary and sensitive info.
__________________
Dave
US Army (Ret)
2020 Entegra Accolade 37TS
2019 Jeep Grand Cherokee Trailhawk (Toad)
FMCA - F432054
EA37TS is offline   Reply With Quote
Old 10-28-2023, 11:18 PM   #3
Junior Member
 
Brand: Thor Motor Coach
State: Minnesota
Posts: 5
THOR #31174
Thanks Dave, just trying to fix my surge protector by replacing a one dollar part instead of paying $100 to buy a new surge protector. Hopefully, asking for the part number of the LED won't be seen as proprietary. Gray Nomad.
__________________
GrayNomad is offline   Reply With Quote
Old 10-28-2023, 11:23 PM   #4
Senior Member
 
paulwadley's Avatar
 
Brand: Thor Motor Coach
Model: Miramar 37.1
State: California
Posts: 2,494
THOR #12698
Gary

Progressive Industries may ask for you to send them your old one and either replace it or repair it for free if you ask them.

Paul
__________________
paulwadley is offline   Reply With Quote
Old 10-28-2023, 11:53 PM   #5
Junior Member
 
Brand: Thor Motor Coach
State: Minnesota
Posts: 5
THOR #31174
Thanks Paul, Progressive Industries has a limited lifetime warranty which says it covers the internal electronics as well as the parts and materials within the unit housing. They don’t cover damage to the outside of the unit, including the weather shield on some models. The warranty also doesn’t cover labor or shipping charges. I might as well buy a new one if I get the LED part number so I can replace it myself. Gray Nomad.
__________________
GrayNomad is offline   Reply With Quote
Old 10-29-2023, 01:48 AM   #6
Senior Member
 
Brand: Thor Motor Coach
Model: Chateau 24F
State: Ohio
Posts: 4,165
THOR #16721
Quote:
Originally Posted by GrayNomad View Post
Thanks Paul, Progressive Industries has a limited lifetime warranty which says it covers the internal electronics as well as the parts and materials within the unit housing. They donít cover damage to the outside of the unit, including the weather shield on some models. The warranty also doesnít cover labor or shipping charges. I might as well buy a new one if I get the LED part number so I can replace it myself. Gray Nomad.
Do you have basic electronics and soldering skills? Do you understand how LEDs work and familiar with sourcing them? They're dirt cheap!

If so, AND that's all that's wrong... (good luck) take it apart and solder in a new LED. Inspect the internals for fried components, then re-seal it and test.

Even if it doesn't work you're only out the cost of a cheap LED and an hour or so of your time!
__________________
Chateau_Nomad is offline   Reply With Quote
Old 10-29-2023, 02:55 AM   #7
Senior Member
 
Brand: Thor Motor Coach
Model: Hurricane 29M
State: Texas
Posts: 2,712
THOR #11781
I would email PI and see what they say. They have replaced 2 units for me free of charge with no shipping costs. If you open the unit and fix it, you will void the warranty. If they send you a new unit, you could always repair the old one and have a spare.
__________________
Lt Keefer
2018 Hurricane 29M
CHF, Saf-T-Plus, SumoSprings
Lt Keefer is online now   Reply With Quote
Old 10-29-2023, 03:49 AM   #8
Senior Member
 
Brand: Thor Motor Coach
Model: Chateau 24F
State: Ohio
Posts: 4,165
THOR #16721
Quote:
Originally Posted by Lt Keefer View Post
I would email PI and see what they say. They have replaced 2 units for me free of charge with no shipping costs. If you open the unit and fix it, you will void the warranty. If they send you a new unit, you could always repair the old one and have a spare.
Great advice! Although not a PI unit, I think dkoldman returned a faulty "some other brand" pedestal unit and had it repaired? Progressive Industries is an upstanding company... they might surprise you with a replacement...

DEFINITELY call or email FIRST before trying a self repair. I have a hardwired PI EMS and it has worked flawlessly.
__________________
Chateau_Nomad is offline   Reply With Quote
Old 10-29-2023, 02:33 PM   #9
Junior Member
 
Brand: Thor Motor Coach
State: North Carolina
Posts: 21
THOR #30527
I have had two Progressive surge protectors (one 50 amp and a 30 amp) replaced by them under warranty without having to send back the old unit or pay any charges and they are a great company to work with. Just go to their website and describe the problem and they will get back with you promptly. In my case, they instructed me to destroy the defective ones and they sent me new replacements. You will need a copy of your receipt showing proof of purchase and they request that you take a picture of the unit causing problems.
__________________
2022 Thor Tellaro L (2800 Onan and Lithium)
2012 Monaco 40' Knight (sold)
Campguy21 is offline   Reply With Quote
Old 10-29-2023, 03:58 PM   #10
Senior Member
 
dkoldman's Avatar
 
Brand: Still Looking
Model: Sunstar 29VE Winnebago
State: Texas
Posts: 5,633
THOR #13058
I have both Southwire 50 amp surge protectors the basic model https://www.campingworld.com/southwi...B&gclsrc=aw.ds and the $400 wireless model
https://www.campingworld.com/southwi...B&gclsrc=aw.ds

I bought both from Techno RV when RV was new.

About a year ago, I got an email from Techno RV letting me know the wireless model ( the $400 unit) had been upgraded to work with a Southwire Phone App. So I downloaded the software and while it connected wirelessly to my phone it was doing some funky things. So I called Southwire and they told me the version I had was not compatible with the new app Then they said if I sent it back they would upgrade with a the new firmware for free So I sent back maybe $12 of shipping confirming with them the tracking number as they requested. Literally the next day after they had received my unit I get a package from Southwire, it was brand new Wireless Southwire 50 amp surge guard, I couldn't believe it. Turns out they shipped the new one before they had received the old one. I was already a Southwire Nutt, now I am a Southwire Fanatic. I won't even consider anything but Southwire. I put a premium on real Customer Service. FWIW, the only reason I did not buy the Progressive Watchdog at the beginning was when I called to ask about turning OFF the white light on dog emblem; they told me to get some black tape

Also for FWIW II, as some may wonder why I have two Surge guards.

I use the cheap one to verify the pedestal. It is the only one I leave on the pedestal at a campsite. I don't bother with trying to lock it on pedestal. If all is good I connect to my $400 unit that is mounted in my electrical bay. While it too is portable, I never take it out of the Electrical bay and the electrical bay is always locked. I have two wireless displays and now my phone to read everything happening with the $400 unit. At campsites, you might say, I have double protection on outside power. No complex codes, simple language to tell you what is wrong.
__________________
2019 Sunstar 29ve; Toad Lincoln Navigator; RVi Brake 3 & Command Center; Roadmaster Nighthawk Tow bar & Baseplate; Sumo Springs; Safe T Plus; Onan EC-30 AGS; Vmax 250ah AGM; T-Mobile Internet; H/W Heater / Chassis Disconnect Switches; Southwire Surge Guard 44270 & 34951 w/Monitor 40301; Jet Flo Macerator; Alpine SPE500 Speakers; Visio M21D-H8R
dkoldman is offline   Reply With Quote
Old 10-29-2023, 04:08 PM   #11
Senior Member
 
dkoldman's Avatar
 
Brand: Still Looking
Model: Sunstar 29VE Winnebago
State: Texas
Posts: 5,633
THOR #13058
Quote:
Originally Posted by Chateau_Nomad View Post
Great advice! Although not a PI unit, I think dkoldman returned a faulty "some other brand" pedestal unit and had it repaired? Progressive Industries is an upstanding company... they might surprise you with a replacement...

DEFINITELY call or email FIRST before trying a self repair. I have a hardwired PI EMS and it has worked flawlessly.

True dat, I elaborate in Post #10 if the Progressives don't kick me out this thread. I am not only a SOB with a RV, but looks like I am a Surge Guard SOB too
__________________
2019 Sunstar 29ve; Toad Lincoln Navigator; RVi Brake 3 & Command Center; Roadmaster Nighthawk Tow bar & Baseplate; Sumo Springs; Safe T Plus; Onan EC-30 AGS; Vmax 250ah AGM; T-Mobile Internet; H/W Heater / Chassis Disconnect Switches; Southwire Surge Guard 44270 & 34951 w/Monitor 40301; Jet Flo Macerator; Alpine SPE500 Speakers; Visio M21D-H8R
dkoldman is offline   Reply With Quote
Old 10-29-2023, 04:36 PM   #12
Site Team
 
EA37TS's Avatar
 
Brand: Entegra
Model: Accolade 37TS
State: South Dakota
Posts: 8,767
THOR #1469
Quote:
Originally Posted by dkoldman View Post
True dat, I elaborate in Post #10 if the Progressives don't kick me out this thread. I am not only a SOB with a RV, but looks like I am a Surge Guard SOB too

Nothing wrong with Surge Guard. I had one for years when we had our 30amp Class C.
__________________
Dave
US Army (Ret)
2020 Entegra Accolade 37TS
2019 Jeep Grand Cherokee Trailhawk (Toad)
FMCA - F432054
EA37TS is offline   Reply With Quote
Old 10-30-2023, 01:53 AM   #13
Junior Member
 
Brand: Thor Motor Coach
State: Minnesota
Posts: 5
THOR #31174
Thanks Chateau. Lol...I'm an electrical engineer for 40 years now and in Amateur Radio for 50 years now. So, soldering and electronics troubleshooting are not a problem. I know how LED's function and could try a few but was hoping Progressive Industries would give me the correct part number. At least that's my first course of action. Regards, Gray Nomad.
__________________
GrayNomad is offline   Reply With Quote
Old 10-30-2023, 02:15 AM   #14
Junior Member
 
Brand: Thor Motor Coach
State: Minnesota
Posts: 5
THOR #31174
Thanks to everyone for the great advice. I'm definitely going to call and email Progressive Industries on Monday. Hopefully, they are as helpful as everyone has stated. Fingers crossed... Thanks again, Gray Nomad.
__________________
GrayNomad is offline   Reply With Quote
Old 11-01-2023, 05:45 PM   #15
Junior Member
 
Brand: Thor Motor Coach
State: North Carolina
Posts: 21
THOR #30527
Had a problem at a campsite pedestal recently and was glad I had the Progressive Tester and the Progressive 30 amp EMS surge protector. The Progressive Tester lights up after simply plugging it in to give you an idea if there is a problem before even plugging in the Progressive EMS surge guard. The tester showed "Open Circuit" when plugged in but decided to go ahead and plug in the surge guard afterwards to see if it also detected a problem. Surge Guard was showing all normal "E0" so decided to go ahead and plug the van in which probably should not have done?? Result was van had no power even after waiting the delay period.
Spoke with the campground manager and explained the problem and her reply was "what does open circuit mean"?. I told her was not an electrician and not sure what was going on but power was not coming on. She moved me to a different site and all tests were good and everything worked normally.
Maybe someone else here can explain what was going on but lesson learned and glad I did not waste time thinking I had a problem with the van and probably would have if it wasn/t for the initial test showing open circuit.
Attached Thumbnails
Click image for larger version

Name:	Progressive tester.jpg
Views:	14
Size:	44.9 KB
ID:	44017  
__________________
2022 Thor Tellaro L (2800 Onan and Lithium)
2012 Monaco 40' Knight (sold)
Campguy21 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Thor Industries or any of its affiliates. This is an independent, unofficial site.




All times are GMT. The time now is 07:08 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2024, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0 PL2