Journey with Confidence RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Take a Speed Test Free 7 Day Trial ×
 

Go Back   Thor Forums > Thor Motorcoach & Motorhome > Thor Motorhome General Discussions
Click Here to Login
Reply
 
Thread Tools Display Modes
 
Old 05-27-2022, 11:07 AM   #1
Junior Member
 
Brand: Thor Motor Coach
Model: Ace 32.1
State: Kentucky
Posts: 15
THOR #26578
Cummings generator won't start on my Thor Ace 32.1

Hello everyone,After picking up my rig from camping world in Marion(what a nightmare) from having the stereo and a inverter charger replaced I get home and tried to start my generator and it has no power..Iíve checked the breakers at the generator access panel and the breakers in my house battery locationÖEverything looked good,even reset all of them just in case.I tried calling the service department in Camping World to maybe troubleshoot the problem as it was working fine when the rig went in for repairs and they would only say we didnít work on your generator and you need to bring it in so the problem can be diagnosed.The young lady was had no clue and I asked to speak to the technician that worked on my rig and they wouldnít do that..Iím sure itís something simple he probably forgot to hook up but and canít get anywhere with the service department..Any suggestions would be greatly appreciated.Mike

__________________
BigDog32.1 is offline   Reply With Quote
Old 05-27-2022, 11:12 AM   #2
Senior Member
 
Brand: Thor Motor Coach
Model: Miramar
State: California
Posts: 641
THOR #22927
What is the condition of the coach batteries. If coach batteries are not fully charged, it will not start. Plug into shore power, get a good charge. Then try and start the generator.

Good luck.
__________________
Grumpy Grampa is offline   Reply With Quote
Old 05-27-2022, 11:47 AM   #3
Senior Member
 
Brand: Thor Motor Coach
Model: Miramar
State: California
Posts: 641
THOR #22927
Also be sure your storage/use switch is in use mode.
__________________
Grumpy Grampa is offline   Reply With Quote
Old 05-27-2022, 12:36 PM   #4
Site Team
 
16ACE27's Avatar
 
Brand: Thor Motor Coach
Model: ACE 27.1
State: Florida
Posts: 9,411
THOR #7035
Quote:
Originally Posted by Grumpy Grampa View Post
Also be sure your storage/use switch is in use mode.
Does not effect generator starting but needed to charge the house batteries when plugged in.
__________________
Ted & Melinda
2016 ACE 27.1
2016 Chevy Sonic Toad
2020 Chevy Colorado Z71 Trail Runner Alternate Toad
16ACE27 is offline   Reply With Quote
Old 05-27-2022, 12:38 PM   #5
Site Team
 
16ACE27's Avatar
 
Brand: Thor Motor Coach
Model: ACE 27.1
State: Florida
Posts: 9,411
THOR #7035
Quote:
Originally Posted by BigDog32.1 View Post
Hello everyone,After picking up my rig from camping world in Marion(what a nightmare) from having the stereo and a inverter charger replaced I get home and tried to start my generator and it has no power..Iíve checked the breakers at the generator access panel and the breakers in my house battery locationÖEverything looked good,even reset all of them just in case.I tried calling the service department in Camping World to maybe troubleshoot the problem as it was working fine when the rig went in for repairs and they would only say we didnít work on your generator and you need to bring it in so the problem can be diagnosed.The young lady was had no clue and I asked to speak to the technician that worked on my rig and they wouldnít do that..Iím sure itís something simple he probably forgot to hook up but and canít get anywhere with the service department..Any suggestions would be greatly appreciated.Mike
Your ACE has an Inverter/Charger?

Do your leveling jacks work?

If so - probably a generator problem.
If not, either the 100 amp DC breaker in you battery compartment is tripped or CW left off/mis-wired a cable to the batteries.
__________________
Ted & Melinda
2016 ACE 27.1
2016 Chevy Sonic Toad
2020 Chevy Colorado Z71 Trail Runner Alternate Toad
16ACE27 is offline   Reply With Quote
Old 05-27-2022, 02:20 PM   #6
Senior Member
 
The Gritz Carlton's Avatar
 
Brand: Thor Motor Coach
Model: THOR Chateua 35SF
State: Florida
Posts: 4,542
THOR #11130
One of the biggest issues with service departments...they don't plug them in while working on them. My vote is the battery charging issue as that may have killed the house batteries...how old are they?
__________________
2018 THOR Chateau 35SF
Two Labs, Bugsie & Blondie
The Gritz Carlton is offline   Reply With Quote
Old 05-28-2022, 01:01 AM   #7
Junior Member
 
Brand: Thor Motor Coach
Model: Ace 32.1
State: Kentucky
Posts: 15
THOR #26578
My leveling jacks don’t work either..I checked the breakers on the house batteries but nothing tripped..
__________________
BigDog32.1 is offline   Reply With Quote
Old 05-28-2022, 01:02 AM   #8
Junior Member
 
Brand: Thor Motor Coach
Model: Ace 32.1
State: Kentucky
Posts: 15
THOR #26578
My batteries are fully charged
__________________
BigDog32.1 is offline   Reply With Quote
Old 05-28-2022, 01:14 AM   #9
Site Team
 
EA37TS's Avatar
 
Brand: Entegra
Model: Accolade 37TS
State: South Carolina
Posts: 7,202
THOR #1469
Someone I know that that issue on an Ace a few years back. The problem was a 50 or 100 amp breaker located in the engine compartment was tripped. He had to call Thor and they told home where the breaker was located.

And yes, he had a breaker in the engine compartment on an Ace.
__________________
EA37TS is offline   Reply With Quote
Old 05-28-2022, 01:35 AM   #10
Site Team
 
16ACE27's Avatar
 
Brand: Thor Motor Coach
Model: ACE 27.1
State: Florida
Posts: 9,411
THOR #7035
Quote:
Originally Posted by EA37TS View Post
Someone I know that that issue on an Ace a few years back. The problem was a 50 or 100 amp breaker located in the engine compartment was tripped. He had to call Thor and they told home where the breaker was located.

And yes, he had a breaker in the engine compartment on an Ace.
Yeah, I have a 100 amp breaker in the engine compartment on my ACE as well but it's for the Thor dash feeds from the chassis battery. The 100 amp breaker for the generator and hydraulic motor comes off the house batteries. It may not look tripped - push the button to trip it then reset it. If that doesn't work trace the battery side cable back and make sure it is on a POSITIVE battery post.
__________________
Ted & Melinda
2016 ACE 27.1
2016 Chevy Sonic Toad
2020 Chevy Colorado Z71 Trail Runner Alternate Toad
16ACE27 is offline   Reply With Quote
Old 05-28-2022, 11:06 AM   #11
Senior Member
 
Brand: Thor Motor Coach
Model: Freedom Traveller A27
State: North Carolina
Posts: 1,232
THOR #17765
The 100 amp breaker under the hood is blue. Should be around the battery. When mine is plugged into shore power, the house batteries charge through the chassis battery. Donít tell me thatís not so cuz I traced it. Worth a look.
__________________
Jimbo56 is offline   Reply With Quote
Old 05-28-2022, 12:39 PM   #12
Junior Member
 
Brand: Thor Motor Coach
Model: Ace 32.1
State: Kentucky
Posts: 15
THOR #26578
Thanks will try that
__________________
BigDog32.1 is offline   Reply With Quote
Old 05-28-2022, 05:26 PM   #13
Senior Member
 
Brand: Thor Motor Coach
State: South Carolina
Posts: 535
THOR #22342
ah this sounds so frustrating, have your RV serviced and now systems don't work. I have a standard process i use to run thru the systems, every other week, but i don't check the slide out or Jacks.

I see the battery panel shows FULL when entering the RV from the Solar panel charge, on go the RV lights, door shut behind me and steps retract.

I start engine and monitor the instrument on the dash to monitor the engine Alternator voltage and matching it to the panel voltage, both show over 14V, i am charging house batteries thru the engine ALT. The Cab AC goes on and SAT Radio go on.

Then i move onto the Generator, I listen for the the primer pump to go on, and hold for a few seconds, then engage the Generator start, I typically starts in a few seconds. I then let it warm up, listen for the transfer switch, and then turn on all the Main CB at the panel. This is confirmed with the beep on the Micro wave. Then i start the AC units one at a time. I do this every other week or so and can almost time everything on startup.

Finding a sequence to start up equip will help troubleshoot if something doesn't match.. And if something doesn't start or beep. I get really concerned.

I also refrain from having all AC units on when the main breaker is closed, very rookie like, tells me i didn't shutdown RV last time in sequence. This is what happens after service. The mechanics leave everything on and just shut down generator!! Check you GEN breakers back at the GEN panel. Maybe something tripped back there... and good luck
__________________
txc2936@yahoo.com is offline   Reply With Quote
Old 05-28-2022, 05:56 PM   #14
Senior Member
 
Scubawise's Avatar
 
Brand: Thor Motor Coach
Model: Vegas 25.6
State: New Mexico
Posts: 3,265
THOR #20220
Quote:
Originally Posted by BigDog32.1 View Post
Hello everyone,After picking up my rig from camping world in Marion(what a nightmare) from having the stereo and a inverter charger replaced I get home and tried to start my generator and it has no power..Iíve checked the breakers at the generator access panel and the breakers in my house battery locationÖEverything looked good,even reset all of them just in case.I tried calling the service department in Camping World to maybe troubleshoot the problem as it was working fine when the rig went in for repairs and they would only say we didnít work on your generator and you need to bring it in so the problem can be diagnosed.The young lady was had no clue and I asked to speak to the technician that worked on my rig and they wouldnít do that..Iím sure itís something simple he probably forgot to hook up but and canít get anywhere with the service department..Any suggestions would be greatly appreciated.Mike

I worked with Cummings a couple times and they gave me a nationwide 2 year warranty. They can also help you on the phone ..good luck
__________________
Scubawise is offline   Reply With Quote
Old 05-28-2022, 08:11 PM   #15
Site Team
 
EA37TS's Avatar
 
Brand: Entegra
Model: Accolade 37TS
State: South Carolina
Posts: 7,202
THOR #1469
Itís Cummins not Cummings.
__________________
EA37TS is offline   Reply With Quote
Old 05-28-2022, 08:31 PM   #16
Senior Member
 
OldWEB's Avatar
 
Brand: Thor Motor Coach
Model: 2011 FW Hurricane 33T
State: England
Posts: 886
THOR #16471
Quote:
Originally Posted by BigDog32.1 View Post
My leveling jacks donít work either..I checked the breakers on the house batteries but nothing tripped..
Follow the positive cable(s) from the generator and/or jack pump back to the batteries. No power indicates an open circuit.... cable off or breaker not resetting...
__________________
OldWEB is offline   Reply With Quote
Old 05-28-2022, 09:32 PM   #17
Senior Member
 
Scubawise's Avatar
 
Brand: Thor Motor Coach
Model: Vegas 25.6
State: New Mexico
Posts: 3,265
THOR #20220
Quote:
Originally Posted by EA37TS View Post
Itís Cummins not Cummings.
Sorry terrible state of mind
__________________
Scubawise is offline   Reply With Quote
Old 05-28-2022, 09:33 PM   #18
Senior Member
 
Scubawise's Avatar
 
Brand: Thor Motor Coach
Model: Vegas 25.6
State: New Mexico
Posts: 3,265
THOR #20220
Quote:
Originally Posted by OldWEB View Post
Follow the positive cable(s) from the generator and/or jack pump back to the batteries. No power indicates an open circuit.... cable off or breaker not resetting...
Cummins opens I think 7am and can usually have you drive to them for a quick look
__________________
Scubawise is offline   Reply With Quote
Old 05-28-2022, 11:30 PM   #19
Senior Member
 
macdaddy1111's Avatar
 
Brand: Thor Motor Coach
Model: Hurricane 35m
State: North Carolina
Posts: 559
THOR #13505
"problem as it was working fine when the rig went in for repairs"


As a betting man, I would Double on that hand that the shop jacked your rig up!
__________________
Retired Squid who has a retired squid that drives him around in a RV!
macdaddy1111 is offline   Reply With Quote
Old 05-29-2022, 02:27 AM   #20
Junior Member
 
Brand: Thor Motor Coach
Model: Ace 32.1
State: Kentucky
Posts: 15
THOR #26578
Iíve got shorepower and parked on a level concrete pad for the weekend anyway.Will try to trace the problem down after the Weekend.Just going to chill and not let this ruin my family time,but it is very frustrating to say the least..
__________________
BigDog32.1 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Thor Industries or any of its affiliates. This is an independent, unofficial site.




All times are GMT. The time now is 10:09 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2022, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0 PL2