RV News RVBusiness 2021 Top 10 RVs of the Year, plus 56 additional debuts and must-see units → ×
 

Go Back   Thor Forums > Thor Motorcoach & Motorhome > Thor Motorhome General Discussions
Click Here to Login
Reply
 
Thread Tools Display Modes
 
Old 01-05-2019, 02:44 AM   #1
Junior Member
 
Brand: Thor Motor Coach
State: Texas
Posts: 2
THOR #14106
Radio/turn signal

Hi. I recently purchased a new 2018 Thor hurricane class a.
It has a axxia radio that also houses the back up camera and side cameras.

When I turn on the blinkers the radio stops. Super annoying.

Anyone have a fix for this?
__________________

__________________
Darrenc75 is offline   Reply With Quote
Old 01-05-2019, 07:33 AM   #2
Member
 
Kickstand's Avatar
 
Brand: Thor Motor Coach
Model: Outlaw 29H Class C
State: California
Posts: 89
THOR #7010
I called Axxera about that after it was driving me nuts. No luck- they just said thatís how it works. The workaround Iíve found is to keep the backup camera on the screen at all times, then when you use the turn signals it will switch to side camera without turning music off.
__________________

__________________
Kickstand is offline   Reply With Quote
Old 01-05-2019, 11:33 AM   #3
Senior Member
 
Brand: Thor Motor Coach
Model: A. C. E. 30.1
State: Indiana
Posts: 120
THOR #1488
That is not how they all work. Our 2015 with that radio plays fine when in reverse or using the turn signals. That includes having the radio in "play" or "camera" where the rear camera stays on. I use that if I am pulling a trailer and it switches to the side when using the turn signals. Seems like I read on some forum a fix was found but don't remember where or what was done. Jim.
__________________
04fxsts is offline   Reply With Quote
Old 01-05-2019, 02:11 PM   #4
Site Team
 
16ACE27's Avatar
 
Brand: Thor Motor Coach
Model: ACE 27.1
State: Florida
Posts: 5,163
THOR #7035
Yep, our 2016 keeps playing as well. Our complaint is that you can't change the volume on the radio with the turn signal camera triggered.

I believe that the people that got your issue "fixed" had to do a firmware update.
__________________
Ted & Melinda
2016 ACE 27.1
2016 Chevy Sonic Toad
2020 Chevy Colorado Z71 Trail Runner Alternate Toad
16ACE27 is offline   Reply With Quote
Old 01-05-2019, 04:41 PM   #5
Member
 
Kickstand's Avatar
 
Brand: Thor Motor Coach
Model: Outlaw 29H Class C
State: California
Posts: 89
THOR #7010
I guess itís time to call Axxera again. I have the 615BHM.
__________________
Kickstand is offline   Reply With Quote
Old 01-23-2019, 06:03 PM   #6
Member
 
Brand: Thor Motor Coach
Model: ACE 30.3
State: Maryland
Posts: 33
THOR #12424
I actually was just checking their firmware that was supposed to fix where it does not switch back to the rear camera after using a turn signal (there was another long thread about that) and when I re-downloaded the firmware I noticed it was newer than the previous version for that fix. So When I checked the pdf instructions it says "The firmware update will allow your Axxera stereo to return to rear camera
display after using vehicle turn signals.
It also prevents audio playback muting while cameras are displayed. (9/24/2018)"

I have not installed either yet. To be fair, I never installed the previous firmware for returning to rear display because the downloadable version seemed to be older than what my Radio said the current version was. That was 1800502A.

The newest/current version is 180808A.

This is the link: https://mito-oem.com/index.php?route...on/faq&topic=5

I would be curious to know what Stereo and firmware everyone has. I'll be checking mine in a bit.
__________________
sab3864 is offline   Reply With Quote
Old 02-22-2019, 09:15 PM   #7
Member
 
tgsmith4845's Avatar
 
Brand: Thor Motor Coach
Model: ACE 30.4
State: California
Posts: 37
THOR #12011
We have a 2018 ACE 30.4 with an Axxera AVM70 radio. It was really annoying losing radio audio every time I used the turn signal. I just updated to the current firmware from Axxera and it fixed that issue. Now when I use the turn signal, side camera video displays but the radio volume remains unchanged. When I turn the turn signal off, the screen returns to whatever was selected before, radio, rear camera monitor, etc. This saved me from cutting wires to totally disable the side camera “feature”.
Product Firmware Updates
__________________
tgsmith4845 is offline   Reply With Quote
Old 02-22-2019, 09:26 PM   #8
Senior Member
 
The_Breeze's Avatar
 
Brand: Thor Motor Coach
Model: Chateau 31L
State: Florida
Posts: 1,586
THOR #12189
Quote:
Originally Posted by sab3864 View Post
...
The newest/current version is 180808A.

This is the link: https://mito-oem.com/index.php?route...on/faq&topic=5

I would be curious to know what Stereo and firmware everyone has. I'll be checking mine in a bit.
Get a 404 not found for that url. Use TG Smith's.
__________________
The_Breeze is offline   Reply With Quote
Old 02-22-2019, 09:32 PM   #9
Member
 
Brand: Thor Motor Coach
Model: ACE 30.3
State: Maryland
Posts: 33
THOR #12424
Quote:
Originally Posted by TheBreeze View Post
Get a 404 not found for that url. Use TG Smith's.
Interesting, it still works for me. But yes, TGSmith's link is the same firmware. I guess Mito Corporation (my link) makes the Axxera and it was a link to their FAQ about it not switching back to the backup camera after using after using the turn signal.
__________________
sab3864 is offline   Reply With Quote
Old 06-10-2019, 06:16 PM   #10
Member
 
Brand: Thor Motor Coach
State: Alabama
Posts: 32
THOR #14401
Hi how do you keep the 'backup camera' on the screen?
__________________
topd65 is offline   Reply With Quote
Old 06-10-2019, 06:55 PM   #11
Site Team
 
16ACE27's Avatar
 
Brand: Thor Motor Coach
Model: ACE 27.1
State: Florida
Posts: 5,163
THOR #7035
Quote:
Originally Posted by topd65 View Post
Hi how do you keep the 'backup camera' on the screen?
Depends on what radio you have. Mine has a "Mode" button that if pressed and held switches to camera view.
__________________
Ted & Melinda
2016 ACE 27.1
2016 Chevy Sonic Toad
2020 Chevy Colorado Z71 Trail Runner Alternate Toad
16ACE27 is offline   Reply With Quote
Old 06-10-2019, 08:48 PM   #12
Senior Member
 
Brand: Still Looking
Model: Fleetwood Bounder 35P
State: Florida
Posts: 475
THOR #15054
Quote:
Originally Posted by Darrenc75 View Post
Hi. I recently purchased a new 2018 Thor hurricane class a.
It has a axxia radio that also houses the back up camera and side cameras.

When I turn on the blinkers the radio stops. Super annoying.

Anyone have a fix for this?
We just purchased a 2019 Vegas 24.1. It has the Axxera AVM82NAV model head unit, which exhibited the exact same (super-annoying) "feature". I do not know if the "workaround" that I did will work for you with your model or not, but here's what I did, based upon several others who preceded me.

There is an orange wire running into the back of the head unit. On mine, it is tagged with a label that says "BACK VIEW CONTROL". According to the others, this is known as the "trigger wire"; it is what tells the head unit that the turn signal has been activated so that it cans switch the screen to the side camera (and, mute the sound). It also tells the head unit when the transmission has been shifted into REVERSE, so it will switch to the rear camera view. If this wire is clipped, there will be no trigger.

What happens when you do this clip?

1. The rear camera must be turned on manually. In mine, it's two button pushes. (Home, Rear Camera)
2. If the radio is displaying the rear camera, turning on a turn signal will switch to the appropriate side camera WITHOUT muting the radio. When the turn signal is cancelled, the screen will return to the rear camera.

Pretty simple fix, at least in my Vegas.

One small thing I did, again based on someone else's experience: Instead of leaving a cut wire behind the head unit, I installed a $5 on/off switch. This way, if you want to return to the original state, you simply flip the switch.

Hope this helps with your issue!

t

__________________
TimmyB is offline   Reply With Quote
Old 06-10-2019, 10:08 PM   #13
Senior Member
 
Brand: Thor Motor Coach
Model: 2016 Thor Outlaw 29H
State: Tennessee
Posts: 458
THOR #13869
I don't know that the radio going off when a turn signal is activated is annoying, because ours, the radio stays on when you make the turn signal and same side camera comes on.

My annoyance is, the radio is usually a bit louder, tuned that way to bay the road noise, while traveling.
Then slowing down, with the turn signal & appropriate camera on the display, all radio volume controls do not work until the camera view is off the screen!

I find it annoying I cannot lower the radio volume, then after turning signal off, waiting for the camera view to cease, before I can reduce the volume, at the same time feeling obligated to have the proper turn signal blinking while waiting on traffic.

Anyone else's work this way too?
__________________
.....
Rusty
10scDust is offline   Reply With Quote
Old 06-10-2019, 10:53 PM   #14
Senior Member
 
Brand: Thor Motor Coach
Model: Hurricane 31S
State: Texas
Posts: 2,241
THOR #6411
Quote:
Originally Posted by Darrenc75 View Post
Hi. I recently purchased a new 2018 Thor hurricane class a.
It has a axxia radio that also houses the back up camera and side cameras.

When I turn on the blinkers the radio stops. Super annoying.

Anyone have a fix for this?
Back when Thor MC started installing Axxera radio, the rear view camera had a microphone install in it. Mine has. Any time you selected any camera, the mute function on the radio is muted and the rear microphone turned on. With the radio on, you could not hear the rear mike. Axxera offers a radio computer update that deleted the change in volume. It works for some. You can always snip the camera power wire to the camera selector box beside the radio.
__________________
Jim & Roy Davis
2016 Hurricane 31S
1961 Rampside in tow
Beau388 is offline   Reply With Quote
Old 03-14-2020, 09:46 PM   #15
Junior Member
 
Brand: Thor Motor Coach
State: Nevada
Posts: 1
THOR #18305
Does anybody have the actual AVM70.zip file they could send me? The one on Axxera's web site is empty. All the other update files seem ok but that one doesnt work.

Thanks to anyone who could help!

Mike
__________________
N7tnh is offline   Reply With Quote
Old 07-05-2020, 09:09 PM   #16
Junior Member
 
Brand: Thor Motor Coach
Model: Windsport
State: New York
Posts: 1
THOR #19493
Looking also

I am also looking for that firmware. Every download is empty. Just purchased our RV. Please let me know if you have found a valid file! Thanks.
__________________
KatBiss is offline   Reply With Quote
Old 10-18-2020, 08:13 PM   #17
Junior Member
 
Brand: Thor Motor Coach
Model: 36mq
State: Iowa
Posts: 8
THOR #5669
What link did you use to find the firmware? I have not had luck finding it.

Thank you.
__________________
gdubbs is offline   Reply With Quote
Old 10-18-2020, 08:14 PM   #18
Junior Member
 
Brand: Thor Motor Coach
Model: 36mq
State: Iowa
Posts: 8
THOR #5669
I have the same problem. If you get it can you reach out to me, too?
__________________
gdubbs is offline   Reply With Quote
Old 10-19-2020, 01:03 AM   #19
Junior Member
 
Brand: Thor Motor Coach
State: Pennsylvania
Posts: 4
THOR #20939
I just replaced my 2 under the step batteries...the one flaw is now my Jensen radio/clock/camera will only come on when I am in "Use" mode. I cannot find a fuse. It does not make sense to not be able to independently drive without using these batteries. It worked prior...that is why I am thinking fuse. Nothing under the fridge or the "P" fuses are directly int the circuit board...and I have no fuses under the drivers side dash as I have seen some discussions about that. I have the 350 Chasis 2014 Thor Vegas? Any help?
__________________
jgvegas is offline   Reply With Quote
Old 10-19-2020, 01:10 AM   #20
Site Team
 
16ACE27's Avatar
 
Brand: Thor Motor Coach
Model: ACE 27.1
State: Florida
Posts: 5,163
THOR #7035
Quote:
Originally Posted by jgvegas View Post
I just replaced my 2 under the step batteries...the one flaw is now my Jensen radio/clock/camera will only come on when I am in "Use" mode. I cannot find a fuse. It does not make sense to not be able to independently drive without using these batteries. It worked prior...that is why I am thinking fuse. Nothing under the fridge or the "P" fuses are directly int the circuit board...and I have no fuses under the drivers side dash as I have seen some discussions about that. I have the 350 Chasis 2014 Thor Vegas? Any help?
If it worked before it was broken then. Now it works like all the other Thor coaches, off the house batteries with the USE/STORE switch in USE.

Why would you put it in STORE when you are in the RV? The fridge won't work either unless the switch is in USE, neither will the house lights.
__________________

__________________
Ted & Melinda
2016 ACE 27.1
2016 Chevy Sonic Toad
2020 Chevy Colorado Z71 Trail Runner Alternate Toad
16ACE27 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Thor Industries or any of its affiliates. This is an independent, unofficial site.




All times are GMT. The time now is 02:09 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0 PL2
×