Journey with Confidence RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Take a Speed Test Free 7 Day Trial ×
 

Go Back   Thor Forums > Thor Tech Forums > Maintenance and Repair
Click Here to Login
Reply
 
Thread Tools Display Modes
 
Old 04-21-2024, 07:26 PM   #1
Junior Member
 
Brand: Thor Motor Coach
Model: Thor Venetian A40
State: Florida
Posts: 2
THOR #17201
2018 Venetian LP/Electric 10 gallon water heater

All of sudden the LP side of the water heater is not working. Seems to be that the software switch is not sending 12v to the water heater. I do not get 12v on the white wire but do on the electric side. Cannot find where this is fed from....etc.

__________________
Jeffzeno is offline   Reply With Quote
Old 04-21-2024, 10:18 PM   #2
Senior Member
 
Brand: Thor Motor Coach
Model: Aria 3901
State: Idaho
Posts: 699
THOR #9660
I don't know if this is your problem, but it was ours a couple of years ago. There were some bad control boards out of the factory. Somewhere on this site are descriptions of the dates and serial numbers that may have been bad. I called the water heater manufacturer and they sent me a new board. You might to try a call to them. Good luck,
Mike
__________________
Vicki and Mike, Aria 3901- The Wined Up Bus, towing 16 Jeep JKUR.
m1noel is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Thor Industries or any of its affiliates. This is an independent, unofficial site.




All times are GMT. The time now is 05:47 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2024, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0 PL2