Journey with Confidence RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Take a Speed Test Free 7 Day Trial ×
 

Go Back   Thor Forums > Thor Tech Forums > Maintenance and Repair
Click Here to Login
Reply
 
Thread Tools Display Modes
 
Old 07-07-2021, 01:07 AM   #1
Junior Member
 
Brand: Thor Motor Coach
State: Ontario
Posts: 4
THOR #23982
Alternator not charging house batteries

When coach running, it will not charge my house batteries... I've changed the solenoid and still not charging. Anyone ever had this problem?

__________________
Minimart is offline   Reply With Quote
Old 07-07-2021, 01:15 AM   #2
I Think We're Lost!
 
Bob Denman's Avatar
 
Brand: Still Looking
Model: Tiffin Wayfarer 24 BW
State: New York
Posts: 22,099
THOR #8860
First: Welcome to our forum!
Next what year and model RV are we talking about?
__________________
Bob Denman is offline   Reply With Quote
Old 07-07-2021, 01:40 AM   #3
Junior Member
 
Brand: Thor Motor Coach
State: Ontario
Posts: 4
THOR #23982
Sorry should of mentioned that.. It's a 2014 Thor Miramar.
__________________
Minimart is offline   Reply With Quote
Old 07-07-2021, 02:54 AM   #4
Site Team
 
16ACE27's Avatar
 
Brand: Thor Motor Coach
Model: ACE 27.1
State: Florida
Posts: 9,811
THOR #7035
What "solenoid" did you replace?

Do ypu have a BIRD and Trombetta or a BCC system?
__________________
Ted & Melinda
2016 ACE 27.1
2016 Chevy Sonic Toad
2020 Chevy Colorado Z71 Trail Runner Alternate Toad
16ACE27 is offline   Reply With Quote
Old 07-07-2021, 05:19 PM   #5
Junior Member
 
Brand: Thor Motor Coach
State: Ontario
Posts: 4
THOR #23982
Not sure what set-up yet but the solenoid was a trombetta that is situated on the chassis near my 2 6v batteries. When engine is running I do have over 14v on one side of the solenoid but not on the other side. Only have what the house batteries are charged at. Also seems like the inverter is not reading what my voltage is at the batteries
__________________
Minimart is offline   Reply With Quote
Old 07-07-2021, 06:24 PM   #6
Senior Member
 
Brand: Thor Motor Coach
Model: Palazzo 33.2
State: Georgia
Posts: 266
THOR #8078
If your set up is the same as my Palazzo the trombetta solenoid has probably failed. There is a previous string on this forum. https://www.thorforums.com/forums/f8...ent-19308.html

You should start your engine and then check for 12v going to the solenoid/relay from the nearby controlling circuit board. There is a 2-3 minute delay after the engine starts before a signal is sent to the relay to close so that the engine charging system and house battery system are connected together. If 12v gets to the relay, check the relay's ground connection also. If all that works and you do not see 13.5 volts on the house side of the relay, you have another defective relay.
__________________
rudyhehn is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Thor Industries or any of its affiliates. This is an independent, unofficial site.




All times are GMT. The time now is 07:35 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2022, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0 PL2