Free 7 Day Trial RV GPS App RV Trip Planner Campground Reviews RV Maintenance Free 7 Day Trial ×
 

Go Back   Thor Forums > Thor Tech Forums > Maintenance and Repair
Click Here to Login
Reply
 
Thread Tools Display Modes
 
Old 05-23-2021, 01:25 AM   #1
Senior Member
 
Brand: Thor Motor Coach
State: Florida
Posts: 120
THOR #15410
Atwood electric water not working

Electric not working, but gas is. Fuses checked, thermostat replaced, it's f getting power, cause I can hear it him. It was working fine then all of a sudden nothing. Any ideas??

__________________
Connieb is offline   Reply With Quote
Old 05-23-2021, 01:49 AM   #2
Site Team
 
16ACE27's Avatar
 
Brand: Thor Motor Coach
Model: ACE 27.1
State: Florida
Posts: 7,502
THOR #7035
Was the tank full of water? If not, the heating element probably overheated and burnt out. That may be the problem regardless. You said you checked fuses: did you check the 120 VAC breaker for the water heater?
__________________
Ted & Melinda
2016 ACE 27.1
2016 Chevy Sonic Toad
2020 Chevy Colorado Z71 Trail Runner Alternate Toad
16ACE27 is offline   Reply With Quote
Old 05-23-2021, 07:45 PM   #3
Senior Member
 
Model: Newmar Bay Star Sport 300
State: Alabama
Posts: 4,194
THOR #6826
Check for 120V at the heating element terminals. If youíve got it itís pretty safe to bet the element has failed. If not Iíd think about the control circuit board. They fail often enough!
__________________
Pete'sMH is offline   Reply With Quote
Old 06-06-2021, 12:28 AM   #4
Senior Member
 
Brand: Thor Motor Coach
State: Florida
Posts: 120
THOR #15410
Update, this was found when the tech came to fix the water heater after we tried everything and checked everything we could .He had to pull the heater,which I couldn't do. Funny that it didn't blow a breaker. Glad it didn't start a fire.
Click image for larger version

Name:	IMG_20210605_145642796.jpeg
Views:	28
Size:	24.5 KB
ID:	31160
__________________
Connieb is offline   Reply With Quote
Old 06-07-2021, 05:00 PM   #5
Junior Member
 
Brand: Thor Motor Coach
Model: A.C.E. 30.1
State: Florida
Posts: 6
THOR #21412
Looks familiar... Wire nut on neutral wire by chance? Mine burned up the same way.
__________________
mytimeyet is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Thor Industries or any of its affiliates. This is an independent, unofficial site.




All times are GMT. The time now is 05:09 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0 PL2