RV News RVBusiness 2021 Top 10 RVs of the Year, plus 56 additional debuts and must-see units → ×
 

Go Back   Thor Forums > Thor Tech Forums > Maintenance and Repair
Click Here to Login
Reply
 
Thread Tools Display Modes
 
Old 10-12-2016, 01:22 AM   #1
Senior Member
 
Brand: Still Looking
Model: Fleetwood Southwind 37F
State: Texas
Posts: 123
THOR #1793
Question Axxera AV614BH dead, need help

2015 ACE 29.3

The other day I disconnected the house batteries to clean the terminals and compartment.

After connecting the batteries, closing the two breakers in battery compartment, and turning on the USE/STORE switch, I now have a dead radio, cameras, etc. Currently plugged into 30amp service.

I have read many of the other threads. The rear radio works. All fuses under the bed are good. I managed to use the keys and pull the radio out of the dash. The 15amp fuse is good. I pressed the reset button.

Radio still inop. Anyone have any other suggestions?
__________________

__________________
2015 Thor ACE 29.3 (Traded in)
w/'15 Jeep Wrangler Unlimited toad

2019 Fleetwood Southwind 37F
2019 Ford Ranger Lariat toad
GMac is offline   Reply With Quote
Old 10-13-2016, 01:21 AM   #2
Senior Member
 
Brand: Still Looking
Model: Fleetwood Southwind 37F
State: Texas
Posts: 123
THOR #1793
I talked with THOR today.

Fuse on back of radio is good.
Fuse at main control panel (bed) is good.
Fuse at drivers left foot (rear video) is good.
Since I had removed and installed house batteries, there is an inline fuse (yellow wire) also with soleoid for Emerg Start, right behind my two house batteries, that is good.
Power at the plug is of question: the memory wire (Yellow) is 00. But the main power is good 13.5V

Radio still inop.
__________________

__________________
2015 Thor ACE 29.3 (Traded in)
w/'15 Jeep Wrangler Unlimited toad

2019 Fleetwood Southwind 37F
2019 Ford Ranger Lariat toad
GMac is offline   Reply With Quote
Old 10-13-2016, 01:25 AM   #3
Site Team
 
EA37TS's Avatar
 
Brand: Entegra
Model: Accolade 37TS
State: Virginia
Posts: 4,821
THOR #1469
Quote:
Originally Posted by GMac View Post
I talked with THOR today.

Fuse on back of radio is good.
Fuse at main control panel (bed) is good.
Fuse at drivers left foot (rear video) is good.
Since I had removed and installed house batteries, there is an inline fuse (yellow wire) also with soleoid for Emerg Start, right behind my two house batteries, that is good.
Power at the plug is of question: the memory wire (Yellow) is 00. But the main power is good 13.5V

Radio still inop.
Have you hit the reset button? It takes a paperclip to do it and it is located by the eject button.

I lost power once and reset did the trick.
__________________
Dave
US Army (Ret)
2020 Entegra Accolade 37TS
2019 Jeep Grand Cherokee Trailhawk (Toad)
FMCA - F432054
EA37TS is offline   Reply With Quote
Old 10-13-2016, 01:42 AM   #4
Senior Member
 
Brand: Still Looking
Model: Fleetwood Southwind 37F
State: Texas
Posts: 123
THOR #1793
I actually tried a reset button under the USB cover, lower left...no luck.

I just tried the upper left hole by the Eject button, nothing changed.
__________________
2015 Thor ACE 29.3 (Traded in)
w/'15 Jeep Wrangler Unlimited toad

2019 Fleetwood Southwind 37F
2019 Ford Ranger Lariat toad
GMac is offline   Reply With Quote
Old 11-15-2016, 10:46 PM   #5
Senior Member
 
Brand: Still Looking
Model: Fleetwood Southwind 37F
State: Texas
Posts: 123
THOR #1793
Well, a month later and it appears I was the idiot.

A few discussions with Thor chasing every wire and fuse.
Sent radio back to MITO Corp for radio ops check...it's fine. This, even a few months out of warranty. They even offered to upgrade model if it was bad.
Installed a new hot wire for radio from chassis battery, now not required.
Today, beat heads again with Thor. Great support with this issue.

Turns out during original disconnect and connect, dispite my attempt to mark what wire goes where, I managed to connect a positive to a negative terminal.

Oddly enough, the only thing not to work was the radio.

It's amazing once connected correctly, all is working.
__________________
2015 Thor ACE 29.3 (Traded in)
w/'15 Jeep Wrangler Unlimited toad

2019 Fleetwood Southwind 37F
2019 Ford Ranger Lariat toad
GMac is offline   Reply With Quote
Old 11-15-2016, 10:50 PM   #6
Kev
Senior Member
 
Kev's Avatar
 
Brand: Thor Motor Coach
Model: Windsport
State: Florida
Posts: 740
THOR #3918
Radio

Glad to hear Thor was responsive.

Kev
__________________
Kev is offline   Reply With Quote
Old 11-16-2016, 01:15 PM   #7
Senior Member
 
Brand: Thor Motor Coach
Model: Axis 24.1
State: Florida
Posts: 611
THOR #4366
Quote:
Originally Posted by GMac View Post
Well, a month later and it appears I was the idiot.

A few discussions with Thor chasing every wire and fuse.
Sent radio back to MITO Corp for radio ops check...it's fine. This, even a few months out of warranty. They even offered to upgrade model if it was bad.
Installed a new hot wire for radio from chassis battery, now not required.
Today, beat heads again with Thor. Great support with this issue.

Turns out during original disconnect and connect, dispite my attempt to mark what wire goes where, I managed to connect a positive to a negative terminal.

Oddly enough, the only thing not to work was the radio.

It's amazing once connected correctly, all is working.
Glad you got it working. If you had 13 volts at the radio power lead when you hooked a positive to a negative the only that makes sense is you lost ground, negative, to the radio. No wonder it was difficult to find.

FWIW when I was redoing the battery wiring in conjunction with my permanent solar set up I used phasing tape on each battery lead as I removed it. Red tape for positive; and black for negative.
__________________
2016 Axis 24.1 E-450 6 spd tranny
300 watts portable solar.
200 watts solar on the roof.
Wrangler JK dinghy
scrubjaysnest is offline   Reply With Quote
Old 11-16-2016, 07:23 PM   #8
Senior Member
 
Brand: Thor Motor Coach
Model: Axis 24.1
State: Florida
Posts: 611
THOR #4366
Found another reason for the radio to not work. I had pulled the fuse at Trombetta and that killed the radio even though it has a fuse in the distribution panel.
__________________

__________________
2016 Axis 24.1 E-450 6 spd tranny
300 watts portable solar.
200 watts solar on the roof.
Wrangler JK dinghy
scrubjaysnest is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Thor Industries or any of its affiliates. This is an independent, unofficial site.




All times are GMT. The time now is 02:59 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0 PL2
×