Journey with Confidence RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Take a Speed Test Free 7 Day Trial ×
 

Go Back   Thor Forums > Thor Tech Forums > Maintenance and Repair
Click Here to Login
Reply
 
Thread Tools Display Modes
 
Old 08-10-2019, 10:17 PM   #21
Member
 
Brand: Thor Motor Coach
Model: Chateau 31W
State: Delaware
Posts: 78
THOR #13591
House batteries MUST be ON for the screen to work. Push in the volume button to turn it on.

__________________
Choxnpinz is offline   Reply With Quote
Old 08-10-2019, 10:38 PM   #22
Senior Member
 
PAtrailtrimmer's Avatar
 
Brand: Thor Motor Coach
Model: Axis 27.7
State: Pennsylvania
Posts: 165
THOR #12085
Quote:
Originally Posted by Choxnpinz View Post
House batteries MUST be ON for the screen to work. Push in the volume button to turn it on.
Exactly right, Also works this way for my Kenwood replace of the Axxera.
__________________
Thor Axis 27.7 towing a hot little Chevy Sonic
SE PA
PAtrailtrimmer is offline   Reply With Quote
Old 08-10-2019, 11:15 PM   #23
Junior Member
 
Mckro05's Avatar
 
Brand: Thor Motor Coach
Model: Hurricane 29M
State: British Columbia
Posts: 22
THOR #10751
The wiring harness may be loose. Had the same problem, pulled the deck, pushed in the harness and it worked.... pushed the deck back in and boom, stopped working. Fiddled a bit more, added some zapstraps and worked.
__________________
Mckro05 is offline   Reply With Quote
Old 08-10-2019, 11:38 PM   #24
Junior Member
 
Brand: Thor Motor Coach
Model: Quantum WS31
State: Florida
Posts: 10
THOR #11466
My Axxera also stopped working intermittently during warranty. Dealer never found anything wrong. At 1.5 years, it died completely. Replaced with Panasonic AVH4400NEX.
Obviously Axxera is junk, just like the Seiki TV's. My 2017 Quantum WS31 is falling apart.
__________________
GilTphoto is offline   Reply With Quote
Old 08-11-2019, 11:17 AM   #25
Junior Member
 
Brand: Thor Motor Coach
State: Florida
Posts: 8
THOR #16003
The Bobo

Hi,
We are new to this.our very 1st trip right now from Ft Myers Florida to the west coast.
We bought ours from Camping World,they never gave us much of an explanation on using our Axis.
We could not get ours to work either....then we found out about the store/use button at the bottom of the stairs
We pressed the use button and that fixed our problem
Good luck
__________________
The bobo is offline   Reply With Quote
Old 08-12-2019, 04:45 PM   #26
Member
 
BattleBorn1's Avatar
 
Brand: Thor Motor Coach
Model: Windsport 29M
State: Nevada
Posts: 69
THOR #11264
Axxera

JK,

We had a similar issue with our 29M. My unit was dead until I found the GFI in the bathroom was popped. I reset it and we had power to the Axxera. I have a hard time understanding how this is but now that I know how to fix it if it happens again, Iíll leave it alone.
Hope this helps
Brett
__________________
BattleBorn1 is offline   Reply With Quote
Old 08-12-2019, 05:22 PM   #27
Site Team
 
16ACE27's Avatar
 
Brand: Thor Motor Coach
Model: ACE 27.1
State: Florida
Posts: 12,731
THOR #7035
Quote:
Originally Posted by BattleBorn1 View Post
JK,

We had a similar issue with our 29M. My unit was dead until I found the GFI in the bathroom was popped. I reset it and we had power to the Axxera. I have a hard time understanding how this is but now that I know how to fix it if it happens again, Iíll leave it alone.
Hope this helps
Brett
GFI should have nothing to do with 12 VDC to the radio.
__________________
Ted & Melinda
2016 ACE 27.1
2016 Chevy Sonic Toad
2020 Chevy Colorado Z71 Trail Runner Alternate Toad
16ACE27 is offline   Reply With Quote
Old 08-12-2019, 06:09 PM   #28
Member
 
BattleBorn1's Avatar
 
Brand: Thor Motor Coach
Model: Windsport 29M
State: Nevada
Posts: 69
THOR #11264
Totally understand my friend, just relaying our experience. When totally exasperated, try the unexpected and you might get lucky.

One way to tell would be to pop the GFI and check your Axxera.
__________________
BattleBorn1 is offline   Reply With Quote
Old 08-29-2019, 04:55 PM   #29
Junior Member
 
Brand: Thor Motor Coach
State: Florida
Posts: 12
THOR #13966
That worked for us too.
Jeff
__________________
Strait331 is offline   Reply With Quote
Old 08-31-2019, 03:12 PM   #30
Member
 
Brand: Thor Motor Coach
Model: Four Winds
State: Arizona
Posts: 35
THOR #12097
I'll add our experience we had with our Axxera AVM70 just this past week. While driving, we plugged a thumb drive into the USB port to play our music as we have done several times before. Only this time, the entire unit froze up. None of the touch screen buttons would worked, the volume control didn't work, the home button didn't work. The ON-OFF push button didn't work. Nothing! Heck, I couldn't even turn it off from the coach's main power switch. I had to remove the negative battery cable from the coach battery to get it to turn off. We tried several times and with 2 different thumb drives. Same results. I guess I'll be changing mine out too.
__________________
RCouch is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Thor Industries or any of its affiliates. This is an independent, unofficial site.




All times are GMT. The time now is 01:00 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2023, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0 PL2