RV News RVBusiness 2021 Top 10 RVs of the Year, plus 56 additional debuts and must-see units → ×
 

Go Back   Thor Forums > Thor Tech Forums > Maintenance and Repair
Click Here to Login
Reply
 
Thread Tools Display Modes
 
Old 02-05-2016, 08:09 PM   #1
Senior Member
 
Brand: Still Looking
Model: Fleetwood Southwind 37F
State: Texas
Posts: 123
THOR #1793
Furnace issue/concern

I've been camping since Tues night. Woke up Weds to mid 30's. I obviously didn't freeze thru the night. I noticed that my furnace was not blowing heat. I could hear it trying to light off and "roar" for only about 2-3 seconds, then blower only. It would attempt light off often.
I called Atwood and a local RV service center. Tech was helpful with possible ideas. My tank is slightly more than half full. I ran my fridge on gas only to test gas supply. All seem fine.
The odd "good" issue is that the furnace has run fine the last two nights.
Anyone else experience similar hiccups?
__________________

__________________
GMac is offline   Reply With Quote
Old 02-05-2016, 08:54 PM   #2
Senior Member
 
Oneilkeys's Avatar
 
Brand: Still Looking
Model: Travato
State: Florida
Posts: 2,435
THOR #1765
Quote:
Originally Posted by GMac View Post
I've been camping since Tues night. Woke up Weds to mid 30's. I obviously didn't freeze thru the night. I noticed that my furnace was not blowing heat. I could hear it trying to light off and "roar" for only about 2-3 seconds, then blower only. It would attempt light off often.
I called Atwood and a local RV service center. Tech was helpful with possible ideas. My tank is slightly more than half full. I ran my fridge on gas only to test gas supply. All seem fine.
The odd "good" issue is that the furnace has run fine the last two nights.
Anyone else experience similar hiccups?
Sure sounds like the gas supply. Before I try to run anything hooked up to gas, I turn on and light the stove with a butane lighter and let it run for a while to make sure that the gas lines don't have any air in them. If your fridge ran fine, it sounds like gas was getting past the stove ok. Was it really windy? If everything is still running fine, it may be you had a small piece of dirt or something in the line that worked itself out..
__________________

__________________
Oneilkeys is offline   Reply With Quote
Old 02-05-2016, 09:02 PM   #3
Senior Member
 
Brand: Still Looking
Model: Fleetwood Southwind 37F
State: Texas
Posts: 123
THOR #1793
No, breezy but not windy. I'm hoping it's all good from here out.
__________________
2015 Thor ACE 29.3 (Traded in)
w/'15 Jeep Wrangler Unlimited toad

2019 Fleetwood Southwind 37F
2019 Ford Ranger Lariat toad
GMac is offline   Reply With Quote
Old 02-05-2016, 11:42 PM   #4
Junior Member
 
Brand: Thor Motor Coach
Model: Vegas 24.1
State: Tennessee
Posts: 2
THOR #3507
I had a similar sounding issue recently. Our furnace worked fine on several different days, but one day it was unable to light, cycling on/off repeatedly. I lit the stove and let that burn a while, and the furnace began working. Maybe a coincidence, but the problem hasn't reoccurred. The day before the problem happened, I'd run the furnace for a couple of hours straight.
__________________
ergonaught is offline   Reply With Quote
Old 02-15-2016, 06:37 AM   #5
Member
 
Brand: Thor Motor Coach
Model: Outlaw 29h
State: Missouri
Posts: 47
THOR #980
Sounds like air in the gas line. Do as suggested above, light the stove, make sure to purge the line. You may have to try a few times but the furnace should light.
__________________
BILL (PM ret US Postal Svc) 41 yrs
USA, Vet. 549th MP Co (US Terr. Canal Zone, Panama)
Owner: 2015 Thor 29h Outlaw (Class C)
Towed: 2013 Jeep Wrangler
Toy hauling: BMW F700 GS & G650 GS (Sertao)
MrZip is offline   Reply With Quote
Old 02-15-2016, 01:28 PM   #6
Junior Member
 
Brand: Thor Motor Coach
State: North Carolina
Posts: 22
THOR #2107
Furnace issue

Hi. Had the same issue while camping in cold weather last week. I picked up a two stage regulator for $40 at a local hardware store and replaced the original. Problem solved. 30.2 ACE.

I'm still under warranty, so I'll ask Thor to reimburse me or send a new regulator as a spare. They are good about sending parts.

Regards.
__________________

__________________
tnrambler is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Thor Industries or any of its affiliates. This is an independent, unofficial site.




All times are GMT. The time now is 08:58 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0 PL2
×