Go Back   Thor Forums > Thor Tech Forums > Maintenance and Repair
Click Here to Login
Reply
 
Thread Tools Display Modes
 
Old 01-08-2020, 05:33 PM   #1
Senior Member
 
Brand: Thor Motor Coach
Model: 2017 Thor Vegas 25.2
State: Indiana
Posts: 295
THOR #7993
Generator switch does nothing.

I've run the generator dozens of times, at least an hour a month since I got this Vegas 25.2 2017. Never had a problem. I tried to start it today and nothing, not even a sound. The priming light comes on but no cranking. The house batteries are good. The Use/Store switch is in use (I know that's working because the 12v lights come on. It won't even start with the chassis engine running. Is there a circuit breaker or fuse that I need to check. Thanks for any info.
__________________

__________________
jb1911 is offline   Reply With Quote
Old 01-08-2020, 06:44 PM   #2
I Think We're Lost!
 
Bob Denman's Avatar
 
Brand: Still Looking
Model: Tiffin Wayfarer 24 BW
State: New York
Posts: 12,647
THOR #8860
Perhaps a loose cable to the starter?
__________________

__________________
Good Sam Member 843599689
FMCA Member F473304
Current coach: Tiffin Wayfarer 24 BW
"History shows again and again; how Nature points
out the folly of man..."
Bob Denman is offline   Reply With Quote
Old 01-08-2020, 07:02 PM   #3
Senior Member
 
Brand: Keystone
Model: Sprinter
State: Florida
Posts: 524
THOR #15553
I would start with a volt meter on the battery, at the on/off switch, at the starter solenoid.
__________________
2011 Keystone Sprinter 323BHS. Retired Master Electrician. All Motor Homes are RV's. All RV's are not Motor Homes.
cavie is offline   Reply With Quote
Old 01-08-2020, 07:33 PM   #4
Site Team
 
16ACE27's Avatar
 
Brand: Thor Motor Coach
Model: ACE 27.1
State: Florida
Posts: 3,519
THOR #7035
Did you try starting it from the switch at the generator?
__________________
Ted & Melinda
2016 ACE 27.1
2016 Chevy Sonic Toad
16ACE27 is offline   Reply With Quote
Old 01-08-2020, 09:52 PM   #5
Senior Member
 
Brand: Thor Motor Coach
Model: Newmar Bay Star Sport 300
State: Alabama
Posts: 1,828
THOR #6826
Is your fuel tank above the cutoff level (about 1/4 tank)? Also, check the generator oil level. Either too high or two low will shut it down.
__________________
Pete'sMH is offline   Reply With Quote
Old 01-08-2020, 10:59 PM   #6
Member
 
Brand: Thor Motor Coach
State: Georgia
Posts: 91
THOR #11774
Quote:
Originally Posted by jb1911 View Post
I've run the generator dozens of times, at least an hour a month since I got this Vegas 25.2 2017. Never had a problem. I tried to start it today and nothing, not even a sound. The priming light comes on but no cranking. The house batteries are good. The Use/Store switch is in use (I know that's working because the 12v lights come on. It won't even start with the chassis engine running. Is there a circuit breaker or fuse that I need to check. Thanks for any info.


Two initial things I would check:
- be sure fuel is at least 25%
- there should be one (or two) breakers on the generator ... try resetting them.
__________________
dave.irwin.59@gmail.com is offline   Reply With Quote
Old 01-08-2020, 11:04 PM   #7
I Think We're Lost!
 
Bob Denman's Avatar
 
Brand: Still Looking
Model: Tiffin Wayfarer 24 BW
State: New York
Posts: 12,647
THOR #8860
I think that it would still turn over: even if the fuel level was too low for it to get any...
__________________
Good Sam Member 843599689
FMCA Member F473304
Current coach: Tiffin Wayfarer 24 BW
"History shows again and again; how Nature points
out the folly of man..."
Bob Denman is offline   Reply With Quote
Old 01-08-2020, 11:11 PM   #8
Senior Member
 
Brand: Thor Motor Coach
Model: Newmar Bay Star Sport 300
State: Alabama
Posts: 1,828
THOR #6826
Quote:
Originally Posted by Bob Denman View Post
I think that it would still turn over: even if the fuel level was too low for it to get any...


I suppose itís just a fuel tank tap on the side of the tank. I was thinking it might be a switch on the computer but of course thatís way too complicated! I guess Iíd look for lose wires on the starter
__________________
Pete'sMH is offline   Reply With Quote
Old 01-08-2020, 11:26 PM   #9
Site Team
 
16ACE27's Avatar
 
Brand: Thor Motor Coach
Model: ACE 27.1
State: Florida
Posts: 3,519
THOR #7035
Quote:
Originally Posted by dave.irwin.59@gmail.com View Post
Two initial things I would check:
- be sure fuel is at least 25%
- there should be one (or two) breakers on the generator ... try resetting them.
Neither of these would cause the OP's symptom of "tried to start it today and nothing, not even a sound. The priming light comes on but no cranking."
__________________
Ted & Melinda
2016 ACE 27.1
2016 Chevy Sonic Toad
16ACE27 is offline   Reply With Quote
Old 01-08-2020, 11:30 PM   #10
Member
 
Brand: Thor Motor Coach
State: Georgia
Posts: 91
THOR #11774
Quote:
Originally Posted by Bob Denman View Post
I think that it would still turn over: even if the fuel level was too low for it to get any...


Ya. Your probably right about that.

Breakers maybe?
__________________
dave.irwin.59@gmail.com is offline   Reply With Quote
Old 01-09-2020, 12:03 AM   #11
Site Team
 
16ACE27's Avatar
 
Brand: Thor Motor Coach
Model: ACE 27.1
State: Florida
Posts: 3,519
THOR #7035
Quote:
Originally Posted by dave.irwin.59@gmail.com View Post
Ya. Your probably right about that.

Breakers maybe?
There is a DC breaker near the batteries that supplies power to the generator for starting which may be tripped, but I don't know if that also supplies the power for the fuel pump priming indication (probably does). The breakers on the generator only affect the AC output.

I suspect there is either a poor connection to the remote switch or a starter solenoid issue.
__________________
Ted & Melinda
2016 ACE 27.1
2016 Chevy Sonic Toad
16ACE27 is offline   Reply With Quote
Old 01-09-2020, 02:59 AM   #12
Senior Member
 
Brand: Keystone
Model: Sprinter
State: Florida
Posts: 524
THOR #15553
Quote:
Originally Posted by Pete'sMH View Post
Is your fuel tank above the cutoff level (about 1/4 tank)? Also, check the generator oil level. Either too high or two low will shut it down.
PO stated " I tried to start it today and nothing, not even a sound. The priming light comes on but no cranking. "
__________________
2011 Keystone Sprinter 323BHS. Retired Master Electrician. All Motor Homes are RV's. All RV's are not Motor Homes.
cavie is offline   Reply With Quote
Old 01-09-2020, 03:52 AM   #13
Senior Member
 
Brand: Thor Motor Coach
Model: 2017 Thor Vegas 25.2
State: Indiana
Posts: 295
THOR #7993
Update: it starts up fine using the switch on the generator. Here's the wierd part. It shuts down using the dash switch, the panel switch and the switch on the generator, but it will only start with the genorator switch. This tells me it's not the switches. I'm thinking it's a fuse ... but where is it?
__________________
jb1911 is offline   Reply With Quote
Old 01-09-2020, 04:09 AM   #14
Site Team
 
16ACE27's Avatar
 
Brand: Thor Motor Coach
Model: ACE 27.1
State: Florida
Posts: 3,519
THOR #7035
I doubt it's a fuse. It's probably the connection where the remote switch wiring harness connects to the generator. This has been a known problem point with corrosion causing this type of problem. Take it apart, clean the connections, put it back together and try it.
__________________
Ted & Melinda
2016 ACE 27.1
2016 Chevy Sonic Toad
16ACE27 is offline   Reply With Quote
Old 01-09-2020, 05:15 AM   #15
Senior Member
 
Brand: Thor Motor Coach
Model: 2017 Thor Vegas 25.2
State: Indiana
Posts: 295
THOR #7993
Quote:
Originally Posted by 16ACE27 View Post
I doubt it's a fuse. It's probably the connection where the remote switch wiring harness connects to the generator. This has been a known problem point with corrosion causing this type of problem. Take it apart, clean the connections, put it back together and try it.
Thanks, I'll check that tomorrow.
__________________
jb1911 is offline   Reply With Quote
Old 01-09-2020, 07:50 PM   #16
Senior Member
 
Brand: Thor Motor Coach
Model: 2017 Thor Vegas 25.2
State: Indiana
Posts: 295
THOR #7993
Quote:
Originally Posted by 16ACE27 View Post
I doubt it's a fuse. It's probably the connection where the remote switch wiring harness connects to the generator. This has been a known problem point with corrosion causing this type of problem. Take it apart, clean the connections, put it back together and try it.
Pulled the connection apart, it looks brand new, no corrosion. I sprayed it with DeOxit anyway. Problem still exists.
__________________
jb1911 is offline   Reply With Quote
Old 01-09-2020, 08:01 PM   #17
Site Team
 
16ACE27's Avatar
 
Brand: Thor Motor Coach
Model: ACE 27.1
State: Florida
Posts: 3,519
THOR #7035
By the chematic below it appears the starter solenoid always has +12 VDC applied and the start switches just complete the circuit by grounding the negative end of the solenoid. Since it works with the local switch it's time to break out the multimeter and jumper wires, start at that remote harness connection and work your way back to the remote switch (es).



This may help as well:

http://gmcws.org/Tech/dsimmons/onan/onan.html
__________________
Ted & Melinda
2016 ACE 27.1
2016 Chevy Sonic Toad
16ACE27 is offline   Reply With Quote
Old 01-09-2020, 08:11 PM   #18
I Think We're Lost!
 
Bob Denman's Avatar
 
Brand: Still Looking
Model: Tiffin Wayfarer 24 BW
State: New York
Posts: 12,647
THOR #8860
It sounds as if you've got a break in the wiring...
__________________
Good Sam Member 843599689
FMCA Member F473304
Current coach: Tiffin Wayfarer 24 BW
"History shows again and again; how Nature points
out the folly of man..."
Bob Denman is offline   Reply With Quote
Old 01-11-2020, 08:19 PM   #19
Senior Member
 
Brand: Thor Motor Coach
Model: 2017 Thor Vegas 25.2
State: Indiana
Posts: 295
THOR #7993
We're frozen in in NW Indiana right now. If I find out what the problems is I will check back in.
__________________
jb1911 is offline   Reply With Quote
Old 01-11-2020, 09:06 PM   #20
Member
 
Brand: Thor Motor Coach
State: Texas
Posts: 30
THOR #16693
I know you said no sound at all, but do you hear a faint click/click/click? Reason I ask is that I've found that ours, using the buttons in the coach, have started taking longer to engage the starter if the batteries are down a bit. Sometimes, after the faint click/click/click, have to hold for 5-10 seconds before it kicks over, while it will hit immediately with the button on the gen or using my Vega app on the phone.
__________________

__________________
David & Danna
2020 Magnitude BH35
Midlothian, TX
cbach is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Thor Industries or any of its affiliates. This is an independent, unofficial site.




All times are GMT. The time now is 06:50 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0 PL2
×