Free 7 Day Trial RV GPS App RV Trip Planner Campground Reviews RV Maintenance Free 7 Day Trial ×
 

Go Back   Thor Forums > Thor Tech Forums > Maintenance and Repair
Click Here to Login
Reply
 
Thread Tools Display Modes
 
Old 04-02-2021, 03:10 AM   #1
Member
 
Brand: Thor Motor Coach
Model: 24HE Freedom Elite
State: California
Posts: 69
THOR #19344
Heater

I have a 2018 Thor 24HE. The Atwood heater does not want to work. When I turn on the heater the fan comes on and sometimes I can hear the heater attempt to fire. Other times it doesn't even try.

I have propane flowing. I have tried lighting the heater while the stove is running and after running the stove with no luck.

I checked the sail switch and it is as clean as a whistle.

Any other ideas?

__________________
Harley97 is offline   Reply With Quote
Old 04-03-2021, 01:15 AM   #2
Senior Member
 
Brand: Still Looking
Model: Newmar Bay Star Sport 300
State: Alabama
Posts: 3,815
THOR #6826
Quote:
Originally Posted by Harley97 View Post
I have a 2018 Thor 24HE. The Atwood heater does not want to work. When I turn on the heater the fan comes on and sometimes I can hear the heater attempt to fire. Other times it doesn't even try.



I have propane flowing. I have tried lighting the heater while the stove is running and after running the stove with no luck.



I checked the sail switch and it is as clean as a whistle.



Any other ideas?


Bummer. Check that the igniter is in the proper position close to the burner. Also make sure the burner tube is clear.
__________________
Pete'sMH is offline   Reply With Quote
Old 04-03-2021, 01:29 PM   #3
Senior Member
 
Brand: Thor Motor Coach
Model: 2013 ACE 30.1
State: Alberta
Posts: 1,274
THOR #2631
Quote:
Originally Posted by Harley97 View Post
I have a 2018 Thor 24HE. The Atwood heater does not want to work. When I turn on the heater the fan comes on and sometimes I can hear the heater attempt to fire. Other times it doesn't even try.

I have propane flowing. I have tried lighting the heater while the stove is running and after running the stove with no luck.

I checked the sail switch and it is as clean as a whistle.

Any other ideas?

Your description of spark attempts sometimes and not at other times sounds like a loose or poor electrical connection in the fan proving circuit of the furnace. Your guess at the sail switch is a good start. The fan starts when there is a call for heat, so the 12vdc is OK and the thermostat is calling for heat OK. The proving circuit “usually”consists of the sail switch in series with the high temp limit switch connecting to the control board. If the proving circuit fails (open/bad connection) no sparking attempt will occur initiated by the control board. Check your proving circuit wiring connections are clean and tight in the furnace. Worst case it might be something strange like a crack in the control board copper trace that opens/fails sometimes and works other times. A multimeter to test the various proving circuit components might come in handy if you visually can’t find the bad connection.
__________________
javelin is offline   Reply With Quote
Old 04-03-2021, 02:04 PM   #4
Site Team
 
16ACE27's Avatar
 
Brand: Thor Motor Coach
Model: ACE 27.1
State: Florida
Posts: 6,433
THOR #7035
Or just a wet, or bad control board.
__________________
Ted & Melinda
2016 ACE 27.1
2016 Chevy Sonic Toad
2020 Chevy Colorado Z71 Trail Runner Alternate Toad
16ACE27 is offline   Reply With Quote
Old 04-03-2021, 02:14 PM   #5
Senior Member
 
Brand: Thor Motor Coach
Model: 2013 ACE 30.1
State: Alberta
Posts: 1,274
THOR #2631
Just a followup comment. If your furnace is sparking several times and not lighting; then after attempting to light several times, but still not lighting; then won’t try sparking again; the control board may be locking out. That might also explain not hearing more sparking sometimes from your description. You need to turn off/down the thermostat below the call for heat threshold for a short time to reset the control board and then it should resume the sparking attempts again when you call for heat again. If this is your situation then you need to check further into the combustion procedure (gas, gas valve opening, smell gas? Spark not igniting gas; flame sensor mis-adjusted etc.). Check the manual for your furnace as it may also have LED trouble codes that will tell you what fault is occurring.
__________________
javelin is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Thor Industries or any of its affiliates. This is an independent, unofficial site.




All times are GMT. The time now is 06:28 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0 PL2