Free 7 Day Trial RV GPS App RV Trip Planner Campground Reviews RV Maintenance Free 7 Day Trial ×
 

Go Back   Thor Forums > Thor Tech Forums > Maintenance and Repair
Click Here to Login
Reply
 
Thread Tools Display Modes
 
Old 05-12-2021, 11:57 PM   #1
Junior Member
 
Brand: Thor Motor Coach
State: South Carolina
Posts: 6
THOR #12502
LCI leveler Jack broken

Greetings. Have 2017 Thor Windsport 31 ft.
Tried to retract jacks. Three retracted. Right rear Jack would not retract.
Lippert LCI auto leveling system. Tried to retract in auto and manual mode. No luck.
Called RV repair. They tried manual override. Didnít work.
They believe seal on Jack is broken. They drained hydraulic fluid from Jack and raised it. They disconnected solenoid from Jack so it would stay up.
On our last leg to Sioux Falls SD. Will stay several weeks and take to a Camping World there.
Why did this happen? We had to replace entire leveler motor last June. Did that have anything to do with the jack breaking? What will have to be done to fix this?
Any advice appreciated.

__________________
Sursavage is offline   Reply With Quote
Old 05-13-2021, 12:47 AM   #2
Site Team
 
16ACE27's Avatar
 
Brand: Thor Motor Coach
Model: ACE 27.1
State: Florida
Posts: 7,502
THOR #7035
I think a bad seal would prevent the jack from raising its corner, not retracting it. I don't think your motor/pump replacement had anything to do with it unless the pump part put metal parts into the system. Maybe the valve for that jack went bad. How did they drain hydraulic fluid from the jack? Crack a hose fitting or override the valve by the allen key operator?
__________________
Ted & Melinda
2016 ACE 27.1
2016 Chevy Sonic Toad
2020 Chevy Colorado Z71 Trail Runner Alternate Toad
16ACE27 is offline   Reply With Quote
Old 05-13-2021, 10:05 PM   #3
Senior Member
 
Brand: Thor Motor Coach
Model: Windsport 27K
State: Ohio
Posts: 225
THOR #989
Curious as what "solenoid" was disconnected to keep the jack up. It's my understanding that there is just one solenoid in the system and that is for the pump motor. I'm thinking they did something for the valve that controls that jack. Please let us know what the final fix is. I'm trying to learn what I can from these posts. Safe travels
__________________
John & Diane is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Thor Industries or any of its affiliates. This is an independent, unofficial site.




All times are GMT. The time now is 04:26 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0 PL2