Free 7 Day Trial RV GPS App RV Trip Planner Campground Reviews RV Maintenance Free 7 Day Trial ×
 

Go Back   Thor Forums > Thor Tech Forums > Maintenance and Repair
Click Here to Login
Reply
 
Thread Tools Display Modes
 
Old 06-22-2021, 05:25 PM   #1
Junior Member
 
Brand: Thor Motor Coach
State: Virginia
Posts: 12
THOR #5529
need help with charging problem

I'm having electrical problems with my 2015 Thor Four Winds 33SW Super C. While I was away the house batteries ran down and I had to replace one. Now I can't get charge voltage to them on shore power or generator. I think there's more going on but it seems that the converter (which is working) output is not getting to the batteries. Here are the symptoms:
1. Shore power (120v). Batteries not seeing charge voltage (batteries at 12.4v). 12v house systems all working. Inverter works. Converter output 13.8v.
2. Shore power off. Batteries at 12.4v. 12v systems not working. Inverter works. Generator starts.
3. Shore pwr off; generator running. 12v systems working. Batteries at 12.4v; not charging. Converter output 13.8v
4. Shore pwr off; chassis engine running. Chassis batteries charging at 14.4v. House batteries charging at 14.0v. 12v house systems not working. Converter output 0v.
I've gone as far as I can go with the pathetic Thor wiring diagrams that I have. I did find a bad inline 50a circuit breaker in the converter output wiring but replacing it didn't help. There is a small black box near the converter that I can't figure out. It has two 6 awg connections and two small wires. It looks like converter voltage appears on one 6 awg side and battery voltage on the other. Nothing ever appears on the two small terminals. I'm thinking this box might be the problem? The fuses all look good.
Any advice would be appreciated.
Gary

__________________
Garyj is offline   Reply With Quote
Old 06-22-2021, 05:52 PM   #2
Site Team
 
16ACE27's Avatar
 
Brand: Thor Motor Coach
Model: ACE 27.1
State: Florida
Posts: 7,523
THOR #7035
That small black box is your latching relay for your USE/STORE (Battery Disconnect) switch. The small wires just have power applied from the battery when you press the USE/STORE switch - +12 VDC in one direction closes the latching relay and connects the house batteries to the DC buss/converter; + 12 VDC in the other direction disconnects the house batteries. There is usually a small (5 amp) inline fuse on one of the smaller wires that may be blown if the latching relay is not operating.
__________________
Ted & Melinda
2016 ACE 27.1
2016 Chevy Sonic Toad
2020 Chevy Colorado Z71 Trail Runner Alternate Toad
16ACE27 is online now   Reply With Quote
Old 06-22-2021, 05:57 PM   #3
Senior Member
 
Brand: Thor Motor Coach
Model: Axis 24.1
State: Connecticut
Posts: 894
THOR #20289
Well, from the symptoms you describe the problem is somewhere between the batteries and the converter. I could speculate a bit but maybe it is better to download Thor's General Schematics file for your coach. It gives electrical, plumbing and other isometric schematics of your specific coach.

You can find it by registering at https://www.thormotorcoach.com/owner-resource/ with your VIN. Then look at the documents available and find the schematics file and then look for the DC schematic.

Mine shows a 50A breaker to the battery then to a heavy switch and then the wire goes to the converter DC in terminal. Instead of a simple on/off switch like mine, yours may have a relay that is actuated by the use/store switch that may be bad. My suspicion is that this relay is in the box you found. There should be heavy DC in and out wires to/from the relay and two light gauge wires from the use/store switch exactly like you describe.

David

David
__________________
DavidEM is offline   Reply With Quote
Old 06-22-2021, 06:59 PM   #4
Junior Member
 
Brand: Thor Motor Coach
State: Virginia
Posts: 12
THOR #5529
Thanks to both of you. Now I'm pretty sure the problem is that Battery Disconnect box. It doesn't seem to be responding at all to the remote switch. I'll pursue that next.
Gary
__________________
Garyj is offline   Reply With Quote
Old 06-24-2021, 12:21 AM   #5
Junior Member
 
Brand: Thor Motor Coach
State: Virginia
Posts: 12
THOR #5529
The remote switch for the battery disconnect was the problem. As soon as I popped the cover off it started to work. Something was binding in the switch!
__________________
Garyj is offline   Reply With Quote
Old 06-24-2021, 12:31 AM   #6
Site Team
 
16ACE27's Avatar
 
Brand: Thor Motor Coach
Model: ACE 27.1
State: Florida
Posts: 7,523
THOR #7035
Quote:
Originally Posted by Garyj View Post
The remote switch for the battery disconnect was the problem. As soon as I popped the cover off it started to work. Something was binding in the switch!
Great! Glad you found the issue and it is now resolved. You should definitely hear the "black box" latching relay move (clunk) when you operate it.
__________________
Ted & Melinda
2016 ACE 27.1
2016 Chevy Sonic Toad
2020 Chevy Colorado Z71 Trail Runner Alternate Toad
16ACE27 is online now   Reply With Quote
Old 06-24-2021, 12:35 AM   #7
Junior Member
 
Brand: Thor Motor Coach
State: Virginia
Posts: 12
THOR #5529
Right. It always bothered me that I didn't hear the relay. Now I'm not sure that switch ever worked! Thanks again for the help.
__________________
Garyj is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Thor Industries or any of its affiliates. This is an independent, unofficial site.




All times are GMT. The time now is 03:34 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0 PL2