Go Back   Thor Forums > Thor Tech Forums > Maintenance and Repair
Click Here to Login
Reply
 
Thread Tools Display Modes
 
Old 03-07-2020, 04:45 AM   #1
Junior Member
 
Brand: Thor Motor Coach
Model: Windsport 34J
State: Colorado
Posts: 2
THOR #18295
New Dometic (Atwood) Furnace not staying lit

Just purchased a new 2020 Windsport 34J. Drove it from TX to CO. Furnace worked great in TX, had fits entering CO, around 4500'. Furnace troubleshooting checks out, good power, good gas in the tank, water heater works, stove works. Sail switch is opening, igniter is igniting, fuel is lighting. Fan comes on with thermostat, ignition occurs, but won't remain lit. Is it the regulator? Is it the elevation (approx. 6000')? is it TX gas mix? I've had 2 previous RVs at elevation with CO propane, without issues.
__________________

__________________
Slo_Rollin' is offline   Reply With Quote
Old 03-07-2020, 06:39 AM   #2
Member
 
OldWEB's Avatar
 
Brand: Thor Motor Coach
Model: Hurricane 33T
State: England
Posts: 82
THOR #16471
Look for the flashing LED

FAULT LED INDICATION LOCKOUT
Internal Circuit Board Failure Steady On, No Flashing
Limit Switch/Airflow Problems 1 Flash With 3-Second Pause
Flame Sense Fault 2 Flashes With 3-Second Pause
Ignition Lockout Fault 3 Flashes With 3-Second Pause (1 hour retry)


Instruction manual may help.
Also if one or more vents are blocked, inhibiting airflow, could cause a shutdown.
__________________

__________________
OldWEB is offline   Reply With Quote
Old 03-07-2020, 10:02 PM   #3
Junior Member
 
Brand: Thor Motor Coach
Model: Miramar 32.2
State: Texas
Posts: 10
THOR #14520
One thing that got us earlier this winter was rust plugging the holes in the burner assembly. Similar symptoms to what you are describing. Had someone take the burner apart and clean the holes out on the assembly.

Repair man said that if it lights, then all the permissive (sail switch, fuel pressure, flame sensor) must all be working. We never saw any error codes while troubleshooting. Repair man was on phone with Atwood for 45 minutes and they couldn’t explain the symptoms. Another repair man said that the burner assembly rusts on the inside due tot the high humidity. Took it apart and the assembly was approx 80% plugged.
__________________
Raeburn2000 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Thor Industries or any of its affiliates. This is an independent, unofficial site.




All times are GMT. The time now is 07:53 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0 PL2
×