Journey with Confidence RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Take a Speed Test Free 7 Day Trial ×
 

Go Back   Thor Forums > Thor Tech Forums > Maintenance and Repair
Click Here to Login
Reply
 
Thread Tools Display Modes
 
Old 05-16-2020, 07:09 PM   #1
Junior Member
 
Brand: Thor Motor Coach
State: Pennsylvania
Posts: 5
THOR #14767
Rear cameras and side cameras

We have a 30.1Thor ACE Rv. Our rear and side cameras as well as radio have stopped working. Any suggestions?

__________________
kvengles is offline   Reply With Quote
Old 05-16-2020, 07:51 PM   #2
Junior Member
 
Brand: Thor Motor Coach
State: Pennsylvania
Posts: 2
THOR #14094
Ours also stopped working. Found that battery was too drained to provide power. Try charging house batteries.
__________________
thepawitts is offline   Reply With Quote
Old 05-16-2020, 08:14 PM   #3
Site Team
 
16ACE27's Avatar
 
Brand: Thor Motor Coach
Model: ACE 27.1
State: Florida
Posts: 9,721
THOR #7035
And put your USE/STORE switch in USE.
__________________
Ted & Melinda
2016 ACE 27.1
2016 Chevy Sonic Toad
2020 Chevy Colorado Z71 Trail Runner Alternate Toad
16ACE27 is offline   Reply With Quote
Old 05-16-2020, 08:41 PM   #4
Junior Member
 
Brand: Thor Motor Coach
State: Pennsylvania
Posts: 5
THOR #14767
Thanks

Thanks weíve tried both those ideas and thatís not the problem.
__________________
kvengles is offline   Reply With Quote
Old 05-16-2020, 08:44 PM   #5
Senior Member
 
Popfla's Avatar
 
Brand: Still Looking
Model: S.O.B.
State: Florida
Posts: 684
THOR #14543
Check the border of your radio for a reset button. It will be VERY small. I needed to use a flashlight to find mine. Press the button with a toothpick or similar item for a few seconds, then try the power button. Picture shows where it is on my radio.

And.....WELCOME to the forum!
Attached Thumbnails
Click image for larger version

Name:	AVM80_0-500x500.jpg
Views:	122
Size:	79.9 KB
ID:	23764  
__________________
Ed
Some Other Brand w/2020 Jeep Gladiator Toad
Living The Dream in "God's Waiting Room"
Popfla is offline   Reply With Quote
Old 05-16-2020, 09:40 PM   #6
Site Team
 
16ACE27's Avatar
 
Brand: Thor Motor Coach
Model: ACE 27.1
State: Florida
Posts: 9,721
THOR #7035
If the reset doesn't work then check for an inline fuse to the radio and for 12 VDC to the input power of the radio. If you have 12 VDC going to the radio and it won't turn on then replace the radio.
__________________
Ted & Melinda
2016 ACE 27.1
2016 Chevy Sonic Toad
2020 Chevy Colorado Z71 Trail Runner Alternate Toad
16ACE27 is offline   Reply With Quote
Old 05-17-2020, 02:29 AM   #7
Senior Member
 
Brand: Thor Motor Coach
Model: Daybreak 22GOC
State: Kansas
Posts: 122
THOR #18675
on my 2020 Thor Daybreak 22goc the rear view camera gets interference whenever my grandson starts streaming with his iphone. This doesn't happen with Andriod phones.
JimC
__________________
JimC is offline   Reply With Quote
Old 05-18-2020, 02:04 PM   #8
Junior Member
 
Brand: Thor Motor Coach
Model: Four Winds
State: Minnesota
Posts: 5
THOR #10332
Our screen went dark, but if you scroll through the sources with left side hard button, you can get sound from radio. I tried reset button and pulled radio out to check fuse, and screen would not come back. After some communication with Axxera, I was told unit was shot. (as stated on this forum many times previously, Axxera is junk)
I replaced it with a new Kenwood unit and it works great! Sounds a lot better too!
__________________
Irishacres is offline   Reply With Quote
Old 05-18-2020, 02:24 PM   #9
Junior Member
 
Brand: Thor Motor Coach
State: Pennsylvania
Posts: 5
THOR #14767
rear and side cameras

Thanks everyone. We have tried all suggestions. Nothing works. Since the cameras are involved with the radio, I guess we need to take it in for service somewhere. Again, thanks everyone.
__________________
kvengles is offline   Reply With Quote
Old 05-20-2020, 08:31 PM   #10
Senior Member
 
Brand: Thor Motor Coach
Model: 2019 Freedom Elite 30FE
State: New York
Posts: 178
THOR #16600
This weekend the radio turned off the speakers and the rear view stopped working. Could not figure it out. We returned the radio to default. Everything works now.
__________________
raffaelli is offline   Reply With Quote
Old 05-23-2020, 02:28 PM   #11
Junior Member
 
Brand: Thor Motor Coach
State: Pennsylvania
Posts: 5
THOR #14767
rear and side cameras

We were wondering where was the fuse for the Axxera radio? Maybe that's our problem with the radio and cameras not working. We just can't find this fuse. Thanks.
__________________
kvengles is offline   Reply With Quote
Old 05-23-2020, 03:07 PM   #12
Senior Member
 
Brand: Thor Motor Coach
Model: Hurricane 31S
State: Texas
Posts: 3,483
THOR #6411
Quote:
Originally Posted by kvengles View Post
We were wondering where was the fuse for the Axxera radio? Maybe that's our problem with the radio and cameras not working. We just can't find this fuse. Thanks.
Two fuses for the front radio. The power fuse is in the electrical power center and powers both radios. The forward radio's memory power fuse is behind the radio in most cases but can also be in the aux electrical panel down by the drivers left foot.
__________________
Jim & Roy Davis
2016 Hurricane 31S
1961 Rampside in tow
Beau388 is offline   Reply With Quote
Old 05-26-2020, 01:32 PM   #13
Junior Member
 
Brand: Thor Motor Coach
State: Pennsylvania
Posts: 5
THOR #14767
rear and side cameras

Thanks for your help. This still did not help the problem. Radio in both front and rear of RV have no power, therefore back camera and side cameras do not work. Again, thanks.
__________________
kvengles is offline   Reply With Quote
Old 05-27-2020, 06:19 PM   #14
Junior Member
 
Brand: Thor Motor Coach
Model: Outlaw 37LS
State: Nebraska
Posts: 7
THOR #1630
crappy wire connections

I had similar problems with my outlaw frmo time to time.

It ended up being the wiring connections behind the radio.

Thor buildrer (also known as clueless monkeys, who give monkeys a bad name) use simple butt connectors, and did not ensure that they were crimped properly. I cut off off the connector and soldered the wires.

once I did that everything was perfect from then on.

BUT, I got sick of using the radio for all of the cameras didn't like that I could only view 1 at a time.

I recently installed a couple 7" LED monitors ($25 each from amazon) on the dash on either side of the gauge cluster. I wired them in to the cameras for each of the side mirrors.

Remember that the video from the rear view, and mirror cams goes into a control box, and then just a single video feed is sent to the radio.

I spliced into the feeds going from the mirror cams into the distribution box to also send the signal to the displays.

Then, since I was doing all that wiring & soldering, I decided to also splice another feed from the rear camera wiring. I then took the rear cam feed, as well as the output from the distribution box (all 3 video feeds controlled by the turn signals) and ran those 2 feeds through a simple 3 way switch, and then in to the video input on the radio.

This allows me to control what I want to view on the radio - rear only, or all 3 cams as it came from the factory. (i..e rear default, and then a mirror cam when the turn signal is activated)


Hope this made sense.
__________________
Terminex is offline   Reply With Quote
Old 05-27-2020, 06:21 PM   #15
Junior Member
 
Mckro05's Avatar
 
Brand: Thor Motor Coach
Model: Hurricane 29M
State: British Columbia
Posts: 22
THOR #10751
I had the same issue. I pulled the stereo out and found the wiring harness was loose. Pushed it back in, all works... drove a couple hundred miles and it stopped again. Pulled the stereo tightened and taped it up and no issues since! Good luck!
__________________
Mckro05 is offline   Reply With Quote
Old 05-27-2020, 07:02 PM   #16
Junior Member
 
Brand: Thor Motor Coach
State: Florida
Posts: 7
THOR #11672
Radio and Back up and Mirrors Not Working

These is a tiny, tiny and I mean tiny hole which is a reset. Use a toothpick and push in. I had the same problem.
__________________
Leadgator is offline   Reply With Quote
Old 05-27-2020, 08:45 PM   #17
Member
 
Brand: Thor Motor Coach
Model: Axis 24.1
State: Florida
Posts: 58
THOR #4064
I had same problem. Radio completely. I checked and it had power going to it. I actually found that Advanced Auto sold the exact radio for $79. It only took two min to do the swap. At first it would say no camera found when I selected camera. I had to go into another menu and activate the camera. One thing the new one does that the old didnt is I can leave the rear camera selected and it stays on. With the other one if I used a turn signal it would revert to radio mode after the turn. I tow a boat and like to keep an eye on it going down the road. I can also see the guy tailgating so close the he is not in my mirror
__________________
flrockytop is offline   Reply With Quote
Old 05-27-2020, 09:22 PM   #18
Junior Member
 
Brand: Thor Motor Coach
Model: Chateau Super C 35SF
State: Kansas
Posts: 21
THOR #11472
Quote:
Originally Posted by kvengles View Post
Thanks everyone. We have tried all suggestions. Nothing works. Since the cameras are involved with the radio, I guess we need to take it in for service somewhere. Again, thanks everyone.

Is it an Axerra monitor on the dashboard? Ours fizzled around for a year - if we looked at it crosseyed, patted our heads and rubbed our bellies, it might resume working. Then a few months ago, it just went kaput.

We're just going to replace it with a different radio/monitor from a local business that sells electronics.
__________________
KCKim is offline   Reply With Quote
Old 05-27-2020, 10:12 PM   #19
Junior Member
 
Brand: Thor Motor Coach
State: Maine
Posts: 3
THOR #18725
Side &Rear Cameras

I have a 2016 Thor Chateau 31L and had this problem.
There is an inline fuse under the hood of the truck that may need to be replaced. There is either a red or yellow wire going from the battery towards the firewall. I recently replaced mine and it fixed the problem. Also, if you have an Exxera radio it could have had an internal short which means you would have to replace the radio completely which I am doing currently. I'm told the Jensen VX4022A is a direct replacement radio. Hope this helps.
__________________
tpd352 is offline   Reply With Quote
Old 05-27-2020, 10:53 PM   #20
Junior Member
 
Brand: Thor Motor Coach
State: Utah
Posts: 3
THOR #12383
Quote:
Originally Posted by kvengles View Post
Thanks everyone. We have tried all suggestions. Nothing works. Since the cameras are involved with the radio, I guess we need to take it in for service somewhere. Again, thanks everyone.
Had the same thing happen to our Thor 2017 29m Windsport. After a lot of troubleshooting, I was able to see that the connections had loosened. I used a mirror, reached underneath the center of the console (under the stereo) and reconnected the Video cables. There is enough give in the wires to pull the converter down and check all connections. Good luck!!!
__________________
jboucher is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Thor Industries or any of its affiliates. This is an independent, unofficial site.




All times are GMT. The time now is 01:25 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2022, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0 PL2