Go Back   Thor Forums > Thor Tech Forums > Maintenance and Repair
Click Here to Login
Reply
 
Thread Tools Display Modes
 
Old 06-06-2020, 08:49 PM   #1
Junior Member
 
Brand: Thor Motor Coach
State: North Carolina
Posts: 2
THOR #19091
Strange fault

Really happy to get back on the road, first trip this year. Connected the MINI and checked lights. The left rear turn signal was not working. We decided to head off and stopped at the first Pilot, exit 152 I85, and picked up a replacement LED. Fitted it but nothing, no change still no turn signal.

Back home and on checking I discovered there was no voltage at the socket. All the other left turn signals, even the one in the mirror work.

The cables for the rear socket come out of the middle of a harness with no other obvious connection points.

I've made a temporary solution be picking up the signal at the toad connection but where do I look for the "break".
__________________

__________________
Mervyn is offline   Reply With Quote
Old 06-06-2020, 09:21 PM   #2
Site Team
 
16ACE27's Avatar
 
Brand: Thor Motor Coach
Model: ACE 27.1
State: Florida
Posts: 4,362
THOR #7035
What Make, Model and Year is your coach? I assume you are talking about the coach's turn signal? Not the Mini's?
__________________

__________________
Ted & Melinda
2016 ACE 27.1
2016 Chevy Sonic Toad
16ACE27 is online now   Reply With Quote
Old 06-06-2020, 09:25 PM   #3
Senior Member
 
Brand: Thor Motor Coach
Model: Citation
State: Texas
Posts: 288
THOR #8139
Greetings and Welcome

If your trouble is your toad turn signal.
Your temporary fix is from the connector on the Mini or the cable that is on your towbar?

Check under the hood where the cable that was installed and connects to the cars wiring harness.
__________________
abjbrtd is offline   Reply With Quote
Old 06-06-2020, 10:02 PM   #4
I Think We're Lost!
 
Bob Denman's Avatar
 
Brand: Still Looking
Model: Tiffin Wayfarer 24 BW
State: New York
Posts: 14,069
THOR #8860
So if you've got power going in, and none coming out: it's time to unwrap that harness, and start the very tedious process of backtracking that wire..,
Good luck!
__________________
Bob Denman is offline   Reply With Quote
Old 06-07-2020, 12:46 AM   #5
Junior Member
 
Brand: Thor Motor Coach
State: North Carolina
Posts: 2
THOR #19091
Should have added, the RV is a 2012 Tuscany XTE. THE issue is with the Coach left rear turn signal. The turn signal is OK at the front, mirror, side marker, Toad socket but not at the main location. I have tapped the Toad socket to connect to the LED/Bulb and now it works.
__________________
Mervyn is offline   Reply With Quote
Reply

Tags
turn signal

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Thor Industries or any of its affiliates. This is an independent, unofficial site.




All times are GMT. The time now is 01:29 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0 PL2
×