Go Back   Thor Forums > Thor Tech Forums > Maintenance and Repair
Click Here to Login
Reply
 
Thread Tools Display Modes
 
Old 03-13-2017, 10:32 PM   #1
Senior Member
 
Dbadger777's Avatar
 
Brand: Thor Motor Coach
Model: Hurricane 34J
State: Michigan
Posts: 238
THOR #6009
Wipers stopped working.

We were thirty miles from our destination, Myrtle Beach. It's raining and the wipers stop working. Called Total Value RV, they say call Thor. Thor says call Ford. Ford says it's A Thor body problem. Called Thor back, talked to Tom Overton. He gave me the fuse numbers and a "good luck". I can't find cd2 or p6 in the fuse box. I just can't believe they have left me hanging like this.
__________________

__________________
Dbadger777 is offline   Reply With Quote
Old 03-13-2017, 10:39 PM   #2
Senior Member
 
SuperD's Avatar
 
Brand: Thor Motor Coach
Model: 2017 Windsport 29M
State: Indiana
Posts: 3,688
THOR #5196
I would call them back!!!
__________________

__________________
USMC Veteran
FMCA 101070S

Dave & Myra
One day your life will flash before your eyes,
make sure it's worth watching!
SuperD is offline   Reply With Quote
Old 03-13-2017, 10:43 PM   #3
Senior Member
 
Brand: Thor Motor Coach
Model: Challenger LX
State: Colorado
Posts: 122
THOR #3922
Did they flop to the left and hang up? If so it may be a bent wiper frame. We had a similar problem. If you can pull the wipers away from the windshield and they reset, it's not a fuse.
__________________
j37genie is offline   Reply With Quote
Old 03-13-2017, 11:14 PM   #4
Axis/Vegas Enthusiast
 
JamieGeek's Avatar
 
Brand: Thor Motor Coach
Model: Axis 24.1
State: Michigan
Posts: 8,481
THOR #1150
Did you happen to hit the washer button?

Some of the early models the washer motor was defective and would blow the wiper fuse (in my Axis I believe the wiper fuse is in the box under the drivers seat in the outside storage compartment, but I have the RV custom products board instead of the BIRD/Trombetta arrangement). I bet the fuse location is spelled out in Ed's manual.
__________________
2014 Thor Axis 24.1
2018 Chevy Bolt
blog - https://spareelectrons.wordpress.com/
JamieGeek is offline   Reply With Quote
Old 03-13-2017, 11:23 PM   #5
Senior Member
 
Mo_Mike's Avatar
 
Brand: Thor Motor Coach
Model: Vegas 25.2
State: Missouri
Posts: 971
THOR #4687
Quote:
Originally Posted by Dbadger777 View Post
We were thirty miles from our destination, Myrtle Beach. It's raining and the wipers stop working. Called Total Value RV, they say call Thor. Thor says call Ford. Ford says it's A Thor body problem. Called Thor back, talked to Tom Overton. He gave me the fuse numbers and a "good luck". I can't find cd2 or p6 in the fuse box. I just can't believe they have left me hanging like this.
Be sure and post what happened and what the solution is....

Not too confident in the wipers on the VEGAS/AXIS here either. The driver's wiper goes about midway across the drivers view and stops on ours
__________________
Mo_Mike is offline   Reply With Quote
Old 03-14-2017, 12:28 AM   #6
Senior Member
 
Dbadger777's Avatar
 
Brand: Thor Motor Coach
Model: Hurricane 34J
State: Michigan
Posts: 238
THOR #6009
Well it seems there is more going on. The fog lights,and the dash lights are not working. There must be a major short. The dash lights go out when the lights are turned on. I called CW in Myrtle Beach and they say they have not sold or worked on an Axis. Is that possible?
__________________
Dbadger777 is offline   Reply With Quote
Old 03-14-2017, 12:41 AM   #7
Senior Member
 
Brand: Thor Motor Coach
Model: Hurricane 31S
State: Texas
Posts: 1,684
THOR #6411
Had that happen on my Hurricane 31S (F-53 chassis). Lost power to everything Thor installed in the front section: radio windshield wipers mirrors dash lights, map lights, fans, etc. The engine still started and the coach moved and the headlights worked as did the horn. It was the Thor master circuit breaker in the engine compartment that protects the chassis battery. The CB is connected by a #4 battery cable to the battery's positive terminal and is about 10 inches from the battery on the right front frame rail. It supplies power the the front cap fuse panel which, on my coach, is down by the driver's left foot. This CB is identical to the ones in the house battery compartment.
__________________
Jim & Roy Davis
2016 Hurricane 31S
1961 Rampside in tow
Beau388 is offline   Reply With Quote
Old 03-14-2017, 02:08 PM   #8
Senior Member
 
Dbadger777's Avatar
 
Brand: Thor Motor Coach
Model: Hurricane 34J
State: Michigan
Posts: 238
THOR #6009
An update to this problem. We could not get anyone to come help us, short of having it towed at our expense. So we started down the road; flashers on, 20 miles an hour. All of a sudden the wipers start working. But there are still no dash lights when the headlights are on and the fog lights won't work, but the light on the switch is lit indicating that they are on. Down the road the wipers stop again. Back to flashers and 20mph. Another few miles and the wipers start working again. My biggest concern is the feeling of being left high and dry. If there are any Thor reps crusing this site; what an unsafe situation I feel I was put in.
__________________
Dbadger777 is offline   Reply With Quote
Old 03-14-2017, 02:47 PM   #9
Axis/Vegas Enthusiast
 
JamieGeek's Avatar
 
Brand: Thor Motor Coach
Model: Axis 24.1
State: Michigan
Posts: 8,481
THOR #1150
That really sounds like a loose connection to me.
__________________
2014 Thor Axis 24.1
2018 Chevy Bolt
blog - https://spareelectrons.wordpress.com/
JamieGeek is offline   Reply With Quote
Old 03-14-2017, 04:06 PM   #10
Senior Member
 
TurnerFam's Avatar
 
Brand: Thor Motor Coach
Model: Palazzo 33.3 34'bunkhouse
State: Alabama
Posts: 2,063
THOR #4735
yes, it's certainly a grounding issue... otherwise it would not 'come back on'... any mechanic or car shop should be able to solve your problem easily.
__________________
the Turners
'14 Palazzo 33.3 bunkhouse 34' diesel
KingTailgater2 Dish HD, 100w/5a SOLAR, BlueOx
100,000+mi since '14 - US, Alaska, Canada.... formerly Georgia, then NorthCarolina, now Alabama : )
TurnerFam is offline   Reply With Quote
Old 03-16-2017, 08:55 PM   #11
Senior Member
 
Dbadger777's Avatar
 
Brand: Thor Motor Coach
Model: Hurricane 34J
State: Michigan
Posts: 238
THOR #6009
I'm putting this problem to rest for now. It's most likely a grounding issue. Camper World here in Myrtle Beach could not even look at it for three weeks. They recommended a local guy who doesn't work on chassis problems. He recommended a couple of garages, who after learning that they must contact Thor before and during any work on the MH; are finding it hard to get me in.
Bottom line: I crawled in, under,and around everywhere and tightened anything and everything. Everything is working fine now. I can't be certain if I did it or it just dried out.
__________________
Dbadger777 is offline   Reply With Quote
Old 03-30-2017, 08:02 PM   #12
Senior Member
 
Dbadger777's Avatar
 
Brand: Thor Motor Coach
Model: Hurricane 34J
State: Michigan
Posts: 238
THOR #6009
I'm still in Myrtle Beach. CW hasn't been able to look at my Axis. Problem not resolved yet. Thor did send me an electrical schematic. I ran things down to the bus box in the drivers side, front storage box. No loose wires, no blown fuses. Any idea why when I lightly tap on this box; my wipers start working?
Attached Thumbnails
Click image for larger version

Name:	IMG_0693.jpg
Views:	141
Size:	94.5 KB
ID:	4358  
__________________
Dbadger777 is offline   Reply With Quote
Old 03-30-2017, 09:43 PM   #13
Senior Member
 
Brand: Thor Motor Coach
Model: Windsport 31S
State: Florida
Posts: 303
THOR #4443
Quote:
Originally Posted by Dbadger777 View Post
I'm still in Myrtle Beach. CW hasn't been able to look at my Axis. Problem not resolved yet. Thor did send me an electrical schematic. I ran things down to the bus box in the drivers side, front storage box. No loose wires, no blown fuses. Any idea why when I lightly tap on this box; my wipers start working?
Sounds like a loose ground only because it affects other circuits. Start wiggling wires gently to try and isolate the problem.
__________________
penguin is offline   Reply With Quote
Old 03-31-2017, 10:32 AM   #14
Senior Member
 
SuperD's Avatar
 
Brand: Thor Motor Coach
Model: 2017 Windsport 29M
State: Indiana
Posts: 3,688
THOR #5196
That may be a relay for the wipers, when you tap on it you're making a connection. Open it up and see what's inside, might be a plug-in relay that would be easy to replace, auto parts store will probably have it.
__________________
USMC Veteran
FMCA 101070S

Dave & Myra
One day your life will flash before your eyes,
make sure it's worth watching!
SuperD is offline   Reply With Quote
Old 04-02-2017, 10:01 PM   #15
Senior Member
 
Dbadger777's Avatar
 
Brand: Thor Motor Coach
Model: Hurricane 34J
State: Michigan
Posts: 238
THOR #6009
Well I have finally traced the problem down to the exact wire causing the problem. It's the white wire in the green buss. The male spade wasn't engaging and pushed the wire up so that it was just sitting on top, thus the bumping on it sometime worked.
The schematic doesn't designate it as a ground, but that wire completes the circuit that controls; wipers, fog lights, dash lights, and blowers.
Attached Thumbnails
Click image for larger version

Name:	IMG_1971.jpg
Views:	142
Size:	105.1 KB
ID:	4387  
__________________
Dbadger777 is offline   Reply With Quote
Old 04-02-2017, 10:30 PM   #16
Senior Member
 
SuperD's Avatar
 
Brand: Thor Motor Coach
Model: 2017 Windsport 29M
State: Indiana
Posts: 3,688
THOR #5196
Persistence pays off! Glad you found the problem, it would be easy to miss!!!
__________________
USMC Veteran
FMCA 101070S

Dave & Myra
One day your life will flash before your eyes,
make sure it's worth watching!
SuperD is offline   Reply With Quote
Old 04-13-2017, 05:03 AM   #17
Member
 
Brand: Thor Motor Coach
Model: Vegas 25.4
State: Oregon
Posts: 51
THOR #4548
My Wipers Not Working Either

I just got my 2017 Vegas 25.4. Was out in a lot of rain over the weekend and also having wiper problems. Sometimes it staying on for awhile and did about 3 wipes, sometimes more and then it went off again. I was having to push the button one time at a time to clear the water. It wasn't raining all that hard and I managed well enough. So, if I have the same problem can you tell me exactly where you found that white wire? You seemed to say it was in the bay under the drivers side seat? I only have fuse things there, I think.

Any more specific directions would be most appreciated.

Thanks and it's really stupid that the wipers, when working, only clear off the water to about 1/2 way in front on the driver side window. I'm hoping next time I take it in for other issues that need attention they might be able to adjust them to cover more of the windshield.
__________________
karwask is offline   Reply With Quote
Old 04-14-2017, 07:18 AM   #18
Member
 
rjhayes3308's Avatar
 
Brand: Thor Motor Coach
State: Michigan
Posts: 35
THOR #5189
Quote:
Originally Posted by karwask View Post
I just got my 2017 Vegas 25.4. Was out in a lot of rain over the weekend and also having wiper problems. Sometimes it staying on for awhile and did about 3 wipes, sometimes more and then it went off again. I was having to push the button one time at a time to clear the water. It wasn't raining all that hard and I managed well enough. So, if I have the same problem can you tell me exactly where you found that white wire? You seemed to say it was in the bay under the drivers side seat? I only have fuse things there, I think.



Any more specific directions would be most appreciated.



Thanks and it's really stupid that the wipers, when working, only clear off the water to about 1/2 way in front on the driver side window. I'm hoping next time I take it in for other issues that need attention they might be able to adjust them to cover more of the windshield.


Click image for larger version

Name:	IMG_1149.jpg
Views:	73
Size:	85.7 KB
ID:	4580this may help
__________________
rjhayes3308 is offline   Reply With Quote
Old 11-30-2018, 11:23 PM   #19
Junior Member
 
Brand: Thor Motor Coach
State: Louisiana
Posts: 2
THOR #13879
Help windshield wipers wonít work

Driving in rain at night nowhere to pull over safely and windshield wiper quit working, husband is driving 77 I am 72 and we have handicapped son and two dogs on board. We are coming back from Dallas and trying to get to Baton Rouge where we live. Anyone has suggestions has to how to fix we are headed into some very stormy weather for the remainder of the trip. Desperate here. Found one truck stop guy would not even look at it told us to go to Freightliner in Baton Rouge. Donít what to do hubby looked at fuse and changed nothing happened. Any suggestions
__________________
mcueria@aol.com is offline   Reply With Quote
Old 11-30-2018, 11:25 PM   #20
Junior Member
 
Brand: Thor Motor Coach
State: Louisiana
Posts: 2
THOR #13879
Forgot to say 2018:Thor Aria RV
__________________

__________________
mcueria@aol.com is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Thor Industries or any of its affiliates. This is an independent, unofficial site.




All times are GMT. The time now is 12:26 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0 PL2
×