Thor Forums

Thor Forums (https://www.thorforums.com/forums/)
-   Maintenance and Repair (https://www.thorforums.com/forums/f8/)
-   -   Axxera AV614BH (https://www.thorforums.com/forums/f8/axxera-av614bh-3058.html)

Paladin735 01-21-2016 11:01 PM

Axxera AV614BH
 
I have an Axxera AV614BH in my 2016 Citation Sprinter. It doesn't seem to hold the date/time or updated pre-sets in memory when the unit is shut down for more than 30 seconds. This problem not mentioned in the Troubleshooting section of the manual. Any ideas as to the cause / solution?

West 01-22-2016 01:13 AM

The constant power must be shut off. If your house batteries are off (switch is in store mode) that will cause it to loose its memory. Other than that check fuses. If all else fails pull the radio and check or run a new power wire. There should be two small flat metal bars in with your books that came with your RV that are for removing the radio. They just slip in on both sides of the radio. They will unlatch it and act as handles for you to pull the radio from the dash.

billnagle6900@gmail.com 01-22-2016 01:51 AM

A quick test for power would be to plug something into the dash USB port below the radio. It should always have power from the radio which is powered by the house batteries. If it doesn't and the house batteries are powering everything else, you aren't getting power to the radio.

esugz 09-11-2019 09:13 PM

army
 
does 358th HHC ring a bell


All times are GMT. The time now is 02:02 PM.

Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0 PL2