Thor Forums

Thor Forums (https://www.thorforums.com/forums/)
-   Maintenance and Repair (https://www.thorforums.com/forums/f8/)
-   -   ACE lost engine power and Died (https://www.thorforums.com/forums/f8/ace-lost-engine-power-died-8739.html)

BrianA.C.E 08-10-2017 09:05 PM

ACE lost engine power and Died
 
I have an ACE 30.2 and last week i was traveling on I-10 westbound and had just crossed into Alabama from Florida when it lost power and slowed to a stop on side of I-10. No check engine light at all, i restarted it and it would not idle and died again. i grabbed my code reader and the only codes it had was P-0171 and P-0174 Lean bank one and two. I cleared the codes and tried to start again and it died again with the same two codes. I done what checks i could do in the rain on the side of the interstate and could not find any thing wrong, so i called roadside assistance "thank God i had it" and 6 hrs later a truck shows up " he was busy towing a 40ft DP off Interstate" Truck tows me into Ford dealer in Daphne Alabama. After 7 days at dealer they finally get around to looking into my vehicle and find the MAF Mass Airflow Sensor had gone bad. So V-10 owners put this in your memory bank so if your Rig ever acts like this maybe you can get back on the road yourself without waiting a week and paying for a tow.

Good Luck

JamieGeek 08-10-2017 09:45 PM

Seems to me that is an infrequent issue with all the Triton engines. I don't think the MAF goes bad; it just gets dirty.
https://www.ford-trucks.com/how-tos/...g-power-361582

Travelin' Texans 08-10-2017 10:09 PM

F O R D = found on road dead! Sorry for your troubles, glad you got back on the road. Carry a can of carburetor cleaner to clean it if it happens again.


All times are GMT. The time now is 12:40 PM.

Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0 PL2